|
|
@292929
|
3 years |
ysuzuki |
[JSC] Remove VM& parameter from structure related code including …
|
|
|
@292619
|
3 years |
cdumez |
Reduce number of StringView to String conversions in JSC …
|
|
|
@289359
|
3 years |
ysuzuki |
[JSC] Convert JSString's non-atomic WTF::String to atomic string while …
|
|
|
@278030
|
4 years |
sbarati |
Finalize DFG/FTL code refs on the compiler threads …
|
|
|
@261755
|
5 years |
ross.kirsling |
[IWYU] Remove unnecessary includes from JSC implementation files …
|
|
|
@261464
|
5 years |
ross.kirsling |
[clang-tidy] Run modernize-use-nullptr over JSC …
|
|
|
@260984
|
5 years |
ross.kirsling |
TriState should be an enum class and use "Indeterminate" instead of …
|
|
|
@249706
|
6 years |
ysuzuki |
[JSC] CodeBlock::m_constantRegisters should be guarded by …
|
|
|
@249175
|
6 years |
mark.lam |
Refactor to use VM& instead of VM* at as many places as possible. …
|
|
|
@248185
|
6 years |
ysuzuki |
[JSC] LazyJSValue should be robust for empty JSValue …
|
|
|
@246490
|
6 years |
darin |
Rename AtomicString to AtomString …
|
|
|
@232089
|
7 years |
mark.lam |
StringImpl utf8 conversion should not fail silently. …
|
|
|
@214571
|
8 years |
sbarati |
LinkBuffer and ExecutableAllocator shouldn't have anything to do with …
|
|
|
@211247
|
8 years |
keith_miller |
classInfo should take a VM so it is not materialized from the object …
|
|
|
@207060
|
9 years |
sbarati |
ValueAdd should be constant folded if the operands are constant …
|
|
|
@201470
|
9 years |
fpizlo |
DFG::LazyJSValue::tryGetStringImpl() crashes for empty values …
|
|
|
@197833
|
9 years |
fpizlo |
DFG should be able to constant-fold strings …
|
|
|
@173069
|
11 years |
fpizlo |
FTL should be able to do polymorphic call inlining …
|
|
|
@172961
|
11 years |
commit-queue |
Unreviewed, rolling out r172940. …
|
|
|
@172940
|
11 years |
fpizlo |
FTL should be able to do polymorphic call inlining …
|
|
|
@171613
|
11 years |
fpizlo |
Merge r169795, r169819, r169864, r169902, r169949, r169950, r170016, …
|
|
|
@164229
|
11 years |
ossy |
Move back primary header includes next to config.h …
|
|
|
@163844
|
11 years |
fpizlo |
Rename Operations.h to JSCInlines.h …
|
|
|
@163760
|
11 years |
fpizlo |
Never include *Inlines.h files in interface headers, and never include …
|
|
|
@153308
|
12 years |
ossy |
One more buildfix after FTL upstream.
Return a dummy value after …
|
|
|
@153296
|
12 years |
oliver |
fourthTier: DFG IR dumps should be easier to read …
|
|
|
@153248
|
12 years |
oliver |
fourthTier: DFG should support switch_string …
|
|
|
@153234
|
12 years |
oliver |
fourthTier: DFG should have switch_char …
|