|
|
@261755
|
5 years |
ross.kirsling |
[IWYU] Remove unnecessary includes from JSC implementation files …
|
|
|
@260730
|
5 years |
ysuzuki |
[JSC] ValueAdd, VaueSub, ValueMul, Inc, Dec should say SpecBigInt32 …
|
|
|
@237972
|
7 years |
ticaiolima |
[BigInt] Add support to BigInt into ValueAdd …
|
|
|
@200606
|
9 years |
fpizlo |
Polymorphic operands in operators coerces downstream values to double. …
|
|
|
@200502
|
9 years |
commit-queue |
[JSC] Get rid of NonNegZeroDouble, it is broken …
|
|
|
@194613
|
9 years |
mark.lam |
Profiling should detect when multiplication overflows but does not …
|
|
|
@194423
|
9 years |
mark.lam |
Rename NodeMayOverflowInXXX to NodeMayOverflowInt32InXXX. …
|
|
|
@179840
|
10 years |
fpizlo |
DFG should only have two mechanisms for describing effectfulness of …
|
|
|
@171613
|
11 years |
fpizlo |
Merge r169795, r169819, r169864, r169902, r169949, r169950, r170016, …
|
|
|
@169354
|
11 years |
fpizlo |
Latest emscripten life benchmark is 4x slower because the DFG doesn't …
|
|
|
@167600
|
11 years |
fpizlo |
Take block execution count estimates into account when voting double …
|
|
|
@167325
|
11 years |
fpizlo |
DFG IR should keep the data flow of doubles and int52's separate from …
|
|
|
@165995
|
11 years |
fpizlo |
Crash beneath operationTearOffActivation running this JS compression …
|
|
|
@164229
|
11 years |
ossy |
Move back primary header includes next to config.h …
|
|
|
@163844
|
11 years |
fpizlo |
Rename Operations.h to JSCInlines.h …
|
|
|
@163760
|
11 years |
fpizlo |
Never include *Inlines.h files in interface headers, and never include …
|
|
|
@163027
|
11 years |
msaboff |
Merge the jsCStack branch …
|
|
|
@161126
|
11 years |
fpizlo |
Get rid of DFG forward exiting …
|
|
|
@156984
|
12 years |
fpizlo |
Compress DFG stack layout …
|
|
|
@155497
|
12 years |
fpizlo |
Be explicit about backwards propagation properties that care about …
|
|
|
@153274
|
12 years |
oliver |
fourthTier: DFG should have an SSA form for use by FTL …
|
|
|
@145489
|
12 years |
fpizlo |
DFG overflow check elimination is too smart for its own good …
|
|
|
@145323
|
12 years |
commit-queue |
Unreviewed, rolling out r145299. …
|
|
|
@145299
|
12 years |
fpizlo |
DFG overflow check elimination is too smart for its own good …
|
|
|
@144362
|
12 years |
fpizlo |
It should be easy to determine if a DFG node exits forward or backward …
|
|
|
@143654
|
12 years |
fpizlo |
DFG should not change its mind about what type speculations a node …
|
|
|
@140594
|
12 years |
oliver |
Replace ASSERT_NOT_REACHED with RELEASE_ASSERT_NOT_REACHED in JSC …
|
|
|
@134168
|
13 years |
fpizlo |
DFG should optimize out the NaN check on loads from double arrays if …
|
|
|
@120834
|
13 years |
fpizlo |
DFG should be able to print disassembly interleaved with the IR …
|
|
|
@118325
|
13 years |
fpizlo |
DFG CFA should record if a node can OSR exit …
|
|
|
@112015
|
13 years |
fpizlo |
DFG double voting may be overzealous in the case of variables that end …
|
|
|
@111781
|
13 years |
fpizlo |
DFG NodeFlags has some duplicate code and naming issues …
|
|
|
@111254
|
13 years |
fpizlo |
DFG NodeUse should be called Edge and NodeReferenceBlob should be …
|
|
|
@110498
|
13 years |
fpizlo |
Node::op and Node::flags should be private …
|
|
copied from trunk/Source/JavaScriptCore/dfg/DFGNode.cpp
|
|
|
@110419
|
13 years |
fpizlo |
All DFG nodes should have a mutable set of flags …
|