|
|
@294180
|
3 years |
mark.lam |
Enhance the ARM64Disassembler to print pc indices and better branch …
|
|
|
@291417
|
3 years |
mikhail |
Unreviewed, non-unified build fix …
|
|
|
@261755
|
5 years |
ross.kirsling |
[IWYU] Remove unnecessary includes from JSC implementation files …
|
|
|
@251468
|
6 years |
keith_miller |
BytecodeIndex should be a proper C++ class …
|
|
|
@244811
|
6 years |
sbarati |
CodeBlock::m_instructionCount is wrong …
|
|
|
@244764
|
6 years |
sbarati |
Make JITType an enum class …
|
|
|
@237547
|
7 years |
tzagallo |
New bytecode format for JSC …
|
|
|
@237486
|
7 years |
commit-queue |
Unreviewed, rolling out r237479 and r237484. …
|
|
|
@237479
|
7 years |
tzagallo |
New bytecode format for JSC …
|
|
|
@230748
|
7 years |
mark.lam |
Templatize CodePtr/Refs/FunctionPtrs with PtrTags. …
|
|
|
@225363
|
7 years |
mark.lam |
Let's scramble MacroAssemblerCodePtr values. …
|
|
|
@218794
|
8 years |
annulen |
Remove excessive headers from JavaScriptCore …
|
|
|
@200658
|
9 years |
fpizlo |
Internal JSC profiler should have a timestamped log of events for each …
|
|
|
@170876
|
11 years |
benjamin |
LinkBuffer should not keep a reference to the MacroAssembler …
|
|
|
@164229
|
11 years |
ossy |
Move back primary header includes next to config.h …
|
|
|
@163844
|
11 years |
fpizlo |
Rename Operations.h to JSCInlines.h …
|
|
|
@163760
|
11 years |
fpizlo |
Never include *Inlines.h files in interface headers, and never include …
|
|
|
@159987
|
11 years |
mark.lam |
Build failure when disabling JIT, YARR_JIT, and ASSEMBLER. …
|
|
|
@159883
|
11 years |
fpizlo |
FTL IC should nop-fill to make up the difference between the actual IC …
|
|
|
@137094
|
12 years |
fpizlo |
JSC should scale the optimization threshold for a code block according …
|
|
|
@136601
|
12 years |
fpizlo |
JSC should be able to report profiling data associated with the IR …
|
|
|
@136318
|
12 years |
fpizlo |
CodeBlock should be able to dump bytecode to something other than …
|
|
|
@136276
|
12 years |
fpizlo |
Rationalize and clean up DFG handling of scoped accesses …
|
|
|
@136199
|
12 years |
fpizlo |
It should be easy to find code blocks in debug dumps …
|
|
|
@136069
|
12 years |
fpizlo |
Disassembly methods should be able to disassemble to any PrintStream& …
|
|
|
@135469
|
12 years |
fpizlo |
Rename dataLog() and dataLogV() to dataLogF() and dataLogFV() …
|
|
|
@135466
|
12 years |
fpizlo |
It should be possible to say disassemble(stuff) instead of having to …
|
|
|
@135457
|
12 years |
fpizlo |
Baseline JIT's disassembly should be just as pretty as the DFG's …
|