|
|
@290768
|
3 years |
justin_michaud |
Refactor OpcodeTraits to support the possibility of having 2-byte WASM …
|
|
|
@283852
|
4 years |
tzagallo |
Implement the WebAssembly exception handling proposal …
|
|
|
@268247
|
5 years |
ysuzuki |
Unreviewed, reland r268170 …
|
|
|
@268241
|
5 years |
commit-queue |
Unreviewed, reverting r268170 and r268190. …
|
|
|
@268170
|
5 years |
ysuzuki |
[JSC] Restrict more ptr-tagging and avoid using OperationPtrTag for …
|
|
|
@268077
|
5 years |
ysuzuki |
[JSC] More consistent PtrTagging for code types …
|
|
|
@261755
|
5 years |
ross.kirsling |
[IWYU] Remove unnecessary includes from JSC implementation files …
|
|
|
@254735
|
5 years |
keith_miller |
Reland bytecode checkpoints since bugs have been fixed …
|
|
|
@254714
|
5 years |
rmorisset |
Use dataLogIf more regularly …
|
|
|
@254632
|
5 years |
keith_miller |
Revert bytecode checkpoints since it breaks watch …
|
|
|
@253896
|
5 years |
keith_miller |
DFG/FTL should be able to exit to the middle of a bytecode …
|
|
|
@251425
|
6 years |
ysuzuki |
[JSC] Thread JSGlobalObject* instead of ExecState* …
|
|
|
@249175
|
6 years |
mark.lam |
Refactor to use VM& instead of VM* at as many places as possible. …
|
|
|
@245906
|
6 years |
ysuzuki |
[JSC] Implement op_wide16 / op_wide32 and introduce 16bit version …
|
|
|
@240637
|
6 years |
ysuzuki |
[JSC] Reduce size of memory used for ShadowChicken …
|
|
|
@237728
|
7 years |
tzagallo |
REGRESSION(r237547): Exception handlers should be aware of wide …
|
|
|
@237547
|
7 years |
tzagallo |
New bytecode format for JSC …
|
|
|
@237486
|
7 years |
commit-queue |
Unreviewed, rolling out r237479 and r237484. …
|
|
|
@237479
|
7 years |
tzagallo |
New bytecode format for JSC …
|
|
|
@235419
|
7 years |
mark.lam |
Fix exception throwing code so that topCallFrame and topEntryFrame …
|
|
|
@230865
|
7 years |
mark.lam |
Some JSEntryPtrTags should actually be JSInternalPtrTags. …
|
|
|
@230748
|
7 years |
mark.lam |
Templatize CodePtr/Refs/FunctionPtrs with PtrTags. …
|
|
|
@230129
|
7 years |
mark.lam |
Add pointer profiling support in baseline JIT and supporting files. …
|
|
|
@223738
|
8 years |
jfbastien |
WebAssembly: no VM / JS version of everything but Instance …
|
|
|
@223002
|
8 years |
ryanhaddad |
Unreviewed, rolling out r222791 and r222873. …
|
|
|
@222791
|
8 years |
jfbastien |
WebAssembly: no VM / JS version of everything but Instance …
|
|
|
@218794
|
8 years |
annulen |
Remove excessive headers from JavaScriptCore …
|
|
|
@206401
|
9 years |
mark.lam |
Exception unwinding code should use a CatchScope instead of a …
|
|
|
@205569
|
9 years |
mark.lam |
Add CatchScope and force all exception checks to be via ThrowScope or …
|
|
|
@205462
|
9 years |
fpizlo |
Butterflies should be allocated in Auxiliary MarkedSpace instead of …
|
|
|
@204912
|
9 years |
fpizlo |
Unreviewed, roll out r204901, r204897, r204866, r204856, r204854.
…
|
|
|
@204854
|
9 years |
fpizlo |
Butterflies should be allocated in Auxiliary MarkedSpace instead of …
|
|
|
@202847
|
9 years |
sbarati |
StackVisitor::unwindToMachineCodeBlockFrame() may unwind past a VM …
|
|
|
@200997
|
9 years |
sbarati |
ShadowChicken crashes when reading a scope from the frame during a …
|
|
|
@199076
|
9 years |
fpizlo |
JSC should use a shadow stack version of CHICKEN so that debuggers …
|
|
|
@195502
|
9 years |
sbarati |
genericUnwind might overflow the instructions() vector when catching …
|
|
|
@191455
|
10 years |
msaboff |
REGRESSION(r191360): Repro Crash: com.apple.WebKit.WebContent at …
|
|
|
@191191
|
10 years |
mark.lam |
Move all the probe trampolines into their respective MacroAssembler …
|
|
|
@189995
|
10 years |
sbarati |
Implement try/catch in the DFG. …
|
|
|
@189961
|
10 years |
commit-queue |
Unreviewed, rolling out r189938, r189952, and r189956. …
|
|
|
@189938
|
10 years |
sbarati |
Implement try/catch in the DFG. …
|
|
|
@189775
|
10 years |
commit-queue |
rename callFrameForThrow to callFrameForCatch …
|
|
|
@189454
|
10 years |
mark.lam |
StackOverflow stack unwinding should stop at native frames. …
|
|
|
@189417
|
10 years |
mark.lam |
Rollout r189411, r189413: Broke JSC tests.
Not reviewed.
* …
|
|
|
@189411
|
10 years |
mark.lam |
StackOverflow stack unwinding should stop at native frames. …
|
|
|
@185259
|
10 years |
mark.lam |
finally blocks should not set the exception stack trace when …
|
|
|
@172867
|
11 years |
msaboff |
REGRESSION(r163179): Sporadic crash in js/dom/line-column-numbers.html …
|
|
|
@163844
|
11 years |
fpizlo |
Rename Operations.h to JSCInlines.h …
|
|
|
@163760
|
11 years |
fpizlo |
Never include *Inlines.h files in interface headers, and never include …
|
|
|
@163027
|
11 years |
msaboff |
Merge the jsCStack branch …
|
|
|
@160186
|
11 years |
mark.lam |
Make the C Loop LLINT work with callToJavaScript. …
|
|
|
@159321
|
12 years |
oliver |
Make CLoop easier to build, and make it work …
|
|
|
@159276
|
12 years |
msaboff |
Change callToJavaScript thunk into an offline assembled stub …
|
|
|
@158751
|
12 years |
msaboff |
Change ctiTrampoline into a thunk …
|
|
|
@157636
|
12 years |
msaboff |
Change native function call stubs to use JIT operations instead of …
|
|
|
@156242
|
12 years |
fpizlo |
Interpreter::unwind() has no need for the bytecodeOffset …
|
|
|
@154817
|
12 years |
commit-queue |
Source/JavaScriptCore: VM::throwException() crashes reproducibly in …
|
|
|
@154797
|
12 years |
commit-queue |
Source/JavaScriptCore: https://bugs.webkit.org/show_bug.cgi?id=119548 …
|
|
|
@154156
|
12 years |
mark.lam |
Fix crash when performing activation tearoff. …
|
|
|
@153646
|
12 years |
msaboff |
REGRESSION(r153612): It made jsc and layout tests crash …
|
|
|
@153612
|
12 years |
msaboff |
REGRESSION: Crash beneath cti_vm_throw_slowpath due to invalid …
|
|
|
@153273
|
12 years |
oliver |
fourthTier: Resurrect the CLoop LLINT on the FTL branch. …
|
|
|
@153222
|
12 years |
oliver |
fourthTier: The baseline jit and LLint should use common slow paths …
|
|
|
@153221
|
12 years |
oliver |
fourthTier: Re-worked non-local variable resolution …
|
|
|
@148696
|
12 years |
ggaren |
Renamed JSGlobalData to VM …
|
|
|
@140718
|
12 years |
mhahnenberg |
Objective-C API: Rename JSValue.h/APIJSValue.h to …
|
|
|
@140619
|
12 years |
oliver |
Harden JSC a bit with RELEASE_ASSERT …
|
|
|
@139541
|
12 years |
fpizlo |
The JITThunks class should be in its own file, and doing so should not …
|
|
|
@133953
|
13 years |
fpizlo |
JSC should infer when indexed storage contains only integers or …
|
|
|
@127333
|
13 years |
commit-queue |
Refactor LLInt and supporting code in preparation for the C Loop …
|
|
|
@127199
|
13 years |
commit-queue |
Render unto #ifdef's that which belong to them. …
|
|
|
@127068
|
13 years |
barraclough |
Refactoring LLInt::Data. …
|
|
|
@115688
|
13 years |
barraclough |
Should be able to build YARR JIT without the JS language JIT …
|
|
|
@108943
|
13 years |
fpizlo |
Getting the instruction stream for a code block should not require two …
|
|
|
@108444
|
13 years |
fpizlo |
JSC should be a triple-tier VM …
|
|
|
@108358
|
13 years |
aroben |
Roll out r108309, r108323, and r108326
They broke the 32-bit Lion …
|
|
|
@108309
|
13 years |
fpizlo |
JSC should be a triple-tier VM …
|
|
|
@104429
|
13 years |
rniwa |
WinCE build fix after r104415.
* jit/JITExceptions.cpp:
* …
|
|
|
@104415
|
13 years |
fpizlo |
The JIT's protocol for exception handling should be available to other …
|