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Welcome to the Pages User’s Guide

This full-color PDF document provides extensive instructions 
for using Pages.

Before using this document, you may want to look at the Pages tutorial in iWork ’08 
Getting Started. It’s a quick way to prepare yourself to be a self-sufficient Pages user. 
iWork ’08 Getting Started also provides additional resources for getting acquainted with 
Pages, such as a tour of its features and how-to videos.

When you need detailed instructions to help you accomplish specific tasks, you’ll find 
them in this user’s guide. Most of the tasks in this guide are also available in online 
help.
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The following table tells you where to find information in this guide. In Help, you can 
find information by browsing or searching. 

For information about See

Using Pages windows and tools 
to create and format documents

Chapter 1, “Pages Tools and Techniques,” on page 16

Creating, saving, and managing 
a Pages document

Chapter 2, “Working with a Pages Document,” on page 30

Creating, organizing, and 
formatting document parts

Chapter 3, “Working with Document Parts,” on page 39

Tracking edits in a Pages 
document

Chapter 4, “Reviewing and Revising Documents,” on page 61

Formatting text in a Pages 
document

Chapter 5, “Working with Text,” on page 70

Changing the appearance of 
text with paragraph, character, 
and list styles

Chapter 6, “Working with Styles,” on page 118

Using graphics, shapes, sound, 
and more to enhance a 
document

Chapter 7, “Working with Shapes, Graphics, and Other Objects,” on 
page 134

Creating, organizing, and 
formatting tables and the table 
values in them

Chapter 8, “Using Tables,” on page 167

Automating calculations by 
using formulas and functions

Chapter 9, “Using Formulas and Functions in Tables,” on page 189

Creating charts to graphically 
display data

Chapter 10, “Using Charts,” on page 201

Displaying Address Book data in 
a Pages document

Chapter 11, “Personalizing Documents with Address Book Data,” on 
page 220

Sharing a Pages document Chapter 12, “Printing and Exporting Your Document to Other 
Formats,” on page 225

Modifying an existing Pages 
template

Chapter 13, “Designing Your Own Document Templates,” on 
page 233
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1 Pages Tools and Techniques

This chapter introduces you to the windows and tools you’ll 
use in Pages.

When you create a Pages document, you first select a template to start from. 

Pages Templates
When you first open the Pages application (by clicking its icon in the Dock or by 
double-clicking its icon in the Finder), the Template Chooser window presents a variety 
of document types from which to choose.
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Pick the type that best fits your purpose and design goals. Use Word Processing 
templates to write documents such as letters, reports, and resumes. Use Page Layout 
templates to arrange elements in documents, such as invitations, posters, and flyers. 
After selecting a template, click Choose to work with a new document based on the 
selected template.

The new document contains placeholder text, placeholder images, and other items, 
which represent elements of the finished document: 

Placeholder text indicates 
where you can type new 
text and how your text will 
look on the page.

Media placeholders 
indicate the size and 
placement of graphics 
in a document template.

The Page View control lets you 
zoom in or out so you can see 
your document larger or 
smaller on the screen.

Address Book fields let you 
personalize documents with 
Address Book data.
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Â Placeholder text shows you how your text will look on the page. If you click 
placeholder text, the entire text area is selected. When you begin typing, the 
placeholder text disappears and is replaced by what you type. To learn more, see 
“Using Placeholder Text” on page 70.

Â Media placeholders can hold images, audio files, and movies. Drag your own images, 
audio files, or movies to the placeholder. Media placeholders automatically size and 
position the image or movie. You can drag media files anywhere in a document (not 
only to a media placeholder). To learn more, see “Using Media Placeholders” on 
page 157.

Â Many templates also contain Address Book fields. Address Book fields let you easily 
insert names, phone numbers, addresses (any data you’ve defined for contacts in 
Address Book) into Pages documents. This capability lets you reuse a document, such 
as a letter or contract, for multiple people by inserting person-specific data into 
Address Book fields in the document. To learn more, see “Using Address Book Fields” 
on page 221.

Â Sometimes graphics, such as watermarks or logos, appear on pages. These objects 
are called master objects. If you cannot select an object in a template, it’s probably a 
master object. To learn more, see “Using Master Objects (Repeated Background 
Images)” on page 57.

You can drag or place objects on a page, including imported graphics, movies, and 
sound, or objects that you create within Pages, including text boxes, charts, tables, and 
shapes. 

You can also insert pages that have been preformatted for the template you’re using. 
Click Pages or Sections in the toolbar and choose a template page. The new page is 
added immediately after the page where you placed the insertion point.

Document Viewing Aids
As you work on your document, you may want to zoom in or out to get a better view 
of what you are doing, or use other techniques for viewing the document.

Zoom Levels
You can enlarge (zoom in) or reduce (zoom out) your view of a document. It’s often 
useful to reduce your view of a document so that you can see several pages at once.

Here are ways to zoom in or out of the document:
m Choose View > Zoom > zoom level.
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m Choose a magnification level from the View pop-up menu at the bottom left of the 
window.

To use a certain zoom level every time you open a document, choose Pages > 
Preferences, click General, and then choose a zoom level from the Default Zoom pop-
up menu.

Document Page Views
You can arrange the way pages are displayed in the Pages window.

To choose a way to view document pages in the Pages window:
1 Click the View pop-up menu in the bottom-left corner of the window.

2 Choose one of the page view options.

One Up presents the pages above and below each other.

Two Up presents two pages side-by-side on the screen.

Fit Width scales the document to the width of the window. You can stretch the Pages 
window to fill your screen, or make it short or narrow. Choose Fit Width to view all the 
content on side-by-side (Two Up) pages.

Fit Page causes a single document page to fill the window.

Layout View
In layout view you can see the outlines of the different text areas of your document, 
including headers, footers, columns, text boxes, and the document body (the main area 
of text in the document). 

In layout view document rulers and alignment guides become visible. Pages also 
displays the document ruler, which contains controls for formatting text, when you 
show a document’s layout. 
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To show or hide a document’s layout:
m Click View in the toolbar and then choose Show Layout or Hide Layout.

In the following example, you can see the page layout includes two columns at the top, 
two layout breaks, and then three columns, a floating image, and the footer area.

A layout is part of a document in which you have defined layout margins and columns. 
As the example above illustrates, you can have multiple layouts on a single page. A 
layout break ends one layout and starts a new one with a different number of columns. 
See “Using Layouts” on page 44 for details.

The example above shows a floating image. A floating image stays where you place it 
on a page, unless you drag it to a new position. Text flows around a floating image as 
you type. There’s a second kind of image: an inline image. An inline image is an image 
placed so that it’s anchored to text. An inline image moves with the text around it. To 
learn how to place images so that they’re floating or inline, see “Adding Images” on 
page 158.

Two columns

A floating image

Three columns

Layout break

Footer

Layout break
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Formatting Characters (Invisibles)
Each time you press the Space bar, the Tab key, or the Return key, or add a column, 
layout, page break, or section break, Pages inserts a formatting character in the 
document. These formatting marks are called invisibles because, by default, you can’t 
see them. 

Making formatting characters visible is often useful, especially when you’re formatting 
a more complex document. For example, you can change your document format by 
selecting an invisible and then pressing the Delete key to remove formatting.

To see invisibles:
1 Click View in the toolbar and choose Show Invisibles.

2 To make invisibles stand out better, you can change their color. Choose Pages > 
Preferences, click General, click the Invisibles color well, and then select a color.

The table below shows what each formatting character represents.

Invisible character Represents

 Space

 Nonbreaking space (Option-Space bar)

 Tab

 Line break (Shift-Return)

 Paragraph break (Return)

 Page break

Column break (page 46)

Layout break (page 46)

Section break (page 53)

 Anchor point (for inline objects with text wrapping)
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The Toolbar
The Pages toolbar gives you one-click access to many of the actions you’ll use when 
working with documents. As you work in Pages and get to know which actions you 
perform most often, you can add, remove, and rearrange toolbar buttons to suit your 
working style.

To see a description of what a button does, hold the pointer over the button.

The default set of toolbar buttons for a word processing document is shown below.

To customize the toolbar:
1 Choose View > Customize Toolbar or Control-click on the toolbar, and then choose 

Customize Toolbar. The Customize Toolbar sheet appears.

2 Make changes to the toolbar as desired.

To add an item to the toolbar, drag its icon to the toolbar at the top.

To remove an item from the toolbar, drag it out of the toolbar.

To restore the default set of toolbar buttons, drag the default set to the toolbar. 

To make the toolbar icons smaller, select Use Small Size.

To display only icons or only text, choose an option from the Show pop-up menu.

To rearrange items in the toolbar, drag them.

3 Click Done when you have finished.

You can perform several toolbar customization activities without using the Customize 
Toolbar sheet:

Â To remove an item from the toolbar, press the Command key while dragging the item 
out of the toolbar.
You can also press the Control key while you click the item, and then choose Remove 
Item from the shortcut menu.

Add a comment for 
selected text or object.

Add text boxes, shapes, 
tables, and charts.

Track edits in your 
document.

Show thumbnails,
comments, the

Styles drawer, rulers,
invisibles, and more.

Add preformatted pages 
to your document.

Open the Inspector window, 
Media Browser, Colors 
window, and Font panel.
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Â To move an item, press the Command key while dragging the item around in the 
toolbar.

To show or hide the toolbar, choose View > Show Toolbar or View > Hide Toolbar.

The Format Bar
Use the Format Bar, displayed beneath the toolbar, to quickly change the appearance 
of text, styles, fonts, and other elements in your document.

The controls in the Format Bar vary with the object selected. To see a description of 
what a Format Bar control does, hold the pointer over it.

Here’s what the Format Bar looks like when text is selected.

To show or hide the Format Bar:
m Choose View > Show Format Bar or View > Hide Format Bar.

The Inspector Window
You can format most elements of your document using the panes of the Inspector 
window, including text appearance, size and positioning of graphics, and much more.

Open multiple Inspector windows to make working with your document easier. For 
example, if you have a Graphic Inspector and a Text Inspector open, you have all the 
text and image formatting options at your fingertips as you work.

Hold the pointer over buttons and other controls in the Inspector panes to see a 
description of what the controls do.

Here are ways to open an Inspector window:
m Click Inspector in the toolbar.

m Choose View > Show Inspector. 

Choose a paragraph
or character style.

Click to open the 
Styles drawer.

Change the font, font style, 
font size, and color.

Choose the line 
spacing and the 
number of columns.

Align selected text. Choose a list style.

The buttons at the top of the Inspector 
window open the ten Inspectors:  
Document, Layout, Wrap, Text, Graphic, 
Metrics, Table, Chart, Link, and QuickTime.
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Click one of the buttons at the top of the Inspector window to display a particular 
Inspector. Hover the pointer over a button to display its name. Clicking the fourth 
button from the left, for example, displays the Text Inspector.

m To open another Inspector window, press the Option key while clicking an Inspector 
window button.

When the Inspector window opens, click one of the buttons at the top to display a 
different inspector. Clicking the second button from the left, for example, displays the 
Layout Inspector. 

The Media Browser
The Media Browser provides access to all the media files in your iPhoto library, your 
iTunes library, and your Movies folder. You can drag an item from the Media Browser to 
a page or to an image well in an inspector. 

Here are ways to open the Media Browser:
m Click Media in the toolbar.

m Choose View > Show Media Browser.

Click a button to view the files in 
your iTunes library, your iPhoto 
library, your Aperture library, or 
your Movies folder.

Drag a file to your 
document.

Search for a file.
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The Font Panel
Using the Mac OS X Font panel—accessible from any application—you can change a 
font’s typeface, size, and other options.

To open the Font panel:
m Click Fonts in the toolbar.

Use the Font panel to select fonts, font sizes, and other font formatting features, 
including text shadows and strikethrough. For more detailed information about using 
the Font panel and changing the look of text, see “Using the Font Panel to Format Text” 
on page 77.

The Colors Window
You use the Mac OS X Colors window to choose colors for text, objects, and lines.

Here are ways to open the Colors window:
m Click the color well in the Format Bar and choose “Show Colors”.

m Click Colors in the toolbar.

For more information, see “Using the Colors Window” on page 148.

Rulers and Alignment Guides
As you move objects around in a document, alignment guides automatically appear to 
help you position objects on the page. See “Aligning Objects” on page 138 for details 
about using the alignment guides.

You can use the horizontal ruler to set tab stops, page margins, and column widths. For 
more information, see “Setting Tab Stops Using the Horizontal Ruler” on page 90, 
“Setting Indents for Paragraphs Using the Horizontal Ruler” on page 94, and “Defining 
Columns” on page 44.

Rulers help you set 
margins and tabs where 
you want them. 

Blue icons on the top ruler indicate 
text indents and tab settings. Drag 
them to reset the position of text.

Gray rectangles inside 
the rulers indicate column 
margins. Drag the 
rectangles to change the 
column gutter widths.
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You can also display the vertical ruler in a Word Processing template. See “Setting Tab 
Stops Using the Horizontal Ruler” on page 90 for more information.

The Styles Drawer
As you create a document, you may want to use a certain text style for every chapter 
title, heading, bulleted list, and body text paragraph. Each template comes with a set of 
preset styles that you can choose from. “About Styles” on page 119 provides more 
details about styles.

The Styles drawer lists and provides a preview of all the text styles in the template you 
are using, so you can create, customize, and manage styles easily.

Here are ways to open the Styles drawer:
m Click View in the toolbar and choose Show Styles Drawer. 

m Click the Styles Drawer button in the Format Bar.

See “Applying Styles” on page 120 to learn how to use the Styles drawer.

Select a paragraph style to 
apply it to selected paragraphs 
or the paragraph that contains 
the insertion point.

Select a character style to 
apply it to selected text or the 
word that contains the 
insertion point.

Select a list style to apply it to 
selected paragraph text or the 
paragraph that contains the 
insertion point.

Click to show and hide list and 
character styles in the drawer.

Press and hold, and then 
choose an option to create 
a new style.
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Scroll Bars, Scroll Arrows, and Thumbnails
 You can use the scroll bars, Previous Page and Next Page arrows, page thumbnails, and 
the Go to Page button to move around a document.

Here are ways to navigate through a document:
m To move forward or backward in small increments, click the scroll arrows.

m To scroll quickly, drag the vertical scroller up or down, or drag the horizontal scroller 
from left to right.

m To move forward or backward one page at a time, click the Previous Page button (looks 
like an up arrow) or the Next Page button (looks like a down arrow) at the bottom of 
the document window.

m To go to a specific page in a document, click View in the toolbar and choose Show 
Page Thumbnails. Then click in the thumbnail view to go to a particular page. You can 
also navigate to a page in a document by clicking the Page button in the lower left of 
the document window, typing the specific page number in the Go to Page field, and 
then pressing Return.

Drag the vertical 
scroller to quickly 
scroll up and down.

Click the scroll arrows to 
move forward or backward 
in small increments.

Click the Previous Page or Next
Page arrows to move forward or

back a page at a time.

Drag the horizontal 
scroller to scroll left 
and right.

Click a thumbnail to
display a particular page.

Click the Page button
to toggle to the Go to

Page button.



28 Chapter 1    Pages Tools and Techniques 

 

m To show facing pages in the thumbnail view, select Facing Pages in the Document 
Inspector’s Document pane. To open the Inspector window, click Inspector in the 
toolbar, then click the Document Inspector button.

See “Managing Sections with the Thumbnail View” on page 54 for more information 
about using thumbnails.

If your keyboard has them, you can also use the Page Up, Page Down, Home, End, and 
arrow keys to move around.

The Warnings Window
When you import a document into a Pages document, some elements might not 
transfer as expected. The Warnings window lists any problems encountered. You might 
get warnings in other situations, such as saving a document in an earlier version of the 
application.

If problems are encountered, you’ll see a message enabling you to review the warnings. 
If you choose not to review them, you can see the Document Warnings window at any 
time by choosing View > Show Document Warnings. 

If you see a warning about a missing font, you can select the warning and click Replace 
Font to choose a replacement font.

You can copy one or more warnings by selecting them in the Document Warnings 
window and choosing Edit > Copy. You can then paste the copied text into an email 
message, text file, or some other document.

Research and Reference Tools
 Use the research and reference tools to look for files on your hard drive, review 
document information, and find word definitions or facts on selected text.

Here are ways to access research and reference tools:
m To locate files on your hard drive, select the text related to the files you wish to find and 

choose Edit > Writing Tools > Search in Spotlight.

m To view document information, choose Edit > Writing Tools > Show Statistics.

m To look up word definitions quickly, select the word you wish to reference and choose 
Edit > Writing Tools > Look Up in Dictionary and Thesaurus.

m To research information on the Internet, select the text you wish to investigate and 
choose Edit > Writing Tools > Search in Google or Edit > Writing Tools > Search in 
Wikipedia.

You can also Control-click to quickly access the research and reference tools.
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Keyboard Shortcuts and Shortcut Menus
You can use the keyboard to perform many of the Pages menu commands and tasks. 
To see a comprehensive list of keyboard shortcuts, open Pages and choose Help > 
Keyboard Shortcuts.

Many commands are available in shortcut menus that you can access directly from the 
object you are working with. Shortcut menus are especially useful for working with 
tables and charts.

To open a shortcut menu:
m Press the Control key while you click text or an object.
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2 Working with a Pages Document 

This chapter describes how to create, open, import, and save 
Pages documents. It also tells you how to design and lay out 
a Pages document.

Working with Word Processing and Page Layout Templates
Word Processing and Page Layout templates have styles and formatting features 
tailored to their use:
Â Word Processing templates are best suited for text-intensive documents, such as 

letters and reports. 
Â Page Layout templates are most useful for documents that are more layout intensive, 

such as invitations and flyers. 

Word Processing Templates
Use Word Processing templates to create linear, text-intensive documents.

Here are the distinguishing features of a Word Processing template:

Â You can add and edit a table of contents in your document. See “Using a Table of 
Contents” on page 58 for more information.

Â Text flows from one page to another. See “Adding Text” on page 70 for more 
information.

Â Page thumbnails are hidden by default. See “Using Sections” on page 53 for more 
information.

Â Only a horizontal ruler is available by default. See “Rulers and Alignment Guides” on 
page 25 for more information.
You can also display the vertical ruler in a Word Processing template. See “Setting Tab 
Stops Using the Horizontal Ruler” on page 90 for more information.
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Â Word Processing templates contain floating and inline objects. For more information 
about working with floating and inline objects, see “Using Floating and Inline 
Objects” on page 134.

Page Layout Templates
Use Page Layout templates to arrange images and other elements in your document.

Here are the distinguishing features of a Page Layout template:

Â Page Layout templates contain floating objects such as images and text boxes that 
can be easily moved anywhere on the page. For more information about working 
with floating objects, see “Using Floating and Inline Objects” on page 134.

Â Text in a Page Layout template must either replace placeholder text in a template 
text box or a text box must be added to the page. See “Adding Text” on page 70 for 
more information.

Â Text can flow between text boxes. See “Linking Floating Text Boxes” on page 102 for 
more information.

Â Vertical and horizontal rulers are displayed by default. See “Rulers and Alignment 
Guides” on page 25 for more information.

Â Page thumbnails are displayed by default. See “Layout View” on page 19 and 
“Managing Sections with the Thumbnail View” on page 54 for more information.

Creating, Opening, and Importing a Pages Document
When you create a new Pages document, you pick a template to provide its initial 
formatting. You expand your new document by adding text, images, and other objects 
to it. You can also create a new Pages document by importing a document created in 
another application, such as Microsoft Word or AppleWorks.

Creating a New Document
To create a new Pages document, you pick the Word Processing or Page Layout 
template that provides appropriate formatting and layout characteristics.
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To create a new Pages document:
1 Open Pages by clicking its icon in the Dock or by double-clicking its icon in the Finder.

2 In the Template Chooser window, select a template category in the left column to 
display related Word Processing or Page Layout templates, and then select the 
template that best matches the document you want to create. 

If you want to begin in a document without any text or media placeholders, select 
Blank under Word Processing or Page Layout.

In a Blank page layout document, text is added by inserting a text box and then typing 
in the text box. To add text to a Blank word processing document, begin typing.

3 Click Choose. A new document opens on your screen. 

If you don’t see the Template Chooser when you first open Pages, you can make it 
appear by setting a preference in Pages preferences. Choose Pages > Preferences, click 
General, and then select “For New Documents:  Show Template Chooser.”

Alternatively, you can set Pages to automatically open a Blank document or the 
document template of your choice every time you open it. Choose Pages > Preferences, 
click General, select “For New Documents:  Use template:  template name,” and then 
click Choose. Select a template name, and then click Choose.
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Importing a Document
You can create a new Pages document by importing a document created in another 
application, such as Microsoft Office 2007 or AppleWorks. Pages can import the 
following file formats: plain text (.txt), Rich Text Format (.rtf and .rtfd), AppleWorks 6 
word processing (.cwk), and Microsoft Word (.doc).

As much as possible, Pages preserves the original document’s text, colors, layout, and 
other formatting options.

From Microsoft Word, you can import styles, tables, inline and floating objects, charts, 
footnotes and endnotes, bookmarks, hyperlinks, lists, sections, change tracking, and 
more.

From AppleWorks, you can only import word processing documents.

Here are ways to import a document:
m Drag the document to the Pages application icon. A new Pages document opens, and 

the contents of the imported document are displayed.

m Choose File > Open, select the document, and then click Open.

If you can’t import a document, try opening the document in another application and 
saving it in a format Pages can read, or copy and paste the contents into an existing 
Pages document.

You can also export Pages documents to Microsoft Word, PDF, Rich Text Format (RTF), 
and Plain Text. See “Exporting a Document for Use in Another Application” on page 230 
for details.

Opening an Existing Pages Document
There are several ways to open a document that was created using Pages.

Here are ways to open a Pages document:
m To open a document when you’re working in Pages, choose File > Open, select the 

document, and then click Open.

m To open a document you’ve worked with recently, choose File > Open Recent and 
choose the document from the submenu.

m To open a Pages document from the Finder, double-click the document icon or drag it 
to the Pages application icon.
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You can open a Pages document created using an older version of Pages (from 
iWork ’05 or iWork ’06). To take advantage of new features, save the document in 
iWork ’08 format. To preserve the document for use with iWork ’05 or iWork ’06, save it 
in the same format. See “Saving a Document as a Previous iWork Version” on page 231.

If you see a message that a font or file is missing, you can still use the document. Pages 
substitutes fonts for missing fonts. To use missing fonts, quit Pages and add the fonts to 
your Fonts folder (for more information, see Mac Help). To make missing movies or 
sound files appear, add them to the document again.

Saving Your Document
When you create a Pages document, all of the graphics and any chart data are 
contained within that document, which can be moved from one computer to another. 
However, fonts are not included as part of the document. If you transfer a Pages 
document to another computer, make sure the fonts used in the document have been 
installed in the Fonts folder of that computer.

Saving a Document
It’s a good idea to save your document often as you work. After you’ve saved it for the 
first time, you can press Command-S to resave it using the same settings.

To save a document for the first time:
1 Choose File > Save, or press Command-S.

2 In the Save As field, type a name for the document.

3 If your file directory isn’t visible in the Where pop-up menu, click the disclosure triangle 
to the right of the Save As field.

4 Choose where you want to save the document.

5 If you want the document to be opened using Pages in iWork ’05 or iWork ’06, select 
“Save a copy as,” and then choose iWork ’05 or iWork ’06 from the pop-up menu.

6 If you or someone else will open the document on another computer, click Advanced 
Options and consider the following:

Copy audio and movies into document:  Selecting this checkbox saves audio and video 
files with the document, so the files play if the document is opened on another 
computer. You might want to deselect this checkbox so that the file size is smaller, but 
media files won’t play on another computer unless you transfer them as well.

Copy template images into document:  If you don’t select this option and you open the 
document on a computer that doesn’t have the same template installed (if you created 
your own template, for example), the document might look different.
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7 Click Save.

You can generally save Pages documents only to computers and servers that use 
Mac OS X. Pages is not compatible with Mac OS 9 computers and Windows servers 
running Services for Macintosh. If you must use a Windows computer, try using AFP 
server software available for Windows to do so.

If you plan to share the document with others who don’t have Pages installed on their 
computers, you can export the document for use in another application. To learn about 
exporting your document in other file formats (including Microsoft Word, rich text 
format, plain text, and PDF), see “Exporting a Document for Use in Another Application” 
on page 230.

You can also send a document to iWeb. For more information, see “Sending a Pages 
Document to iWeb” on page 232.

Undoing Changes 
If you don’t want to save changes you made to your document since opening it or last 
saving it, you can undo them.

Here are ways to undo changes:
m To undo your most recent change, choose Edit > Undo.

m To undo multiple changes, choose Edit > Undo multiple times. You can undo any 
changes you made since opening the document or reverting to the last saved version.

m To undo one or more Edit > Undo operations, choose Edit > Redo one or more times.

m To undo all changes you made since the last time you saved your document, choose 
File > “Revert to Saved” and then click Revert.

Saving a Document as a Template
When you save a document as a template, it appears in the Template Chooser.

To save a document as a template:
m Choose File > Save as Template.

Saving a Copy of a Document
If you want to make a copy of your document—to create a backup copy or multiple 
versions, for example—you can save it using a different name or location. (You can also 
automate saving a backup version, as “Automatically Saving a Backup Version of a 
Document” describes.)
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To save a copy of a document:
m Choose File > Save As and specify a name and location.

The document with the new name remains open. To work with the previous version, 
choose File > Open Recent and choose the previous version from the submenu.

Automatically Saving a Backup Version of a Document
Each time you save a document, you can save a copy without the changes you made 
since last saving it. That way, if you change your mind about edits you have made, you 
can go back to (revert to) the backup version of the document.

Here are ways to create and use a backup version:
m To automatically save a backup version of a document, choose Pages > Preferences, 

click General, and then select “Back up previous version when saving.” 

The next time you save your document, a backup version is created in the same 
location, with “Backup of” preceding the filename. Only one version—the last saved 
version—is backed up. Every time you save the document, the old backup file is 
replaced with the new backup file.

m To revert to the last saved version after making unsaved changes, choose File > Revert 
to Saved. The changes in your open document are undone.

Closing a Document Without Quitting Pages
When you have finished working with a document, you can close it without quitting 
Pages.

Here are ways to close documents and keep the application open:
m To close the active document, choose File > Close or click the close button in the 

upper-left corner of the document window.

m To close all open Pages documents, press the Option key and choose File > Close All or 
click the active document’s close button.

If you’ve made changes since you last saved the document, Pages prompts you to save.

Storing Information About a Document
You can store such information as author name and keywords and later display that 
information as well as statistics created automatically (number of words, creation date, 
and so forth).

Here are ways to work with information about a document:
m To add or change descriptive information about a document (author, title, comments, 

and keywords), click Inspector in the toolbar, click the Document Inspector button, and 
then click Info. Enter or change information in the fields in the pane.

This information is searchable using Spotlight on computers with Mac OS X version 
10.4 and later.
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m To display document statistics, such as number of words, pages, lines, paragraphs, 
sections, graphics, and characters in the document, click Inspector in the toolbar, click 
the Document Inspector button, and then click Info.

If a range of text is selected, you can specify the extent of the displayed statistics by 
choosing Selection or Document from the Range pop-up menu in the Document 
Inspector.

m To display a document’s file information, including its size, its location, and the dates it 
was created and last modified, click Inspector in the toolbar, click the Document 
Inspector button, click Info, and then click the Show File Info button.

Designing Documents
Document layout and style, the appearance of text, and the use of graphics and other 
media all play a role in a document’s effectiveness. 

Document Layout and Style
Think about how you want the document to appear as a whole, including how it’s laid 
out and how it uses space. 
Â What type of document are you creating and which template most closely matches 

the layout you need?
Â Does the document need a landscape or portrait page orientation? Make sure to set 

this option in the Page Setup dialog before you begin. See “Setting the Paper Size 
and Orientation” on page 225.

Â If you are designing a unique page layout, are the document margins set the way 
you need? See “Setting Document Margins” on page 42.

Â Will the document be divided into sections with different page numbering, headers 
and footers, or design elements? See “Using Headers and Footers” on page 49 and 
“Using Sections” on page 53.

Â Will the document be bound? If so, be aware of how the page numbers, margins, 
and section breaks will fall on the right- and left-facing pages of your document. See 
“Using Left- and Right-Facing Pages” on page 47.

Â Does the document layout require columns? See “Using Layouts” on page 44.
Â Will the document require a table of contents? If so, make sure to use consistent 

heading styles throughout the document. See “Using a Table of Contents” on 
page 58.
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Appearance of Text
Consider how you might use text in your document to emphasize the organization of 
content and to create a compelling design. 
Â Which fonts will you use in the document? See “Formatting Text Size and 

Appearance” on page 75.
Â Are there heading styles or fonts that you would like to use consistently throughout 

the document? See “About Styles” on page 119.
Â What shape or image would you like to use for bullets? What number styles for 

outlines? See “Using Bulleted, Numbered, and Ordered Lists (Outlines)” on page 95.
Â Will you make use of callouts, sidebars, or other highlighted text in your document? 

See “Using Text Boxes, Shapes, and Other Effects to Highlight Text” on page 100.

Graphics and Other Objects
Think about how you will use graphical elements in your document, where they will 
appear in the document flow, and what kinds of graphics you might use. 
Â Do you want objects to remain with text as the text changes (inline objects), or do 

you want objects to stay in a particular location (floating objects)? See “Using 
Floating and Inline Objects” on page 134 for more information about these two 
options.

Â How will images be used in your document? See “Working with Images” on 
page 158.

Â Can you use tables to clearly present information? See “About Tables” on page 167.
Â Can you use charts to effectively display data? See “About Charts” on page 201.
Â What will be the final format for your document (printed page, and so on)? See 

“Printing Your Document” on page 225 and “Exporting to Other Document Formats” 
on page 230.

Â Will you make use of sound or movies in your document? See “Using Sound and 
Movies” on page 164.
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3 Working with Document Parts

This chapter describes how to set up overall document 
characteristics, including margins, facing pages, text columns, 
and sections, and how to create a table of contents, 
footnotes, and endnotes.

Before adding content to your document, it’s a good idea to set up such document 
settings as page orientation and size, page margins, master objects (background 
graphics, such as watermarks), and facing-page differences. You change most of these 
settings in the Document Inspector and the Layout Inspector.
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To open the Document Inspector:
m Click Inspector in the toolbar, and then click the Document Inspector button.

Formatting set in the Document Inspector applies to the entire document. 

The Document
Inspector button

Use the TOC pane to set up a table 
of contents for the document. 

Use the Info pane to see document 
statistics, such as word count, date, 
and keywords.

Use the Page Setup dialog to specify 
paper size and orientation.

Set up margins for the left, right, top, 
and bottom edges of the page. 

Choose a footnote or endnote style.

Use automatic
hyphenation throughout

the document. Use any available font ligatures 
throughout the document.

Adjust the space between notes.

Select the kind of note to create.

Select to add headers
and footers to a

document.



Chapter 3    Working with Document Parts 41

 

To open the Layout Inspector:
m Click Inspector in the toolbar, and then click the Layout Inspector button.

You use the Layout Inspector to set up text column layouts. It also lets you control 
formatting options for document sections, such as chapters; for example, you can 
create a different first page, left page, and right page layout for each section. 

Setting Page Orientation and Size
By default, most Pages templates are created for standard paper sizes, with the text 
printed in portrait (vertical) orientation. If your document will require a different paper 
size or you want to print it in landscape (horizontal) orientation, you should set the 
paper size and orientation at the start. This way, as you work in your document, you will 
have a clearer idea of what it’s going to look like.

If you start with a Blank (word processing) or Blank Canvas (page layout) document, it is 
in portrait orientation by default. “Setting the Paper Size and Orientation” on page 225 
provides instructions for changing the page orientation and setting up paper size.

The Layout Inspector button

Select a column or 
gutter width and type 
a new value.

Set the space between
the current layout and

the preceding and
following layouts.

Deselect to set unequal 
column widths.

Set the number
of columns.

Select to start the
current layout at the

top of a page. Set the margins for the 
current layout.

Use the Section pane to set up 
page number, facing-page, and 
other section attributes.
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Setting Document Margins
Every document has margins (blank space between the document’s content and the 
edges of the paper). These margins are indicated onscreen by light gray lines when 
you’re using layout view. To show layout view, click View in the toolbar and then 
choose Show Layout.

The default margins for most of the Pages templates, including Blank, are set to one 
inch from the left and right sides of the page, and one inch from the top and bottom. 
This means that the body text of the document will not expand outside these margins.

To change the page margins:
1 Click Inspector in the toolbar, click the Document Inspector button, and then click 

Document.

2 Enter values in the Left, Right, Top, and Bottom fields.

If you want to set different margins in different sections of your document, you must 
use the Layout Inspector. To learn about setting layout margins, see “Defining Layout 
Margins” on page 47.

If you are creating a document that will be bound, you may want your document 
margins to take into account which side of the page will go into the binding (the inside 
margin) and which will be the loose edge of each page (the outside margin). To do this, 
you must create a document with left- and right-facing pages. To read about this, see 
“Using Left- and Right-Facing Pages” on page 47.

Using Page and Line Breaks
You can insert page breaks, make a particular paragraph always start on a new page, 
make sure certain paragraphs always remain on the same page, and more.

When you insert breaks, Pages inserts a special formatting character called an invisible. 
See “Formatting Characters (Invisibles)” on page 21 for more information about 
invisibles.

Inserting a Page Break
In a word processing document, you can force the page to break at a particular place 
by inserting a page break. This creates a new page within the current section and is 
ready for typing text. In a page layout document, you can create a new page by adding 
a new page to your document. This creates a new page in a new section, and is ready 
to have a text box added for typing text.
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Here are ways to insert a page break:
m In a word processing document, click where you want the break to occur, and then 

choose Insert > Page Break. 

To remove a page break, click at the beginning of the line that follows the break and 
press the Delete key.

m In a page layout document, to insert a new page in your document, choose Insert > 
Pages > template page.

Starting Paragraphs on a New Page
You can make a paragraph always start on a new page, regardless of what precedes it 
in a document.

To start a paragraph on a new page:
1 Select the paragraph you want to start on a new page.

2 Click Inspector in the toolbar, click the Text Inspector button, and then click More.

3 Select “Paragraph starts on a new page.”

In a Blank Canvas (Page Layout) template, once a new page has been added, it's ready 
to have a text box added for typing text.

Keeping Paragraphs Together on a Page
You can make two or more paragraphs always appear on the same page unless you 
insert a page break between them.

To keep paragraphs together on a page:
1 Click the paragraph that you always want to appear with the paragraph following it.

2 Click Inspector in the toolbar, click the Text Inspector button, and then click More.

3 Select “Keep with following paragraph.”

Keeping an Entire Paragraph on the Same Page
You can make all the lines in a paragraph always appear on the same page.

To avoid breaking a paragraph across pages:
1 Click the paragraph whose lines you want to remain together.

2 Click Inspector in the toolbar, click the Text Inspector button, and then click More.

3 Select “Keep lines together.”

In a page layout document, text is contained in text boxes. For more information about 
linking text boxes, see “Linking Floating Text Boxes” on page 102.
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Inserting a Manual Line Break
You can use a manual line break, also called a soft return, if you want to start a new line 
without starting a new paragraph.

To insert a manual line break:
1 Click where you want the break to occur.

2 Press Return while holding down the Shift key.

Preventing Widow and Orphan Lines
You can prevent the first line of a paragraph from appearing alone at the bottom of a 
page (called a widow line) or the last line of a paragraph from appearing alone at the 
top of a page (called an orphan line).

To prevent widow and orphan lines in a paragraph:
1 Click the paragraph in which you want to prevent a widow or orphan.

2 Click Inspector in the toolbar, click the Text Inspector button, and then click More.

3 Select “Prevent widow & orphan lines.”

Using Layouts
In Pages, you can vary the design of pages in a page layout document by creating 
columns in text boxes, and in a word processing document through layouts separated 
by layout breaks.

For more information about working with text boxes in page layout documents, “Using 
Text Boxes, Shapes, and Other Effects to Highlight Text” on page 100.

In a word processing document, layouts are separated by layout breaks. A layout is part 
of a document in which you’ve defined specific column attributes and space around 
the columns, called the layout margin.

You can have multiple layouts in a section of your document, or even on a single page.

Defining Columns
Depending on the page size and column width you specify for a document, you can 
create as many as ten text columns (for example, in a standard letter size with 
landscape orientation).

When you type in a column and reach the end of the column, text automatically flows 
to the next column as you type. To change where a column breaks, follow the 
instructions in “Defining Column Breaks” on page 45.

When you want to vary the number or appearance of columns at some point in a 
document, create a new layout. See “Defining Layout Breaks” on page 46 for 
instructions.
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To format a document into multiple columns:
1 Click Inspector in the toolbar, click the Layout Inspector button, click Layout, and then 

specify the number of columns you want in the Columns field. To type a number in the 
Columns field, place the insertion point inside a text area in your document, type the 
number in the Columns field, and then press Return.

2 To make all columns the same width, select “Equal column width.”

To adjust the width of all columns, double-click any value in the column list and type a 
new number. To adjust the space between each column, double-click any value in the 
Gutter list and type a new number.

3 To specify different widths for the columns, deselect “Equal column width.”

To adjust the width of a specific column, double-click its value in the Column list and 
type a new number. To adjust the space between adjacent columns, double-click a 
value in the Gutter list and type a new number.

4 In a word processing document, to adjust the space around the outside margins of 
columns, specify new values in the Left, Right, Before, and After fields. 

Layout margins are not adjustable in a page layout document.

5 In a word processing document, to move columns to the top of the next page, select 
“Layout starts on a new page.”

“Layout starts on a new page” is not selectable in a page layout document.

6 To quickly create as many as four columns, click the Columns pop-up menu in the 
Format Bar and choose the number of columns you want to use from the pop-up 
menu.

7 To quickly modify column width and spacing, use the document ruler. Click View in the 
toolbar, and then choose Show Rulers. Drag the left or right edges of the gray gutter 
areas in the horizontal ruler.

Defining Column Breaks
 In a word processing document, a column break ends the text flow in one column 
(leaving the rest of the column blank) and continues it in the next.

The white areas in the 
ruler denote the text area 
within columns.

The gray areas denote the 
column gutters.
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To create a column break:
1 Click after the word where you want to end the text flow.

2 Choose Insert > Column Break.

The text breaks where the insertion point was placed and continues in the next text 
column. If you insert a column break in a single-column layout, the text continues at 
the top of the next page.

When you show invisibles in your document (click View in the toolbar and choose 
Show Invisibles), a column break symbol marks the location of the column break.

To delete a column break, click at the beginning of the line that follows the break and 
press the Delete key.

Defining Layout Breaks
In a word processing document, a layout break ends one layout and starts a new one in 
which you can define different column characteristics and different layout margins.

Using layout breaks doesn’t affect the headers, footers, page numbering, or other 
formatting specific to the document or section.

To insert a layout break in a word processing document:
1 Place the insertion point after the word where you want to end the current layout and 

change to a new layout.

2 Choose Insert > Layout Break.

A layout break is inserted and the insertion point is moved to the top of the next 
layout.

3 The layout following the break has the same formatting and number of text columns as 
the previous layout until you change it. To change the layout attributes, click Inspector 
in the toolbar and click the Layout Inspector button. In the Layout pane, set the 
number of columns, and then format them. 

4 To move the new layout to the top of a page, select “Layout starts on new page.”

When you show invisibles in your document (click View in the toolbar and then choose 
Show Invisibles), a layout break symbol marks the location of the layout break.

To delete a layout break, click at the beginning of the line that follows the break and 
press the Delete key.
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Defining Layout Margins
In a word processing document, a layout margin is the space around columns in a 
layout.

To change the layout margin in a word processing document:
1 Click in a column.

2 Click Inspector in the toolbar, click the Layout Inspector button, and then click Layout.

3 To change the outside margins of the column(s), enter values in the Left and Right 
fields under Layout Margins.

4 To specify the amount of space above and below the column(s), enter values in the 
Before and After fields under Layout Margins.

The new margins can’t extend outside the page margins set for the document in the 
Document Inspector.

Using Left- and Right-Facing Pages
If you intend to print a document double-sided and bind it, the document will have 
left- and right-facing pages. 

The left and right pages of these documents usually have different inside and outside 
margins. For example, you may want the inside margins of a document that will be 
bound to be wider than the outside margins.

If your document contains sections, such as chapters, you can use different headers or 
footers for left and right pages when you want to place page numbers on the outer 
corners of each page.

Defining Margins for Facing Pages
Use the Document Inspector to set up different margins for left and right pages.

To create different margins for left- and right-facing pages:
1 Click Inspector in the toolbar, click the Document Inspector button, and then click 

Document.

2 Select Facing Pages.

Specify a value for the 
margin on the outside 
edges of the pages.

Specify a value for the 
margin that will go into 
the binding.

Select to set the margins
for left- and right-facing

pages independently.
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3 Set inside and outside margins. The inside margin is the side of left or right pages that 
goes into the binding. The outside margin is the side that is on the outside edge of left 
or right pages.

Defining Headers and Footers for Facing Pages
In word processing documents, if your document uses sections, you can set up 
different headers and footers for left and right pages, such as when you want the page 
number to appear on the outer edge of the footers. See “Using Sections” on page 53 
for information about defining sections.

To set up headers and footers for facing pages in a section:
1 Click inside the section.

2 Click Inspector in the toolbar, click the Layout Inspector, and then click Section.

3 Select “Left and right pages are different.”

4 Deselect “Use previous headers & footers.”

5 On a left page in the section, define the header and footer you want to use for all left 
pages in the section. See “Using Headers and Footers” on page 49 for instructions.

6 On a right page in the section, define the header and footer you want to use for all 
right pages in the section.

7 If you want the first page of the section to have a unique header or footer, select “First 
page is different” and define the header and footer on the first page of the section.

Viewing Facing Pages
When your document has facing pages, there are several ways to view them in Pages.

Here are ways to view facing pages:
m Click View in the toolbar and choose Show Page Thumbnails to view facing pages in 

the thumbnail view. 

m Click the Page View control in the bottom-left corner of the window, and then choose 
Two Up from the pop-up menu to view facing pages side by side in the main 
document window. 
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Using Headers and Footers
You can have the same text or graphic appear on multiple pages in a document. 
Recurring information that appears at the top of the page is called a header; at the 
bottom it’s called a footer.

You can put your own text or graphics in a header or footer, and you can use formatted 
text fields. Formatted text fields allow you to insert text that is automatically updated. 
For example, inserting the date field shows the current date whenever you open the 
document. Similarly, page number fields keep track of page numbers as you add or 
delete pages. 

To define the contents of a header or footer:
1 Click View in the toolbar and choose Show Layout. You can see the header and footer 

areas at the top and bottom of the page.

2 To add text or graphics to a header or footer, place the insertion point in the header or 
footer and type or paste text or graphics.

3 To add page numbers or other changeable values, see the instructions in “Inserting 
Page Numbers and Other Changeable Values” on page 112.

Whatever you type in a header or footer is repeated on every page. If you want to 
change the header and footer text in different sections of your document, see 
“Changing Headers and Footers in a Section” on page 55.

Using Footnotes and Endnotes
In a word processing document, you can add special marks (numbers or symbols) in a 
document that link to notes at the bottom of a page (footnotes) or at the end of a 
document or section (endnotes).

You can’t mix footnotes and endnotes in a document, but you can convert notes from 
one type to the other.

Adding and Editing Footnotes and Endnotes
In a word processing document, footnotes and endnotes can contain text as well as 
inline objects.

Adding a Footnote
In a word processing document, you can add special marks in a document that link to 
notes at the bottom of the page. These notes are called footnotes.

To add a footnote:
1 Click Inspector in the toolbar, click the Document Inspector button, and then click 

Document.

2 Choose Use Footnotes from the Footnotes & Endnotes pop-up menu.
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3 Choose a numbering format.

4  Place the insertion point in the main text flow (not in a text box, table, or other object) 
where you want the footnote mark to appear.

5 Choose Insert > Footnote.

A footnote mark appears and the insertion point moves to the corresponding footnote 
field at the bottom of the page.

6 Type the footnote information. In addition to text, you can use inline shapes, graphics, 
and other objects; see “Using Floating and Inline Objects” on page 134 for instructions.

Adding an Endnote at the End of a Document
In a word processing document, you can add special marks in a document that link to 
notes at the end of the document. These notes are called document endnotes.

To add an endnote at the end of a document:
1 Click Inspector in the toolbar, click the Document Inspector button, and then click 

Document.

2 Choose Use Document Endnotes from the Footnotes & Endnotes pop-up menu.

3 Choose a numbering format.

4 Place the insertion point in the main text flow (not in a text box, table, or other object) 
where you want the endnote mark to appear.

5 Choose Insert > Endnote.

An endnote mark appears and the insertion point moves to the corresponding 
endnote field, at the end of the document following a section break. If you don’t want 
the endnotes on a new page, delete the section break.

6 Type the endnote information. 

In addition to text, you can use inline shapes, graphics, and other objects; see “Using 
Floating and Inline Objects” on page 134 for instructions.

Adding an Endnote at the End of a Section
In a word processing document, you can add special marks in a document that link to 
notes at the end of each section. These notes are called section endnotes.

To add an endnote at the end of a section:
1 Click Inspector in the toolbar, click the Document Inspector button, and then click 

Document.

2 Choose Use Section Endnotes from the Footnotes & Endnotes pop-up menu.

3 Choose a numbering format.

4 Place the insertion point in the main text flow (not in a text box, table, or other object) 
where you want the endnote mark to appear.
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5 Choose Insert > Section Endnote.

An endnote mark appears and the insertion point moves to the corresponding 
endnote field, at the end of the section in which the mark appears. A line separates the 
endnotes from other information in the section.

6 Type the endnote information. 

In addition to text, you can use inline shapes, graphics, and other objects; see “Using 
Floating and Inline Objects” on page 134 for instructions.

Deleting Footnotes and Endnotes
In a word processing document, deleting footnotes and endnotes is easy.

To delete a footnote or endnote:
m Delete the mark within your document that refers to the note.

Converting Footnotes to Endnotes and Vice Versa
In a word processing document, you can change all the footnotes in a document into 
endnotes, or all the endnotes into footnotes. You can also convert all document 
endnotes to section endnotes and vice versa. However, you can’t mix endnotes and 
footnotes in the same document.

To convert footnotes to endnotes and vice versa:
m  In the Document pane of the Document Inspector, change the setting in the 

Footnotes & Endnotes pop-up menu.

Formatting Footnotes and Endnotes
In a word processing document, you can format footnotes, endnotes, and marks to 
change their appearance or control the amount of space between notes.

Here are ways to format notes:
m To change the appearance of notes and marks, select the note text and/or mark and 

format it as you would any text using the Font panel, the Text Inspector, and the Styles 
drawer. 

m To adjust the space between notes, in the Document pane of the Document Inspector, 
increase or decrease the number in the Space Between Notes field.

Jumping Between a Mark and Its Related Footnote or Endnote
In a word processing document, you can jump to a note from its mark or to the mark 
from a note.

Here are ways to jump between marks and notes:
m  In the note, double-click the mark to jump to the location in the document where the 

mark appears.

m In the document body, double-click the mark to jump to its note.
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Numbering Footnotes and Endnotes
In a word processing document, you can use one of the predefined autonumbering 
styles for the mark that refers to the note. Predefined numbering styles are Arabic 
numbers (1, 2, 3), Roman numerals (i, ii, iii), and symbols (*, †, ‡). Numbering can be 
continuous through the document, or restarted for each document section or page. 

Instead of or in addition to using autonumbering, you can use custom marks, which 
you define yourself. There’s no autonumbering for custom marks; if you use custom 
marks, you need to specify the mark you want to use every time you create a footnote 
or endnote.

Defining Marks for Numbering Footnotes and Endnotes
In a word processing document, you can use a predefined number or symbol format or 
define your own marks.

Here are ways to define marks:
m To use a predefined number or symbol format, in the Document pane of the Document 

Inspector, choose a numbering style from the Format pop-up menu. The numbering 
style you choose will be the same throughout the document.

m To insert a custom mark, place the insertion point at the location in the document 
where you want the mark to appear.

Click the Insert menu, then press the Option key. Choose Custom Endnote, Custom 
Section Endnote, or Custom Footnote. What appears in the menu depends on the 
setting in the Footnotes & Endnotes pop-up menu.

In the dialog that appears, type or select a custom mark, and then click OK.

The mark appears and the insertion point moves to the appropriate location in the 
document for you to type the note.

Changing Marks for Numbering Footnotes and Endnotes
In a word processing document, you can switch from custom mark numbering to 
predefined number formatting and vice versa.

Here are ways to change mark numbering styles:
m To change the numbering format from predefined to custom, Control-click an endnote 

or footnote mark, and then choose Use Custom Mark from the shortcut menu.

In the dialog that appears, type or choose a custom mark, and then click OK. The 
custom mark replaces the predefined mark.

m To change custom numbering to predefined numbering, Control-click a custom mark, 
and then choose Use Automatic Numbering from the shortcut menu.

The mark that replaces the custom mark reflects the number format settings in the 
Document pane of the Document Inspector.
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Restarting Footnote and Section Endnote Numbering
If you don’t want mark numbers to be continuous, you can restart numbering on each 
page or for each section in a word processing document.

To restart mark numbering:
m  Choose Restarts on Each Page or Restarts for Each Section from the Numbering pop-

up menu in the Document pane of the Document Inspector. 

Using Sections 
Use sections to separate your document into distinct parts that use different layouts, 
numbering, or other document formatting. You can use sections to make the following 
formatting elements different from one part of your document to the next: headers, 
footers, page numbering, margins, column layout, and master objects (repeated 
background images). 

Creating Sections
In a word processing document, a section consists of one or more pages. 

Each Pages template consists of one or more predefined sections. Every time you add 
pages to the document by using the Sections (word processing) or Pages (page layout) 
button in the toolbar, you add a new section.

In a page layout document, each page is one section. You can use the predefined 
sections as they are, or you can modify or remove them one page at a time.

In a word processing document, you can use the predefined sections as they are, or 
you can create or remove section breaks to define your own sections. To add a page to 
a section, add more content and pages will be automatically added, or insert a page 
break.

Here are ways to work with section breaks in word processing documents:
m To insert a section break, place the pointer where you want the break to occur, and 

then choose Insert > Section Break or click Sections in the toolbar and choose an item 
from the list.

When you show invisibles in your document (click View in the toolbar and then choose 
Show Invisibles), a section break symbol marks the location of the section break.

The new section has the same formatting as the previous section until you change it. 
Changes you make to master objects, headers, footers, or page numbering will apply 
only to the section in which you make the changes. See “Using Master Objects 
(Repeated Background Images)” on page 57 for information about master objects.
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m To remove a section break, click at the beginning of the line that follows the break and 
press the Delete key.

Managing Sections with the Thumbnail View
You can view miniature versions (thumbnails) of all the pages in a document. 
Displaying page thumbnails makes it easy to see all your document’s pages at once, 
quickly duplicate or go to a specific page, or change the order of sections in a 
document.

Viewing Thumbnails
Use thumbnails to view your Pages document.

Here are ways to view thumbnails:
m To show the thumbnail view in a word processing document, click View in the toolbar 

and choose Show Page Thumbnails. In a page layout document, thumbnails are 
displayed by default.

To hide the thumbnail view, click View in the toolbar and choose Hide Page 
Thumbnails.

m To show facing pages in the thumbnail view, select Facing Pages in the Document 
Inspector’s Document pane. 

m To go to a specific page, click its thumbnail or click on the page in the document. The 
page appears in the main viewing area and the page’s thumbnail is highlighted to 
indicate your place in the document.

You can also navigate to a page in a document by clicking the Page button in the lower 
left of the document window, typing the specific page number in the Go to Page field, 
and then pressing Return.

Adding and Deleting Sections
You can quickly add and delete sections in your Pages document using thumbnails.

Here are ways to add and delete sections:
m To delete a section and its contents, select the section in the thumbnail view, press the 

Delete key.

m To copy (or cut) and paste one or more sections, in the thumbnail view select the 
sections you want to copy or cut and choose Edit > Copy or Edit > Cut. 

Select the section after which you want to paste the sections, and then choose Edit > 
Paste.

You can also copy and paste one or more sections by Option-dragging selected 
sections to a new destination in the thumbnail view. As you drag, sections shift to 
make room for what you’re pasting.

m To paste a copy of selected sections immediately following them, select the sections 
and then choose Edit > Duplicate.
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Reorganizing Sections
Reorganize your Pages document effectively using thumbnails.

Here are ways to reorganize sections:
m To select one or more sections in the thumbnail view, click a page. A yellow box 

surrounds all the page thumbnails that are in the same section as the selected page.

To select multiple adjacent sections, hold down the Shift key, and then select the first 
and last section you want.

You can also select multiple sections by dragging. Click to the left or right of a page 
thumbnail, and then drag up or down to select adjacent sections.

m To move sections, select the sections, click a page thumbnail in one of the selected 
sections, and then drag the sections to a new location in the thumbnail view. Sections 
shift to make room for your insertion as you drag.

Defining Section Attributes
 When you insert a section break, the new document section inherits all of the 
formatting and layout attributes of the previous section. You can change settings such 
as page numbering, headers and footers, margins, and master objects for each section.

Many section attributes are set in the Section pane of the Layout Inspector.

Changing Headers and Footers in a Section
You can change headers and footers to be unique to a section. You can also change 
headers and footers within a section.

To change headers and footers:
1 Place the insertion point in the section.

2 Click Inspector in the toolbar, click the Layout Inspector button, and then click Section.

3 Deselect “Use previous headers and footers.”

4 Type the new header or footer in the header or footer area of your document.

Make page numbering 
continuous with the previous 
section or enter a number to 
start renumbering pages.

Make headers and footers and 
master objects different on the 
first page or alternate pages, or 
continue from the previous section.

Make the new section begin 
on a left- or right-facing page.
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Restarting Page Numbering in a Section
You can start a new page-numbering scheme for a section.

To restart page numbering in a document section:
m Click in the section, select “Start at” in the Section pane of the Layout Inspector, and 

then specify the number of the first page of the section.

Setting Up a Unique Format for a Section’s First Page
You can make the header, footer, and master objects different for the first page of a 
section.

Here are ways to make the first page of a section unique:
m To make the headers and footers on the first page unique, click in the section, select 

“First page is different” in the Section pane of the layout inspector, and then change 
the header and footer as “Using Headers and Footers” on page 49 describes.

m To place a master object on the first page, follow the instructions in “Using Master 
Objects (Repeated Background Images)” on page 57.

Formatting Facing Pages in a Section
You can make headers, footers, and master objects different on facing pages in a 
section.

Click in the section to select it, and then format its facing pages.

Here are ways to format facing pages in a selected section:
m To put different headers and footers on alternate pages, select “Left and right pages are 

different” in the Section pane of the Layout Inspector.

m To make the first page of the section always start on the left- or right-facing page, 
choose Left Page or Right Page from the “Section starts on” pop-up menu. Otherwise, 
choose Any Page.

m To place a master object on left or right pages, follow the instructions in “Using Master 
Objects (Repeated Background Images)” on page 57.

For more information about facing pages, see “Using Left- and Right-Facing Pages” on 
page 47.

Setting Section Margins
If you want to set different margins in different sections of your document, you must 
use the Layout Inspector and change the layout margins. To learn about setting layout 
margins, see “Defining Layout Margins” on page 47.

Reusing Sections
You can make a section in a document reusable by adding it to the pop-up menu that 
appears when you click Pages in the toolbar.



Chapter 3    Working with Document Parts 57

 

To reuse some or all the pages in a section:
1 Select the section in the thumbnail view.

2 Choose Format > Advanced > Capture Pages. 

3 In the dialog that appears, type a name for the page or pages, use the Include pop-up 
menu to indicate which pages you want to reuse, and then click OK.

The page or pages are available in the pop-up menu that appears when you click the 
Pages button in the toolbar.

Using Master Objects (Repeated Background Images)
You may want to add watermarks, logos, or other background images that appear in 
the same spot on every page of your word processing and page layout documents. 
These repeated graphics are called master objects.

If your document is divided into sections, you can put different master objects in each 
section. Within a section, you can put a different master object on the first page of the 
section and on right and left pages in the section. See “Setting Up a Unique Format for 
a Section’s First Page” on page 56 and “Formatting Facing Pages in a Section” on 
page 56 for more information.

To add a master object:
1 Add an object.

See “Using Floating and Inline Objects” on page 134 for information about floating 
objects.

2 Position the object wherever you want it on the page.

3 Choose Format > Advanced > Move Object to Section Master, and make sure that 
Format> Advanced > Make Master Objects Selectable does not have a checkmark next 
to it.

The selection handles disappear from the object, so you can no longer select it.

To edit or move a master object, you must first make master objects selectable for the 
entire document by choosing Format > Advanced > Make Master Objects Selectable if 
it has no checkmark in front of it. Selectable master objects look different from other 
objects because they have blue selection handles.

Master objects have 
blue selection handles.
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Using a Table of Contents
 Using a Word Processing template, Pages can automatically generate a table of 
contents for your document. Many Word Processing templates come with a 
preformatted table of contents that you can add to your document.

In order to create a table of contents in a word processing document, you need to 
consistently use paragraph styles for headings in your document. To learn about styles, 
see “About Styles” on page 119 and “Applying Styles” on page 120.

After you create a table of contents, you can format it to change its appearance.

Creating and Updating a Table of Contents
Each table of contents you create using a Word Processing template lists only the 
content that follows it, up until the next table of contents. If you want a master table of 
contents for the entire document, it must be the only table of contents, and it must be 
at the beginning of the document.

To create a table of contents:
1 Click Inspector in the toolbar, click the Document Inspector button, and then click TOC.

2 Select the checkboxes next to the paragraph styles whose text you want to appear in 
the table of contents. For example, if you want all the first-level headings and 
subheadings to appear in the table of contents, select the paragraph style that you 
used for first-level headings and subheadings.

Click to update the table 
of contents after making 
changes to your document.

Select the checkbox in 
the #’s column if you want 
page numbers to appear 
with each entry.

Select the paragraph
styles whose text you
want to appear in the

table of contents.
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If the styles you select are not used anywhere in the document, you will see a message 
that your table of contents is empty when you create the table of contents. If you select 
styles that are used very frequently in the document, your table of contents might be 
longer than you want. 

3 In the #’s column, select the checkboxes of those styles whose entries you want to 
include a page number.

4 Place the insertion point at the beginning of the line where you want the table of 
contents to appear, and then choose Insert > Table of Contents.

If the Word Processing template you’re working with has a table of contents predefined 
for it, click in the page preceding where you want to insert the table of contents, click 
Sections in the toolbar, and then choose Table of Contents.

To update the TOC after editing a document, click any entry in the table of contents, or 
click Update Now in the TOC pane of the Document Inspector. If you don’t update the 
table of contents after changing a document, it updates automatically when you close 
the document.

Styling a Table of Contents
You can change the look of text in the table of contents as you would any other text in 
a word processing document. You can also add a leader line between an entry and its 
associated page number, and you can create new TOC styles.

To change the look of a table of contents entry:
1 In the table of contents, select the entry type that you want to format, such as a first-

level heading. All entries of the same type are automatically selected. They cannot be 
individually selected.

2 To open the Styles drawer, click the Styles drawer button in the Format Bar. Notice that 
the Styles drawer now displays a list of table of contents styles. The TOC style that 
corresponds to the selected entry is also selected.

Click the arrow and choose 
whether to redefine the 
selected style, create a new 
style, or just rename it.

When a table of contents 
entry is selected, the Styles 
drawer displays table of 
contents styles.
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3 To change the font attributes of the TOC heading, use the Format Bar controls. Other 
ways to change font attributes are the Font panel, the Text Inspector, and the Colors 
window.

4 To create leader lines from an entry to its associated page number, select the TOC entry, 
click the tab in the Tab Stops column in the Tabs pane of the Text Inspector, and then 
choose a line style from the Leader pop-up menu.

5 To change the style in the Styles drawer to match the entry, click the arrow to the right 
of the style name and choose Redefine Style From Selection.

To create a new TOC style instead, click the arrow to the right of the style name and 
choose Create New TOC Style From Selection, and then type a name for the new style. 
You can also add a new style by clicking the Add (+) button at the bottom-left corner 
of the Styles drawer. In either case, type a name for the new style, and then select 
“Apply this new style on creation” if you want it to be applied immediately to the 
selected text.

6 To rename the style in the Styles drawer, click the arrow next to the style name and 
choose Rename Style. Type a new name for the style.
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4 Reviewing and Revising 
Documents

In this chapter, learn how to use change tracking, comments, 
and other Pages features that are useful when you review 
and revise documents.

Pages includes several features that are especially useful when you’re revising a 
document:

Â Change tracking:  Track changes within a document until you decide which edits you 
want to accept or reject.

Â Comments:  Like margin notes, they allow you to annotate a paragraph without 
changing it.

Â Color and font changes:  Draw attention to particular parts of a document by 
modifying color and font style. For example, color the background of several 
paragraphs orange, and then use a comment at the beginning of the document to 
ask reviewers to help complete the orange paragraphs.

This chapter focuses on change tracking and comments. To learn about emphasizing 
text using color and font changes, see “Formatting Text Size and Appearance” on 
page 75 and “Adding Accents and Special Characters” on page 81. Instructions for using 
color appear in “Setting Character and Paragraph Fill Colors” on page 104.
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Using Change Tracking
With change tracking you can monitor changes that you or others make to text, 
character format, or paragraph style.

When change tracking is on, you can see:
Â Text that has been added, deleted, edited, or replaced in the document body, header, 

footer, shapes, and text boxes
Â Tables, charts, and shapes that have been added or deleted inline
Â Paragraph additions, deletions, or replacements
Â Text with style changes
Â Character and paragraph formatting changes 
Â New or deleted hyperlinks, Address Book fields, placeholders, or bookmarks
Â A new or deleted table of contents 
Â Edits displayed in thumbnail view

Click to start and stop
change tracking.

Use the Change Tracking 
control bar to manage and 
navigate changes to your 
document.

Change bubbles flag edits 
made to your document.

Tracked changes made
to your document are

highlighted in the page
thumbnails.
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A Tour of Change Tracking 
The following scenario illustrates how to use change tracking to consolidate and 
respond to changes that two reviewers, Anne and Tom, make to text in a document.

1 With a document open, Tom turns on change tracking by clicking the Track Changes 
button in the toolbar.

When change tracking is on, the Change Tracking control bar is visible below the 
Format Bar.

These controls help manage and navigate changes to your document. For more 
information about the Change Tracking control bar see, “Starting, Pausing, and 
Stopping Change Tracking” on page 65.

Click to start and stop
change tracking.

Click Track Changes in 
the toolbar and the 
Change Tracking control 
bar is displayed.

The Comments pane 
opens when you use 
change tracking.

Click to accept or reject 
selected changes.

Click arrow buttons to navigate 
between change bubbles.

Click to open Markup
View pop-up menu.

Click to open the
Action menu.

Click to pause 
change tracking.
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2 Tom saves the document without making changes, closes it, and emails it to Anne. This 
version of the document is the original version.

3 Anne opens the document and decides to change some text.

A change bubble flags her changes.

4 Anne saves the document, closes it, and emails it back to Tom. 

5 Tom opens the document and reads Anne’s edited version of the text. 

In the following examples, you can see Tom’s original document and the edited version 
using change tracking.

       

The document now displays the original text in black, and Anne’s changes in colored 
text.

6 When Tom opens the document, both the original text and the colored, edited text are 
visible.

Edited text is 
displayed in color.

The change bubble displays 
author name, date and time, 
and type of edit.

Original text is 
displayed in black.
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7 Tom decides he likes Anne’s revisions and clicks the checkmark in Anne’s change 
bubbles.

The change bubbles disappear. The text is no longer tracked as changed and the text is 
black.

See “Accepting and Rejecting Edits” on page 67, to learn other ways to accept and 
reject changes. 

Starting, Pausing, and Stopping Change Tracking
After you start change tracking for a document, changes are tracked until you pause or 
stop change tracking. 

Here are ways to control change tracking:
m To start change tracking, click the Track Changes button in the toolbar or choose Edit > 

Track Text Changes.

When change tracking is turned on, the Comments pane opens and the Change 
Tracking control bar is displayed.

m To pause change tracking, click Paused on the Change Tracking control bar. To resume 
tracking, click Tracking: On.

Pausing retains all previous changes, but suspends change tracking until you resume it.

Pause change tracking when you want to make changes but don’t want to track them. 
For example, you may decide to change the color of all the text in a document or apply 
a new text margin to all the text in a section.

m To stop change tracking, click Stop Tracking in the toolbar or choose Edit > Turn Off 
Tracking.

You can also choose Turn Off Tracking from the Action menu on the Change Tracking 
control bar.

Click to accept changes.

Click to reject changes.

Select to stop 
tracking changes.
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If your document has changes you haven’t yet accepted or rejected, a dialog asks you 
to cancel the operation or accept or reject the edits before continuing.

Controlling Change Tracking Information
Select your change bubble color, review your document using thumbnails, and more 
with change tracking.

Here are ways to control change tracking information:
m To hide text markup, choose Hide Text Markup from the Markup View pop-up menu. 

Edits in your document are displayed without author color or markup preferences. To 
show text markup, choose Show Text Markup from the Markup View pop-up menu.

m To hide deleted text, choose Hide Deleted Text from the Markup View pop-up menu. 
The text previously displayed with a strikethrough is hidden from view. To display 
deleted text, choose Show Deleted Text from the Markup View pop-up menu.

Deleted text can be displayed in different text styles. To change how deleted text is 
displayed, choose Preferences from the Markup View pop-up menu, and then choose a 
text style from the Deleted Text Style pop-up menu.

m To hide change bubbles, choose Hide Change Bubbles from the Markup View pop-up 
menu. The Comments pane closes and change bars appear next to edited portions of 
your document. To show change bubbles, choose Show Change Bubbles from the 
Markup View pop-up menu.

m To select your author color, choose Select Author Color from the Markup View pop-up 
menu on the Change Tracking control bar, and then choose your author color.

m To change your author name, markup text style, and deleted text style, choose 
Preferences from the Markup View pop-up menu.

m To view your document using thumbnails, click the View button on the toolbar, and 
then choose Show Page Thumbnails.

Tracked changes made to your document are highlighted in the page thumbnails.

Choose how edited text is 
displayed, author color, and set 
change tracking preferences.
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Accepting and Rejecting Edits
Change tracking allows you to accept or reject edits made to text in your Pages 
document.

Here are ways of accepting or rejecting edits:
m To accept an edit, select the edited text and click the Accept Change button in the 

change bubble or click the Accept button on the Change Tracking control bar.

m To reject an edit, select the edited text and click the Reject Change button in the 
change bubble or click the Reject button on the Change Tracking control bar.

m To accept selected edits, select the text with the editing changes you want to keep, 
and then choose Accept Selected Changes from the Action menu in the Change 
Tracking control bar.

m To review edits for selection, click a change bubble in the Comments pane or click 
anywhere in the document body, and then click the up or down arrow buttons in the 
Change Tracking control bar.

m To reject selected edits, select the text with the editing changes you don’t want, and 
then choose Reject Selected Changes from the Action menu.

m To accept all edits, choose Accept all Changes from the Action menu.

m To reject all edits, choose Reject all Changes from the Action menu.

Select change bubbles to review 
edits made to your document.

Click arrow buttons to navigate 
between change bubbles.
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Saving with Change Tracking Off
Save a “clean” copy of your document with change tracking turned off and comments 
deleted.

Saving a copy of your document with change tracking turned off is useful when you 
want a version with all the changes accepted.

To save a document with change tracking off:
m With change tracking on, choose Save a Copy as Final from the Action menu in the 

Change Tracking control bar. All editing changes made to your document are accepted.

Using Comments
With comments you can annotate a document or parts of it without changing the 
document. Comments are useful for making notes to yourself, asking questions of 
reviewers, conveying editorial suggestions, and so on.

Identify the part of the document a comment applies to by placing an insertion point 
or by selecting words or objects. The part of the document associated with a comment 
is called the comment anchor.

Select to save a “clean” 
copy of your document.

Click Comment to add 
a comment to your 
document.

Comments are
displayed in the

Comments pane and
are anchored to part

of the document.
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Here are ways to manage comments:
m To add comments to your document, click Comment in the toolbar or choose Insert > 

Comment.

In the comment bubble that appears, type your comment. The size of the comment 
bubble grows and shrinks to accommodate your text.

m To change a comment, click in the comment bubble and edit it just as you would text 
and objects elsewhere in your document. 

You can use character and paragraph styles to modify the appearance of text.

m To delete a comment, click the Delete button in the right corner of the comment 
bubble.

m To view comments, click the View button, and then choose Show Comments.

If change tracking is on, all comments and change bubbles associated with the current 
version are visible in the Comments pane.

If comments are not visible, inserting one displays all comments.

m To hide comments, click the View button and then choose Hide Comments.

m To print comments, choose File > Print. Printed pages are adjusted to make room for 
the comments. 

Click to delete 
the comment.
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5 Working with Text

This chapter describes how to add and modify the 
appearance of text, including lists, in text boxes, table cells, 
and shapes.

Adding Text
Add text by typing in a blank word processing document, replacing placeholder text, 
using text boxes and lists, placing text in shapes, and more. 
Â To learn about working with placeholder text in templates and Address Book fields, 

see “Using Placeholder Text” on page 70 and “Using Address Book Fields” on 
page 220.

Â To add different text styles, or create your own, see “About Styles” on page 119.
Â To learn how to add new template pages, see “Adding New Template Pages” on 

page 72.
Â To delete pages from your document, see “Deleting Pages” on page 73.
Â To learn how to delete, copy, and paste text, see “Deleting, Copying, and Pasting 

Text” on page 74.
Â To add text to a text box or shape, see “Using Text Boxes, Shapes, and Other Effects 

to Highlight Text” on page 100.
Â To add text that’s formatted as a list, see “Using Bulleted, Numbered, and Ordered 

Lists (Outlines)” on page 95.
Â To learn how to add text to table cells, see “Working with Text in Cells” on page 175 

or “Working with Content in Table Cells” on page 175.

Using Placeholder Text
Templates contain placeholder text, which shows you what text will look like and where 
it will be placed in the finished document. Most placeholder text appears in Latin (for 
example, lorem ipsum) in the document body, text boxes, headers, and elsewhere. 
Other predefined text, such as the title of a newsletter, appears in the language you’re 
using.
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You select the placeholder text, and then type your own text to replace it. The text you 
type keeps the same style and formatting as the placeholder text. If you don’t want to 
use the style and size of fonts the placeholder text uses, you can change the selected 
text by clicking the font family and font size controls in the Format Bar.

Placeholders in Main Text Areas
When you click placeholder text in a document template, the entire text area is 
highlighted.

When you type, the placeholder text disappears and is replaced by whatever text you 
are typing. The text you type behaves like regular text.

Placeholders in Text Boxes
Some placeholder text is contained in text boxes to preserve formatting. When you 
click placeholder text that’s in a text box, a rectangular, gray border appears around it 
when layout view is turned on. To turn layout view on, Click View in the toolbar and 
choose Show Layout.

To select the placeholder text inside a text box:
m Click once to select the text box, and then click to select the text inside the box.

Text box placeholder text is part of the template’s default design. To preserve the 
design, be careful not to press Delete after you select the text box or you’ll remove the 
text box from the page. If you accidentally delete a text box, press Command-Z (the 
shortcut for undo).

Placeholder text
The entire text area is 
selected when you click.
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Placeholders in Tables
Some tables contain placeholder text. When you select text that’s inside a table cell, a 
highlighted rectangle appears around it.

To select the placeholder text inside a table:
m Click once to select the table, and then double-click to select an individual cell and its 

placeholder text.

The text inside the cell is selected for editing when you select the individual cell. You 
can tell it’s placeholder text if it is highlighted; otherwise, it’s regular text.

Table placeholder text is part of the template’s default design. To preserve the design, 
be careful not to press Delete after you select the table or you’ll remove it from the 
page. If you accidentally delete a table, press Command-Z.

You can also add text to table cells that don’t contain placeholder text. See “Working 
with Content in Table Cells” on page 175 for instructions.

Placeholders in Columns
Occasionally, templates may contain placeholder text formatted in columns. It may be 
easier to work with text columns if the document layout is visible. To show the 
document layout, click View in the toolbar and choose Show Layout.

To select the placeholder text inside a column:
m Click the placeholder text in the column.

Adding New Template Pages
Each page of a Pages template has a unique design. You can choose to use the page 
designs shown when the document first opens. Or, if the page designs don’t meet your 
needs, you can choose from additional pages designed to fit the template. 

Adding new template pages lets you quickly add pages that already contain text, 
images, tables, charts, or other formatting options you want to use.

To add a new template page:
1 Click in the section you want the new page to follow. A section is a group of one or 

more pages that have the same layout, numbering, and other document attributes. A 
chapter is an example of a section.

Individual table cell 
selected for editing.
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2 Click the Sections (Word Processing template) or Pages (Page Layout template) button 
in the toolbar, and choose a page type to add to your document.

See “Using Sections” on page 53 for more information about working with sections.

Deleting Pages
There are several techniques for deleting entire pages.

Here are ways to delete a page:
m To remove a page without deleting other pages in its section, delete all the text and 

objects on the page or select a thumbnail and press Delete.

m To delete a section and all the pages in it, click View in the toolbar and then choose 
Show Page Thumbnails. Select the section in the thumbnail view and press the Delete 
key. Pages confirms which pages will be deleted. Click Delete.

m You can also delete a section by clicking in a paragraph in the section and choosing 
Edit > Delete Pages. Pages confirms which pages will be deleted. Click Delete.

For more information about sections, see “Using Sections” on page 53.

Choose additional pages
from the Sections or
Pages pop-up menu.
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Deleting, Copying, and Pasting Text
The Edit menu contains commands that help you perform text editing operations.

Here are ways to edit text:
m To copy (or cut) and paste text, select the text and choose Edit > Copy or Edit > Cut. 

Click where you want to paste the text.

To have the copied text retain its style formatting, choose Edit > Paste.

To have the copied text take on the style formatting of the text around it, choose Edit > 
Paste and Match Style.

m To delete text, select the text and choose Edit > Delete or press the Delete key.

If you accidentally delete text, choose Edit > Undo to restore it.

When you use the Copy or Cut command, the selected text is placed in a holding area 
called the Clipboard, where it remains until you choose Copy or Cut again or you turn 
off your computer. The Clipboard holds the contents of only one copy or cut operation 
at a time.

To avoid unintentionally changing a document’s format by removing formatting 
characters in addition to text, it’s a good idea to display formatting characters 
(invisibles) before cutting or deleting text. To show invisibles, click View in the toolbar 
and then click Show Invisibles.

Selecting Text
Before you format or perform other operations on text, you need to select the text you 
want to work with.

Here are ways to select text:
m To select one or more characters, click in front of the first character and drag across the 

characters you want to select.

m To select a word, double-click the word.

m To select a paragraph, click three times in the paragraph.

m To select all text in a document, choose Edit > Select All.

m To select blocks of text, click the start of a text block, and then click the end of another 
text block while holding down the Shift key.

m To select from the insertion point to the beginning of the paragraph, press the Up 
Arrow key while holding down the Shift and Option keys.

m To select from the insertion point to the end of the paragraph, press the Down Arrow 
key while holding down the Shift and Option keys.

m To extend the selection one character at a time, press the Left Arrow or Right Arrow key 
while holding down the Shift key.
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m To extend the selection one line at a time, press the Up Arrow or Down Arrow key 
while holding down the Shift key.

m To select multiple words or blocks of text that are not next to each other, select the first 
amount of text you want, and then select additional text while holding down the 
Command key.

Formatting Text Size and Appearance
You can do text formatting using the Format Bar, the Pages menus, the Text Inspector, 
and the Font panel.

You can do basic text formatting using the Format Bar and the Format menu. If you 
want to apply advanced formatting to text, use the Font panel and Text Inspector.

Using the Format Bar to Format Text
The Format Bar makes changing the size and appearance of text in a text box, shape, or 
comment quick and easy. When text in a text box, shape, or comment is selected, you 
can change the font style and size, adjust the color of the text and its background, 
make text bold or italics or underlined, align text, and set line spacing.

Here’s what the Format Bar looks like when text is selected. The first four controls are 
also available in the Format Bar when text in a table is selected.

Using the Format Menu to Format Text 
The items in the Font submenu of the Format menu give you basic control over the size 
and appearance of text.

Making Text Bold or Italic Using the Menus
You can make characters bold or italic.

To make text bold or italic:
1 Select the text you want to make bold or italic, or click where you want to type new 

text.

2 Choose Format > Font > Bold. Or choose Format > Font > Italic.

Some fonts contain several bold and italic typefaces. To choose from a variety of bold 
and italic typefaces, use the Font panel. See “Using the Font Panel to Format Text” on 
page 77.

Change font typeface, 
style, and size.

Set color of text. Set text background color.

Make text bold, italics,
or underlined.
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Creating Outlined Text Using the Menus
You can change text to appear as a stenciled outline.

To create outlined text:
1 Select the text you want to make outlined, or click where you want to type new text.

2 Choose Format > Font > Outline.

Outlined text you create in Pages may look different if the document is opened in 
another application. If you plan to share a document that contains outlined text with 
people who don’t have Pages installed on their computers, export the document as a 
PDF file and then share this file with others.

Underlining Text Using the Menus
You can underline text and then format the underline to change the underline style or 
color.

To underline text:
1 Select the text you want to underline, or click where you want to type new text.

2 Choose Format > Font > Underline.

To modify the underline style or color, click Fonts in the toolbar and use the Text 
Underline button in the Font panel. See “Using the Font Panel to Format Text” on 
page 77.

Many templates include an underline character style. To display the character styles 
defined for your document, click the Character Styles button in the Format Bar. Select 
the text you want to underline, and then choose the underline character style from the 
character styles displayed.

Changing Text Size Using the Menus
You can change the point size of text to make the text larger or smaller.

To change the size of selected text:
1 Select the text you want to resize.

2 To change the text size in 1-point increments, choose Format > Font > Bigger. Or 
choose Format > Font > Smaller.

You can also add Bigger and Smaller icons to the toolbar. Choose View > Customize 
Toolbar, drag the icons to the toolbar, and then click Done.

To specify a precise size for selected text, click Fonts in the toolbar and use the Size 
controls in the Font panel. See “Using the Font Panel to Format Text” on page 77.
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Making Text Subscript or Superscript Using the Menus
You can raise or lower text from its baseline.

To make text subscript or superscript:
1 Select the text you want to raise or lower, or click where you want to type new text.

2 To create a subscript or superscript that has a smaller font size than the text it 
accompanies, choose Format > Font > Baseline > Subscript. Or choose Format > Font > 
Baseline > Superscript.

3 To raise or lower text without reducing its font size, choose Raise or Lower from the 
Baseline submenu. 

4 To restore text to the same baseline as the body text, choose Use Default from the 
Baseline submenu.

You can add Subscript and Superscript icons to the toolbar. Choose View > Customize 
Toolbar, drag the icons to the toolbar, and then click Done. 

To specify a precise amount to raise or lower text, use the Text Inspector. Click Inspector 
in the toolbar, click Text, click More, and then use the Baseline Shift controls.

Changing Text Capitalization Using the Menus
You can quickly make blocks of text all uppercase or lowercase, or format text as a title.

To change text capitalization: 
1 Select the text you want to change, or click where you want to type new text.

2 Choose Format > Font > Capitalization and choose an option from the submenu.

Choose All Caps to change the text to capitals.

Choose Small Caps to change the text to smaller capitals with larger capitals for 
uppercase letters.

Choose Title to change the text to a title format, which capitalizes the first letter of each 
word.

Choose None to change text from all capitals to initial caps. Uppercase characters, such 
as the first word of each sentence, are capitals but the rest are lowercase.

Using the Font Panel to Format Text 
The Mac OS X Font panel gives you access to all the fonts installed on your computer. It 
provides a preview of the available typefaces (such as bold and italic) and sizes for each 
font. The buttons in the Font panel let you add underlines, strikethrough lines, color, 
and shadow to text. You can even change the background page color in the Font 
panel.

For information on installing fonts, creating and managing font collections, or 
troubleshooting font-related issues, see Mac Help.



78 Chapter 5    Working with Text 

 

To open the Font panel:
m Click Fonts in the toolbar.

You can change the appearance of any text in your document by selecting it and then 
selecting options in the Font panel. When you make formatting changes in the Font 
panel, the selected text changes right away, so you can try different formatting options 
and quickly see what looks best.

Here is a summary of what the text effects buttons do, from left to right:

Â The Text Underline pop-up menu lets you choose an underline style (such as single 
or double).

Â The Text Strikethrough pop-up menu lets you choose a strikethrough style (such as 
single or double).

Â The Text Color pop-up menu lets you apply a color to text.
Â The Document Color pop-up menu lets you apply a color behind a paragraph.
Â The Text Shadow button applies a shadow to selected text.
Â The Shadow Opacity, Shadow Blur, Shadow Offset, and Shadow Angle controls 

control the appearance of the shadow.

If you don’t see the text effects buttons, choose Show Effects from the Action pop-up 
menu in the lower-left corner of the Font panel.

Preview the selected typeface (you 
might need to choose Show Preview 
from the Action menu).

Select a typeface to 
apply to selected text 
in your document.

Select a font size to apply 
to selected text in your 
document.

The Action menu

Create interesting
text effects using

these buttons.

Apply a shadow to 
selected text. Modify 
the shadow using the 
opacity, blur, offset, and 
angle controls.

Find fonts by typing
a font name in the

search field.
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Making the Font Panel Easy to Use
If you frequently use the Font panel, there are several techniques for saving time.

Here are tips for using the Font panel:
m To quickly locate fonts you frequently use, organize them into font collections. Click the 

Add (+) button to create a font collection, and then drag a typeface into the new 
collection. 

m To make it easy to change fonts often, leave the Font panel open. If it takes up too 
much space on your screen, you can shrink it by dragging its resize control (the 
bottom-right corner of the panel), so that only the font families and typefaces in your 
selected font collection are visible. To close the panel, click the Fonts button again or 
the Close button in the upper-left corner.

Changing Fonts Using the Font Panel
The Font panel gives you extensive control over fonts. Use size controls and 
typography settings to customize the appearance of your text.

To modify the font of selected text:
1 Click Fonts in the toolbar.

2 In the Font panel, select a font style in the Family column and then select the typeface 
in the Typeface column.

If you don't see all the font families you know are installed on your computer, select All 
Fonts in the Collections column or type the name of the font you are looking for in the 
search field at the bottom of the Font panel.

A preview of the selected font appears in the preview pane at the top of the Font 
panel. If you don't see a preview pane, choose Show Preview from the Action pop-up 
menu in the lower-left corner of the Font panel.

3 Adjust the font size using the size slider or other size controls.

4 Adjust the typography settings of the selected font by choosing Typography from the 
Action pop-up menu. In the Typography window, click the disclosure triangles to see 
and select the different typography effects that are available for the selected font. 
Different fonts have different typography effects available. See “Using Advanced 
Typography Features” on page 83 for more information.

Changing Underlining Using the Font Panel
You can use the Font panel to change the appearance of underlines.

To modify underlining of text:
1 Click Fonts in the toolbar.

2 Click the Text Underline button in the Font panel (the first button on the left), and 
choose None, Single, or Double from the pop-up menu.
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3 To change the underline color, choose Color from the Text Underline pop-up menu, 
and then select a color in the Colors window.

Adding a Strikethrough to Text Using the Font Panel
You can mark text with a strikethrough line, and make the line’s color different from the 
text color.

To add a strikethrough to selected text:
1 Click Fonts in the toolbar.

2 Click the Text Strikethrough button (the second button from the left), and choose 
None, Single, or Double from the pop-up menu. A single or double strikethrough 
appears through the selected text in the same color as the text.

3 To change the strikethrough color, choose Color from the Text Strikethrough pop-up 
menu, and then select a color in the Colors window. The strikethrough takes on the 
color you select in the Colors window, but the text remains its original color.

Many templates include a strikethrough character style. To display the character styles 
defined for your document, click the Character Styles button in the Format Bar. Select 
the text you want to strike through, and then choose the strikethrough character style 
in the Styles drawer.

Changing Text Color Using the Font Panel
Changes made to text color in the Font panel will override text color changes made in 
the Text Inspector, and vice versa. (To read about changing color using the Text 
Inspector, see “Changing Text Color” on page 89.)

To modify the color of selected text:
1 Click Fonts in the toolbar.

2 Click the Text Color button menu in the Font panel (the third button from the left), and 
then select a color in the Colors window. See “Using the Colors Window” on page 148 
for instructions.

Changing the Paragraph Background Color Using the Font Panel
You can use the Font panel to add a color behind a paragraph.

To modify the background color of a selected paragraph:
1 Click Fonts in the toolbar.

2 Click the Document Color button in the Font panel (the fourth button from the left), 
and then select a color in the Colors window. See “Using the Colors Window” on 
page 148 for instructions.

You can also modify paragraph background color in the Text Inspector, as described in 
“Setting Character and Paragraph Fill Colors” on page 104.
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Creating Shadows on Text Using the Font Panel
You can use the Font panel to create and format shadows on text.

To define shadows on selected text:
1 Click Fonts in the toolbar.

2 Click the Text Shadow button in the Font panel (the fifth button from the left).

3 Drag the shadow opacity slider (the first slider on the left) to the right to make the 
shadow darker.

4 Drag the shadow blur slider (the middle slider) to the right to make the shadow more 
diffuse.

5 Drag the shadow offset slider (the third slider) to the right to separate the shadow from 
the text.

6 Rotate the Shadow Angle wheel to set the direction of the shadow.

You can also set text shadows in the Graphic Inspector, as described in “Adding 
Shadows” on page 144.

Adding Accents and Special Characters
If you need to type characters with accent marks (such as ü), mathematical symbols, 
arrows, or other special characters, you can use the International preferences pane or 
the Character Palette. You can also see where characters are located on keyboards used 
for other languages by using the Keyboard Viewer (for example, you can see how the 
keys on an Italian keyboard are laid out). All of these are built-in tools of Mac OS X.

Adding Accent Marks
You can use the Keyboard Viewer available in System Preferences to add accent marks 
to characters.

To add accent marks:
1 Choose Apple > System Preferences and click International.

2 Click Input Menu, then select the checkbox next to Keyboard Viewer.

3 Choose Show Keyboard Viewer from the Input menu on the right side of the menu bar 
(the one that looks like a flag or alphabetical symbol).

The Keyboard Viewer shows the characters for your keyboard. (If you've selected a 
different keyboard layout or input method in the Input menu, it shows the characters 
for the selected keyboard layout.) For example, if U.S. is chosen in the Input menu, you 
see the characters that appear on a U.S. keyboard in the Keyboard Viewer.

4 To see the different accent marks that you can type highlighted in the Keyboard 
Viewer, press Option, or the Option and Shift keys.

The accent mark keys appear with white outlines. Depending on your keyboard, you 
may not need to press any of the modifier keys to see the accent keys.
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5 Place the insertion point in your document where you want to type.

6 Press the modifier key you pressed in step 4 (Shift, Option, Option-Shift, or none) and 
press the key on your keyboard that is in the same place as the accent you see in the 
Keyboard Viewer. Then release the modifier key and press the key for the character you 
want to accent.

The accent key modifies the key you type next. For example, on a U.S. keyboard, to 
make the é appear, press Option and E (the accent key), then press E (the letter on 
which you want that accent to appear).

Viewing Keyboard Layouts for Other Languages
You can use the Keyboard Viewer available in System Preferences to see where 
characters are located on keyboards used for other languages.

You must have fonts installed for the language you want to see in the Keyboard Viewer.

To see keyboard layouts for different languages:
1 Choose Apple > System Preferences and click International.

2 Click Input Menu, then select the checkbox next to Keyboard Viewer.

3 To see the character layout on keyboards used in different countries, select the On 
checkbox next to the country's keyboard layout or input method.

4 Choose Show Keyboard Viewer from the Input menu on the right side of the menu bar 
(the one that looks like a flag or alphabetical character).

The Keyboard Viewer shows the characters for the keyboard layout or input method 
selected in the Input menu. For example, if U.S. is chosen in the Input menu, you see 
the characters that appear on a U.S. keyboard in the Keyboard Viewer.

5 To see the keyboard layout for a different country, choose its keyboard layout from the 
Input menu.

Typing Special Characters and Symbols
Using the Mac OS X Character Palette, you can insert special characters, such as 
mathematical symbols, letters with accent marks, arrows and other “dingbats,” and 
more. You can also use this palette to enter Japanese, Traditional Chinese, Simplified 
Chinese, and Korean characters, as well as characters from other languages.

To insert special characters or symbols:
1 Place the insertion point where you want the special character or symbol to appear.

2 Choose Edit > Special Characters to open the Character Palette (or choose Characters 
from the Action pop-up menu in the lower-left corner of the Font panel).

3 Choose the type of characters you want to see from the View pop-up menu at the top 
of the Character Palette. If you don't see the View menu, click the button in the upper-
right corner of the window to show the top portion of the window. Click this button 
again to hide the top portion of the window.
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4 Click an item in the list on the left to see the characters that are available in each 
category.

5 Double-click the character or symbol on the right that you want to insert into your 
document, or select the character and click Insert. 

If the character or symbol has variations, they appear at the bottom of the window 
when you click the Character Info triangle or Font Variation triangle at the bottom of 
the palette. Double-click one to insert it in your document.

If the character doesn’t appear in your document, Pages may not support that 
character.

Using Smart Quotes
Smart quotes are opening and closing quotation marks that are curly; the opening 
quotation marks are different from the closing marks. When you don’t use smart 
quotes, the marks are straight and the opening and closing marks don’t differ.

To use smart quotes:
m Choose Pages > Preferences, click Auto-Correction, and then select “Use smart quotes.”

Using Advanced Typography Features
Some fonts, such as Zapfino and Hoefler, have advanced typography features, which let 
you create different effects. If you are using a font in a text box that has different 
typography effects available, you can change many of the effects in the Font submenu 
of the Format menu. For example, you may be able to adjust the following:
Â Tracking:  Place characters closer together or farther apart.
Â  Ligature:  Use or leave out stylish flourishes between letters or at the end or 

beginning of lines that combine two or more text characters into one glyph.

In the Ligature submenu, choose Use Default to use ligature settings specified in the 
Typography window for the font you’re using, choose Use None to turn off ligatures 
for selected text, or choose Use All to turn on additional ligatures for the selected 
text.

Â  Baseline:  Move text higher or lower than the text around it.
Â  Capitalization:  Convert characters to all capital letters, small capital letters, or initial 

capital letters (title style).

Smart quotes

Straight quotes

Ligature not used

Ligature used
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Advanced typography features are available in the Typography window.

To open the Typography window:
1 Click Fonts in the toolbar.

2 In the Font panel, choose Typography from the Action pop-up menu (in the lower-left 
corner).

To enable ligatures for an entire document, Click Inspector in the toolbar, click the 
Document Inspector button, click Document, and then select “Use ligatures.” To turn off 
ligatures for a specific paragraph, click in the paragraph, open the Text Inspector, click 
More, and then select “Remove ligatures.”

Adjusting Font Smoothing
If the fonts on your screen look fuzzy, blurry, or jagged, you may want to adjust the font 
smoothing style or change the text size at which Mac OS X starts to smooth fonts.

To smooth the fonts on your screen:
1 Open System Preferences and click Appearance.

2 Choose a font smoothing style from the pop-up menu at the bottom. Depending on 
the type of display you have, you may notice only small or no differences between 
smoothing styles.

3 If you plan to use small font sizes in your document, choose a point size from the “Turn 
off text smoothing for font sizes” pop-up menu. When text smoothing (or “antialiasing”) 
is on, smaller fonts can be harder to read.

Setting Text Alignment, Spacing, and Color
The primary tools for adjusting text attributes are the Format Bar and the Text 
Inspector. You can make some horizontal alignment adjustments (such as centering 
text or aligning it on the left) by using the Format menu.

Color and alignment controls are also available on the Format Bar when text is selected. 
When text in a text box, comment, or shape is selected, you can set the color of text 
and its background, align text, and set line spacing.

Set color of text and
its background. Align text horizontally.

Set line spacing.
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When you’re working with text in a table cell, you can use the Format Bar to align text 
both horizontally and vertically in the cell.

The Text pane of the Text Inspector gives you access to more alignment and line 
spacing settings.

To open the Text pane of the Text Inspector:
m Click Inspector in the toolbar, click the Text Inspector button, and then click Text.

Aligning Text Horizontally 
You can change the alignment of paragraphs in a page, column, table cell, text box, or 
shape so that text is aligned to the left or right border, centered, or aligned on both left 
and right (justified).

Use the Alignment buttons in the Format Bar to quickly change the alignment of text 
in your document. To change the alignment of text, select the text, and then click the 
Alignment buttons in the Format Bar.

Align text horizontally.

Align text vertically.

Click to change the
color of selected text.

Horizontal alignment buttons:
Click to align selected text left, right, 
center, or to the left and right, or 
special table cell alignment.

Vertical alignment buttons: 
Click to align text to the top, 
center, or bottom of a text box, 
shape, or table cell.

Character and
line spacing:

Adjust character, line,
and paragraph spacing

for selected text.

Drag to adjust the amount of space 
between text and the inside borders 
of text boxes, table cells, and shapes.

The Text Inspector
button.
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To align text left, center, right, or justified using the Text Inspector:
1 Select the text you want to change.

2 Click Inspector in the toolbar, click the Text Inspector button, and then click Text.

3 Click one of the five horizontal alignment buttons, located to the right of the color well. 
From left to right, these buttons have the following effects.

The Align Left button places each line of text against the left margin of the object.

The Center button sets the center of each line of text at the center of the object.

The Align Right button sets each line of text against the right margin of the object.

The Justify button spaces characters in each line so that the lines reach both the left 
and right margins of the object.

The Auto Align Table Cell button left justifies text and right justifies numbers in a table 
cell.

The first four alignment buttons are available on the Format Bar when text is selected. 
Five horizontal alignment buttons are also available on the Format Bar when a table 
cell is selected. 

You can also align text horizontally by choosing Format > Text > Align Left, Center, Align 
Right, Justify.

If you want to indent the first line of text in a paragraph, or learn how to undo 
paragraph indenting, see “Setting Indents” on page 94.

Aligning Text Vertically 
You can change the alignment of paragraphs in a table cell, text box, or shape so that 
text is aligned to the top or bottom border or centered between them.

To align text to the top, center, or bottom of a text box, table cell, or shape:
1 Select the text box, table cell, or shape whose alignment you want to change.

2 Click Inspector in the toolbar, click the Text Inspector button, and then click Text.

3 Click one of the three vertical alignment buttons, located below Color & Alignment, to 
align text to the top, middle, or bottom of the table cell, text box, or shape.

The vertical alignment buttons are also available on the Format Bar when you’re 
working with a table cell.
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Adjusting the Spacing Between Lines of Text
You can increase or decrease the distance between lines of text.

Use the Line Spacing control in the Format Bar to quickly change the distance between 
lines of text. To adjust line spacing, select the text, and then click the Line Spacing 
control in the Format Bar.

To adjust spacing using the Text Inspector:
1  Select the text you want to change.

2 Click Inspector in the toolbar, click the Text Inspector button, and then click Text.

3 Move the Line slider left to decrease spacing or right to increase it.

To specify a precise line spacing value, type a point value in the Line field, or click the 
Up Arrow or Down Arrow next to the field.

4 Choose a line spacing option from the Line spacing pop-up menu that appears when 
you click the text below the line field.

Standard line spacing (Single, Double, Multiple):  The space between lines is proportional 
to font size. Use this when the relative distance between ascenders (parts of letters that 
extend to the top of the line) and descenders (parts of letters that extend below the 
line) should remain fixed. Single sets line spacing to single-spaced, and Double sets it 
to double-spaced. Multiple lets you set line spacing values between single and double, 
or greater than double.

At Least:  The distance from one line to the next will never be less than the value you 
set, but it may be larger for larger fonts in order to prevent overlapping text lines. Use 
this when the distance between lines should remain fixed, but overlap is not desired if 
the text gets large.

Exactly:  The distance between the baselines. 

Between:  The value you set increases the space between the lines, instead of increasing 
the height of the lines. By contrast, double-spacing doubles the height of each line.

Line spacing pop-up menu: 
Click the text below the Line 
field and choose a line 
spacing option.

Line field: 
Type a value (or click the 
arrows) to specify the space 
between lines of text in a 
paragraph.
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Line spacing can also be controlled by using the Line Spacing pop-up menu on the 
Format Bar when text is selected.

Adjusting the Spacing Before or After a Paragraph
You can increase or decrease the spacing before or after paragraphs.

Use the Line Spacing control in the Format Bar to quickly change the distance before or 
after paragraphs. To adjust spacing before or after paragraphs, select the text, and then 
click the Line Spacing control in the Format Bar.

To adjust the amount of space before or after a paragraph:
1 Select the paragraphs you want to change.

2 Click Inspector in the toolbar, click the Text Inspector button, and then click Text.

3 Drag the Before Paragraph or After Paragraph slider. You can also specify a precise value 
(5 pt, for example) in the text boxes.

If the Before Paragraph or After Paragraph values for adjacent paragraphs aren’t equal, 
the higher spacing value will be used. For example, if the current paragraph’s Before 
Paragraph value is 12 points and the paragraph preceding it has an After Paragraph 
value of 14 points, the spacing between paragraphs will be 14 points.

Spacing before a paragraph does not appear if the paragraph is the paragraph in a text 
box, shape, or table cell.

To set spacing around text in boxes, shapes, and table cells, use the Inset Margin 
control, described in “Changing the Inset Margin of Text in Objects” on page 95.

Adjusting the Spacing Between Characters
You can increase or decrease the amount of space between characters.

To adjust the amount of space between characters:
1 Select the text you want to change, or click where you want to type new text.

2 Click Inspector in the toolbar, click the Text Inspector button, and then click Text.

3 Drag the Character slider or specify a new percentage in the Character field.

You can also adjust the space between selected characters by choosing Format > 
Font > Tracking and choosing an option from the submenu.

Click to change the amount of 
space between lines of text.
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Changing Text Color
You can change text color by using the Format Bar, the Text Inspector, and the Font 
panel. Changes you make with any of these tools overrides color changes already made 
with the other tools.

Here are ways to change text color:
m Click the Text Color or Text Background color well in the Format Bar. In the color matrix 

that appears, select a color by clicking it or click Show Colors to open the Colors 
window for additional color options.

m Click Inspector in the toolbar, click the Text Inspector button, click Text, and then click 
the color well. The Colors window opens.

“Using the Colors Window” on page 148 provides instructions for using the Colors 
window.

Setting Tab Stops to Align Text
You can align text at specific points by setting tab stops in a document, text box, table 
cell, or shape. When you press the Tab key (or Option-Tab when you’re working in a 
table cell), the insertion point (and any text to the right of it) moves to the next tab 
stop, and text you type starts at that point.

You can work with tab stop settings by manipulating the tab symbols on the horizontal 
rulers. You can see symbols for existing tab stops on the horizontal ruler when you click 
View in the toolbar, choose Show Rulers, and then select some text on a page.

Note:  Don’t use these instructions to set tab stops in lists. See “Using Bulleted, 
Numbered, and Ordered Lists (Outlines)” on page 95 for information about indenting 
items in lists.
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Setting Tab Stops Using the Horizontal Ruler
You can work with tab stop settings by manipulating the tab symbols on the horizontal 
rulers. You can see symbols for existing tab stops on the horizontal ruler when you click 
View in the toolbar, choose Show Rulers, and then select some text on a page.

To set tab stops in lists, see “Using Bulleted, Numbered, and Ordered Lists (Outlines)” on 
page 95 for information about indenting items in lists.

Here are ways to work with rulers:
m To show or hide rulers, click View in the toolbar and choose Show Rulers or Hide Rulers.

m To change the units of measure in the rulers, choose Pages > Preferences, click General, 
and choose an item from the Ruler Units pop-up menu.

m To display measurements as a percentage of the distance across the page, choose 
Pages > Preferences, click General, and then select “Display ruler units as percentage.”

m To place the ruler’s horizontal origin point at the center of the page, choose Pages > 
Preferences, click General, and then select “Place origin at center of ruler.”

m To display the vertical ruler in a word processing document, choose Pages > 
Preferences, and then select “Enable vertical ruler in word processing documents.”

When you change ruler settings in Pages preferences, the new settings apply to all 
documents viewed in Pages until you change the settings again.

Setting a New Tab Stop Using the Horizontal Ruler
You use the horizontal ruler to add a new tab stop.

To create a new tab stop:
1 Click View in the toolbar and choose Show Rulers.

2 Click the horizontal ruler to place a tab symbol where you want to set the tab stop.

3 Control-click the tab symbol and choose an option from the shortcut menu. 

Left Tab:  Aligns the left side of text with the tab stop.

Center Tab:  Places the center of text at the tab stop.

Blue tab symbols appear on 
the horizontal ruler when 
you select tabbed text.

Decimal tab

Right tab

Center tab

Left tab

Choose from among 
these tab types.
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Right Tab:  Aligns the right side of text with the tab stop.

Decimal Tab:  For numbers, aligns the decimal character (such as a period or comma) 
with the tab stop. (You can specify the character to serve as the decimal tab character; 
see “Setting a New Tab Stop Using the Text Inspector” on page 92.)

You can also double-click the tab symbol repeatedly until the type of tab you want 
appears.

Changing a Tab Stop Using the Horizontal Ruler
You can change the location and type of tab stops using the horizontal ruler.

To change tab stops:
1 Click View in the toolbar and choose Show Rulers.

2 To move a tab stop, drag its blue tab symbol in the horizontal ruler.

3 To change the tab to a different type, Control-click the tab symbol and choose an 
option from the shortcut menu. Or double-click the tab symbol in the ruler repeatedly 
until the type of tab you want appears.

Deleting a Tab Stop Using the Horizontal Ruler
You can quickly remove a tab stop using the horizontal ruler.

To delete a tab stop:
1 Click View in the toolbar and choose Show Rulers.

2 Drag the tab off the horizontal ruler.

Setting Tab Stops Using the Text Inspector
Every document has built-in tab stops, usually spaced half an inch apart across the 
page. 

In the Tabs pane of the Text Inspector, you can change the default tab spacing or the 
decimal tab character for the entire document. You can also set additional tab stops in 
any paragraph, or add a leader line, so that when you press the Tab key, a dashed or 
dotted line extends across the tabbed distance. This is useful, for example, for inserting 
dashed lines between a chapter title and its page number in a table of contents.
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To open the Tabs pane of the Text Inspector:
1 Click Inspector in the toolbar.

2 Click the Text Inspector button, and then click Tabs.

Setting the Default Distance Between Tabs
Although the default distance between tab stops is usually a half inch, you can change 
the distance using the Text Inspector.

To change how far apart tabs are by default:
1 Click Inspector in the toolbar, click the Text Inspector button, and then click Tabs.

2 Use the Default Tabs field to set the default distance between tabs.

Setting a New Tab Stop Using the Text Inspector
You can use the Tab pane of the Text Inspector to add a new tab stop.

To create a new tab stop:
1 In the document, click where you want to create a new tab stop.

2 Click Inspector in the toolbar, click the Text Inspector button, and then click Tabs.

3 Click the Add (+) button in the bottom-left corner of the Tabs pane of the Text 
Inspector. The new tab stop appears in the Tab Stops column.

4 To change the tab stop location, double-click the tab stop in the Tab Stops column and 
type a new value.

Set how far you want
the first line of each

paragraph to indent.

If you want to indent a paragraph 
relative to the page margins, 
specify how far to indent it.

Add or remove tab stops 
from the column.

Choose a leader line for any 
tab stop selected in the Tab 
Stops column.

For a tab stop selected in the 
Tab Stops column, select how 
you want the text to align.

Type a new character
to change the character

used for decimal tabs.

Set the default distance 
between tabs.
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5 With the tab stop selected, select an Alignment option to indicate how you want text 
to align at the tab stop.

Left:  Aligns the left side of text with the tab stop.

Center:  Places the center of text at the tab stop.

Right:  Aligns the right side of text with the tab stop.

Decimal:  For numbers, aligns the decimal character (such as a period or comma) with 
the tab stop. 

6 To specify a decimal tab character for the document, type a new character in the 
Decimal Tab Character field.

7 If you want to add a dashed or dotted line to the tab, choose a line style from the 
Leader pop-up menu. Otherwise, choose None.

Changing a Tab Stop Using the Text Inspector
You can change the location and type of tab stops and the decimal tab character for 
the document using the Text Inspector.

To change tab stops:
1 Click Inspector in the toolbar, click the Text Inspector button, and then click Tabs.

2 To change the tab stop location, double-click the tab stop in the Tab Stops column and 
type a new value.

3 To change the tab to a different type, select an Alignment option.

4 To change the decimal tab character for the document, type a new character in the 
Decimal Tab Character field.

5 To change the leader line setting, choose an option from the Leader pop-up menu.

6 To change the default spacing between tabs, use the Default Tabs field.

Deleting a Tab Stop Using the Text Inspector
You can quickly remove a tab stop using the Text Inspector.

To delete a tab stop:
1 Click Inspector in the toolbar, click the Text Inspector button, and then click Tabs.

2 Select the tab stop you want to delete in the Tab Stops column, and then click the 
Delete (–) button.
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Setting Indents
You can modify the amount of space between the edge of a paragraph and the 
document margins. You can also adjust the amount of space between text and the 
inside border of a text box, shape, or table cell.

Setting Indents for Paragraphs Using the Text Inspector
You can use the Text Inspector to set indents for paragraphs.

To set indents using the Text Inspector:
1 Click Inspector in the toolbar, click the Text Inspector button, and then click Tabs.

2 Select the paragraph or paragraphs you want to change.

3 To set the first line indent (or overhang), specify values in the First Line and Left fields 
under Paragraph Indents. If you want the first line to be indented relative to the second 
line of text, the First Line value should be higher than the value in the Left field. If you 
want the first line to overhang the left side of the paragraph margin, the value in the 
First Line field should be lower than the value in the Left field.

4 To set off a paragraph using indentation (as when you want to include a long quote in 
your text), enter a value in the Left field and the Right field under Paragraph Indents. 

You can also drag the margin symbols in the document ruler to change the margins for 
selected paragraphs.

Setting Indents for Paragraphs Using the Horizontal Ruler
You can change indentation by dragging the indentation controls on the text ruler.

To set indents using the rulers:
1 Click View in the toolbar, and then choose Show Rulers.

2 To change the right indent, drag the right indent symbol (downward blue triangle on 
the right side of the horizontal ruler) to the position where you want the right edge of 
the paragraph to end.

3 To change the left indent, drag the left indent symbol (downward blue triangle on the 
left side of the ruler) to where you want the left edge of the paragraph to begin. 

To change the left margin independently from the left indent, hold down the Option 
key as you drag.

First line indent Right indent

Left indent
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4 To change the first line indent, drag the first line indent (blue rectangle) to where you 
want the first line to start. 

If you want the first line to remain flush with the left margin, make sure the rectangle 
aligns with the left indent symbol. 

If you want to create a hanging indent, drag the rectangle to the left of the left indent 
symbol.

Changing the Inset Margin of Text in Objects
You can change the amount of space between text and the inside border of a text box, 
shape, or table cell. This measurement is called the inset margin. The amount of space 
you specify is applied equally around the text on all sides.

To set the spacing between text and the inside border of its object:
1 If there’s no insertion point in the object, select the object. (If the insertion point is 

inside the object, press Command-Return to get out of text editing mode and select 
the object.)

2 Click Inspector in the toolbar, click the Text Inspector button, and then click Text.

3 Drag the Inset Margin slider to the right to increase the space between text and the 
inside border of the object, or type a number in the Inset Margin box and press Return. 
You can also click the arrows to increase and decrease space.

Setting Indents for Lists
To manage the indentation of bullets, numbers, and text that accompanies them in 
bulleted lists, numbered lists, and ordered lists, you use the Text Inspector. See “Using 
Bulleted, Numbered, and Ordered Lists (Outlines)” for details.

Using Bulleted, Numbered, and Ordered Lists (Outlines)
Pages provides pre-formatted bullet and numbering styles for creating simple or 
ordered lists (outlines). Bulleted and numbered lists are simple lists without the nested 
hierarchies of information like those you would see in an outline.

Generating Lists Automatically
When you use automatic list generation, Pages automatically formats a list for you 
based on what you type. To use this feature, first choose Pages > Preferences, click 
Auto-Correction, and make sure that “Automatically detect lists” is selected.

Specify how much space you 
want around text inside a text 
box, shape, or table. cell.
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Here are ways to automatically generate lists:
m To create a bulleted list, press Option-8 to type a bullet (•) or a hyphen (-), a space, 

some text, and then press Return.

m To create a list with labels that are asterisks (*) or hyphens (-), type an asterisk or a 
hyphen, a space, some text, and then press Return.

m To create a list with labels that are numbers, letters, or Roman numerals, type the 
number, letter, or Roman numeral; a period; a space; and some text. Then press Return.

You can use any of the character formats on the numbering style pop-up menu in the 
Text Inspector. To access this menu, in the Text Inspector click Bullets and choose 
Numbers from the Bullets & Numbering pop-up menu.

m To enter a new list topic at the next lower indent level, press Tab. To enter a new list 
topic at the next higher level, press Shift-Tab. 

m To end your list, press Return twice.

Note:  If you’re working in a table cell and “Return key moves to next cell” is selected in 
the Table Inspector, press Option-Return instead of Return.

Using Bulleted Lists
Although you can use automatic list generation to create a simple bulleted list, using 
the Text Inspector gives you many options for formatting bulleted lists. See “Generating 
Lists Automatically” on page 95 for information about automatic list generation.

You can also add a bulleted list style by using the List button in the Format Bar. Place 
the insertion point where you want the list to begin, click the List button in the Format 
Bar, and then select Bullet.

To add and format a bulleted list using the Text Inspector:
1 Place the insertion point where you want the list to begin.

2 Click Inspector in the toolbar, click the Text Inspector button, and then click List.

3 Choose a bullet style from the Bullets & Numbering pop-up menu.

To use a typed character as a bullet, choose Text Bullets and choose a character from 
the list or type a new character in the field.

Click to make list styles 
appear in the Styles drawer.

Select a list style to apply it 
to selected text.
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To use one of the image bullets that comes with Pages, choose Image Bullets and 
choose an image from the scrolling list.

To use your own image as a bullet, choose Custom Image and choose an image in the 
Open dialog that appears.

4 To change the size of an image bullet, specify a percentage of the original image size in 
the Size field. Or, select the “Scale with text” checkbox and specify a percentage of the 
text size; this option maintains the image-to-text size ratio of the bullets even if you 
later change the font size of text.

5 To adjust the space between bullets and the left margin, use the Bullet Indent field. To 
adjust the space between bullets and text, use the Text Indent field.

6 To position bullets higher or lower relative to text, use the Align field.

Use these techniques to add and indent bulleted items in your list:
Â To add a new topic at the current indent level, press Return. If you’re working in a 

table cell and “Return key moves to next cell” is selected in the Table Inspector, press 
Option-Return instead.

Â To create an unbulleted paragraph within a topic, press Return while holding down 
the Shift key. If you’re working in a table cell and “Return key moves to next cell” is 
selected in the Table Inspector, press Control-Return instead.

Â To enter a new topic at the next lower indent level, press Tab. To enter a new topic at 
the next higher level, press Shift-Tab. You can also click and hold a bullet, and then 
drag to the right, to the left, down and to the right, or down and to the left.
If you’re working in a table cell and “Return key moves to next cell” is selected in the 
Table Inspector, use the Indent Level controls in the List pane of the Text Inspector to 
increase or decrease the indentation of list entries.

Â To return to regular text at the end of your list, press Return and choose No Bullets 
from the Bullets & Numbering pop-up menu. You may also need to adjust the indent 
level.
If you’re working in a table cell and “Return key moves to next cell” is selected in the 
Table Inspector, press Option-Return instead of Return.

To learn about modifying list styles or creating your own list style, see “Modifying and 
Creating New List Styles” on page 129.
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Using Numbered Lists
Although you can use automatic list generation to create a simple numbered list, using 
the Text Inspector gives you many options for formatting numbered lists. See 
“Generating Lists Automatically” on page 95 for information about automatic list 
generation.

You can also choose a numbered list style in the Styles drawer. Click the Styles Drawer 
button in the Format Bar, and then select the list style. If you don’t see list styles in the 
Styles drawer, click the button in the lower-right corner of the drawer to make the 
styles appear.

Here are ways to add and format a numbered list:
m Place the insertion point where you want the list to begin, click the List button in the 

Format Bar, and then choose Numbered List.

m Place the insertion point where you want the list to begin, click Inspector in the toolbar, 
click the Text Inspector button, and then click List. Choose Numbers from the Bullets & 
Numbering pop-up menu, and then choose a numbering style from the pop-up menu 
directly below it.

To adjust the space between numbers and the left margin, use the Number Indent 
field. To adjust the space between numbers and text, use the Text Indent field.

Use these techniques to add and indent items in your list:
Â To add a new topic at the current indent level, press Return. If you’re working in a 

table cell and “Return key moves to next cell” is selected in the Table Inspector, press 
Option-Return instead. 

Â To create an unnumbered paragraph within a topic, press Return while holding 
down the Shift key. If you’re working in a table cell and “Return key moves to next 
cell” is selected in the Table Inspector, press Control-Return instead.

Â To enter a new topic at the next lower indent level, press Tab. To enter a new topic at 
the next higher level, press Shift-Tab. You can also click and hold a number, and then 
drag to the right, to the left, down and to the right, or down and to the left. 
If you’re working in a table cell and “Return key moves to next cell” is selected in the 
Table Inspector, use the Indent Level controls in the List pane of the Text Inspector to 
increase or decrease the indentation of list entries.

Â To return to regular text at the end of your list, press Return and choose No Bullets 
from the Bullets & Numbering pop-up menu. You may also need to adjust the indent 
level.
If you’re working in a table cell and “Return key moves to next cell” is selected in the 
Table Inspector, press Option-Return instead of Return.

Â To add an existing paragraph to a numbered list, click the paragraph, choose a 
numbering style, and click “Continue from previous.”
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Â To start a new numbered sequence in a list, click “Start at” and specify the number 
you want the sequence to begin with.

If you want items in your list to have labeled subtopics (like in an outline), use an 
ordered list instead of a numbered list.

To learn about modifying list styles or creating your own list style, see “Modifying and 
Creating New List Styles” on page 129.

Using Ordered Lists (Outlines)
Ordered lists (or outlines) provide different numbering styles for each indent level in a 
list, allowing you to create a hierarchy of information. For example:
Â You can create an outline using numbering sequence such as the following as you 

proceed from the highest level to lower levels: I, A, 1, a), (1), (a), i), (1), and (a).
Â You can create a legal style outline, which appends an additional number or letter at 

each lower level: 1, 1.1, 1.1.1, and so on.

You can also choose an ordered list style in the Styles drawer. Click the Styles Drawer 
button in the Format Bar, and then select the list style. If you don’t see list styles in the 
Styles drawer, click the List Styles button in the lower-right corner of the drawer to 
make the styles appear.

You can add and format ordered lists using the Text Inspector.

To add and format an ordered list:
1 Place the insertion point where you want the list to begin.

2 Click Inspector in the toolbar, click the Text Inspector button, and then click List.

3 To create a legal style list, choose Tiered Numbers from the Bullets & Numbering pop-
up menu. Otherwise, choose Numbers instead.

4 Choose a numbering style from the pop-up menu directly below it.

5 To adjust the space between numbers and the left margin, use the Number Indent 
field. To adjust the space between numbers and text, use the Text Indent field.

Use these techniques to add and indent items in your list:
Â To add a new topic at the current indent level, press Return. If you’re working in a 

table cell and “Return key moves to next cell” is selected in the Table Inspector, press 
Option-Return instead. 

Â To create an unnumbered paragraph within a topic, press Return while holding 
down the Shift key. If you’re working in a table cell and “Return key moves to next 
cell” is selected in the Table Inspector, press Control-Return instead. 
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Â To enter a new topic at the next lower indent level, press Tab. To enter a new topic at 
the next higher level, press Shift-Tab. To move among levels you can also click and 
hold a number, and then drag to the right, to the left, down and to the right, or 
down and to the left.
If you’re working in a table cell and “Return key moves to next cell” is selected in the 
Table Inspector, use the Indent Level controls in the List pane of the Text Inspector to 
increase or decrease the indentation of list entries.

Â To return to regular text at the end of your list, press Return and choose No Bullets 
from the Bullets & Numbering pop-up menu. You may also need to adjust the indent 
level. 
If you’re working in a table cell and “Return key moves to next cell” is selected in the 
Table Inspector, press Option-Return instead of Return. 

Â To add an existing paragraph to a numbered list, click the paragraph, choose a 
numbering style, and then click “Continue from previous.”

Â To start a new numbered sequence in a list, click “Start at” and specify the number 
you want the sequence to begin with.

To learn about modifying list styles or creating your own list style, see “Modifying and 
Creating New List Styles” on page 129.

Using Text Boxes, Shapes, and Other Effects to Highlight Text
Callouts and sidebars are used to make text stand out from the main body of text in a 
document. Pages offers many ways to emphasize text:
Â Adding text to text boxes
Â Adding a background (or fill color) to paragraphs
Â Adding borders and rules to text
Â Typing text in shapes

You can also use table cells to hold callouts. To read about working with tables, see 
“Working with Tables” on page 168

Adding Text Boxes
You can add text boxes to create rectangular blocks of text anywhere on your page. 
You can format text inside a text box as you would any other text, changing colors, 
adding shadows, applying styles, and so on.

Adding a Floating Text Box
When you add a text box as a floating text box, it’s anchored to a position on the page 
so that body text on the page flows around it. You can move the floating text box by 
selecting it and dragging it.



Chapter 5    Working with Text 101

 

To create a floating text box:
1 Click Text Box in the toolbar. A text box appears on the page.

In a word processing document, you can also create a floating text box by converting 
an inline text box. Choose Insert > Text Box; an inline text box appears. Click the inline 
text box to select it, and then click the Floating button in the Format Bar.

2 In the text box, double-click the highlighted placeholder text and type.

3 Drag the selection handles to resize the text box and reveal any hidden text. (Or you 
can create linked text boxes so that the overflow text flows continuously into another 
text box. To read about linked text boxes, see “Linking Floating Text Boxes” on 
page 102.)

4 When you’ve finished typing, click outside the text box. Or, to stop editing text and 
select the text box, press Command-Return.

When you click away from a text box, its boundaries are visible only if you’re using 
layout view. To use layout view, click View in the toolbar, and then choose Show Layout.

5 Drag the handles on the text box to change its width.

6 Drag the text box to position it where you want on the page.

7 To lock the text box to the page so it doesn’t accidentally get moved as you work, 
select the text box and choose Arrange > Lock.

You can also draw a floating text box. Option-click Text Box in the toolbar, release the 
Option key, and drag the crosshair pointer across the document window to create a 
text box that’s the size you want.

To learn about changing the spacing between the text and the inside of the text box 
and about changing the look of a text box, see “Formatting a Text Box or Shape” on 
page 106. 

Adding an Inline Text Box
In a word processing document, you can add an inline text box that is anchored to text 
on the page.

To add an inline text box:
1 In a word processing document, place the insertion point where you want the text box 

to appear, choose Insert > Text Box. An inline text box appears at the insertion point on 
the page.

You can also create an inline text box by converting a floating text box. Click the Text 
Box button in the toolbar; a floating text box appears. Click the floating text box to 
select it, and then click the Inline button in the Format Bar. 
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2 In the text box, double-click the highlighted placeholder text and type. The text box 
does not grow automatically if you enter too much text.

When you click away from a text box, its boundaries are visible only if you’re using 
layout view. To use layout view, click View in the toolbar, and then choose Show Layout.

3 Drag the selection handles to resize the text box and reveal any hidden text. 

The selection handles on the top of inline text boxes are inactive. You can’t drag these 
handles to resize the text box; you resize it by dragging the active handles, which are 
solid white.

4 Drag the text box to position it on the page. When the insertion point is where you 
want to place the text box, release the mouse. 

To learn about changing the spacing between the text and the inside of the text box 
and about changing the look of a text box, see “Formatting a Text Box or Shape” on 
page 106. 

Linking Floating Text Boxes
If the text you type doesn’t fit in a floating text box, you can create a linked text box so 
that the text flows from one text box to another. Whenever you edit or format the text 
in the first text box, the linked text box is also affected. Linked text boxes can be 
positioned separate from each other in the document.

Here are ways to work with linked text boxes:
m To create a floating text box, see “Adding a Floating Text Box” on page 100.

Position and resize the text box as you want, and then type text in it.

When the text box is full, a clipping indicator appears at the bottom of the text box. 
This indicates that the text extends beyond the bottom of the box.

m To link to another text box or create a linked text box, click the blue square on the right 
side of the text box, and click another text box or click somewhere on the page (or 
choose Format > Text Box > Add Linked Text Box). To cancel linking, press Escape.

A clipping indicator shows 
the text extends beyond 
the text box.

Click the blue square on the 
right to link to another text 
box or create a new linked 
text box.

A blue square on the
left indicates there are

no text boxes linked
before this one.
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The new text box has a solid blue square on its left side. This indicates that this text box 
is linked to a previous one. 

m To link selected text boxes, Command-click to select the text boxes you want to link, 
and then choose Format > Text Box > Link Selected Text Boxes. The text boxes are 
linked in the order in which you selected them.

m To break the connection between linked text boxes, choose Format > Text Box > “Break 
Connection into Text Box,” or choose Format > Text Box > “Break Connection out of 
Text Box.”

m To hide connection lines between text boxes, choose Format > Text Box > Hide 
Connection Lines. To display connection lines between text boxes, choose Format > 
Text Box > Show Connection Lines.

m To reposition the text boxes, select and drag them. The flow of the text inside the 
boxes always follows the order in which the boxes were created, regardless of where 
you position them in the document.

m To copy and paste linked text boxes, select all of them, choose Edit > Copy, and choose 
Edit > Paste without deselecting the original text boxes. The copy is pasted directly 
over the original text boxes and is selected. Drag the selected copy to its new location.

If you copy and paste a single linked box, you will create a single unlinked text box, 
identical to the one you copied.

If a single table flows through linked text boxes, you must copy or duplicate the first 
text box in which the table appears in order to copy the table as well.

m To select only the text in all the linked text boxes, select text in the first box, and then 
press Command-A.

A solid blue square on 
the right indicates this 
text box is linked before 
another one.

A blue square indicates 
this text box is the last 
in this series.

A solid blue square
on the left indicates

this text box is linked
to a previous one.
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Setting Character and Paragraph Fill Colors
For some designs, you may want to highlight text by placing a fill color behind the text. 
When you place a character or paragraph fill color behind text, the color extends 
between the layout margins and moves with the text.

Use the Format Bar controls to quickly add character or paragraph fill color to text. 
Select the text, and then click the Text or Background color well in the Format Bar.

To place a character or paragraph fill color behind text using the Text Inspector:
1 Select the text to which you want to add the fill color.

2 Click Inspector in the toolbar, click the Text Inspector button, and then click More.

3 Select the Character or Paragraph checkbox below Background Fills.

4 Click the Fill color well and select a color in the Colors window. For information about 
the Colors window, see “Using the Colors Window” on page 148.

Adding Borders and Rules
Place a line above, below, or around the text in your document. Use borders and rules 
to highlight text.

To add borders and rules to your document:
1 Select the text to which you want to add borders and rules.

2 Click Inspector in the toolbar, click the Text Inspector button, and then click More.

3 Choose a border or rule line style (or None) from the Borders & Rules pop-up menu.

4 To change the border or rule color, click the color well and select a color.

5 To adjust the thickness of a border or rule, use the controls to the right of the color 
well.

6 To insert a rule above, below, or above and below selected text, click the buttons under 
the Borders & Rules pop-up menu.

Select a fill color.

Select to place a fill 
color behind text.
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7 To insert a border around selected text, click the border button under the Borders & 
Rules pop-up menu.

8 To adjust the distance between borders and rules from selected text, use the Offset 
controls.

Presenting Text in Columns
You can organize text in a text box or a rectangular shape into columns. When text has 
filled one column, it flows into the next column.

Use the Columns pop-up menu in the Format Bar to quickly divide text into columns in 
your document.

For more options, use the Text Inspector.

To create and format columns using the Text Inspector:
1 Select the text box or rectangular shape with text you want to divide into columns.

2 Click Inspector in the toolbar, click the Text Inspector button, and then click Columns.

3 To indicate how many columns you want, use the Column field.

4 To use equal-width columns, select “Equal column width.”

To set up different column widths, deselect “Equal column width, “ double-click a 
Column value in the table, and type a new width.

5 To change the distance between columns, double-click a Gutter value and change it.

Select a line style.
Click to adjust the 
thickness of a line.

Click to adjust the 
distance between 
borders and rules 
and selected text.

Click to change line color.

Click to position rule
with selected text. Click to insert a 

border around 
selected text.
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Putting Text Inside a Shape
All shapes, except lines, can contain text.

To add text to a shape:
1 Place a shape where you want it on the page. To learn about adding shapes, see 

“Adding a Predrawn Shape” on page 151 and “Adding a Custom Shape” on page 151.

2 Double-click the shape and type the text you want. If the text extends beyond the 
border of the shape, a clipping indicator appears.

3 To resize the shape, select it and drag the selection handles. (If the insertion point is 
inside the shape, press Command-Return to get out of text editing mode and select 
the shape.)

You can format the text within a shape. You can also rotate a shape while keeping its 
text horizontal. After rotating the shape choose Format > Shape > Reset Text and 
Object Handles.

4 To add text to a shape that’s part of a group, double-click in the text area of any shape 
in the group. If you resize the group, everything resizes except for the text. Of course, 
you can still select text and change its font size. 

See “Grouping and Locking Objects” on page 147 for details about grouping objects.

Formatting a Text Box or Shape
You can change the amount of space between text and the inside border of a text box, 
shape, or table cell. See “Changing the Inset Margin of Text in Objects” on page 95 for 
instructions. 

Use the Wrap Inspector to set how you want the text on the page to wrap around a 
text box or shape. For more information about wrapping text around an object, see 
“Wrapping Text Around an Object” on page 110.

Use the Format Bar and Graphic Inspector to format borders, shadows, opacity, color 
fill, and more for text boxes or shapes. For more information about setting object 
properties, see “Modifying Objects” on page 141 and “Filling Objects” on page 147.

You can create columns in a text box or rectangle by selecting the text box or rectangle 
and choosing the number of columns you want, just as you would add columns to the 
document body. For more information about creating and formatting columns, see 
“Using Layouts” on page 44. 

The clipping indicator shows 
that text extends beyond the 
borders of a shape.



Chapter 5    Working with Text 107

 

You can also place shapes, images, and charts inside text boxes and shapes, and you 
can add tables inside text boxes. Objects added inside text boxes and shapes can only 
be added as inline objects. To read about adding inline objects, see “Using Floating and 
Inline Objects” on page 134.

Using Hyperlinks and Bookmarks
 Hyperlinks and bookmarks are used in documents that will be viewed onscreen, either 
as HTML files or as Pages documents. You can add hyperlinks to jump to another page 
or to open an email message or a webpage on the Internet. Use bookmarks to mark 
passages in the document that you want to refer to as you work.

Linking to a Webpage
You can add a hyperlink that opens a webpage in your default web browser.

To add hypertext that opens a webpage:
1 Select the text that you want to turn into a hyperlink.

If you use text that starts with “www” or “http,” the text automatically becomes a 
hyperlink. To turn off this feature, choose Pages > Preferences, click Auto-Correction, 
and deselect “Automatically detect email and web addresses.” This setting is computer-
specific, so if the document is opened on a computer with a different setting, that 
computer’s setting is used instead.

2 Click Inspector in the toolbar, click the Link Inspector button, click Hyperlink, and then 
select “Enable as a hyperlink.”

3 Choose Webpage from the Link To pop-up menu.

Use this type of hyperlink To go to Notes

Webpage A page in a web browser Provide the URL of the page you 
want to open.

Email Message A new mail message with the 
specified subject and addressee

Type the address of the email 
recipient and a subject line.

Bookmark Another page in the same 
document

Navigate quickly through the 
document as you work.
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4 Type the webpage’s address in the URL field.

Linking to a Preaddressed Email Message
You can add a hyperlink that you can click to create a preaddressed email message in 
your default mail application.

To add hypertext that links to an email message:
1 Select the text that you want to turn into a hyperlink.

If you include an email address in a document, the text automatically becomes a 
hyperlink. To turn off this feature, choose Pages > Preferences, click Auto-Correction, 
and then deselect “Automatically detect email and web addresses.” This setting is 
computer-specific, so if the document is opened on a computer with a different setting, 
that computer’s setting is used instead.

2 Click Inspector in the toolbar, click the Link Inspector button, click Hyperlink, and then 
select “Enable as a hyperlink.”

3 Choose Email Message from the Link To pop-up menu.

4 Type the email address of the intended recipient in the To field.

5 Optionally type a subject line in the Subject field.

Type the URL that you want 
to link to.

The Link Inspector button

Select to disable all
hyperlinks so that you

can easily edit them.

Type the message subject.

Type the email address of 
the message recipient.
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Linking to Pages in a Document
To make accessing specific pages in a document fast, you can add bookmarks and click 
a bookmark in the Link Inspector to go to the bookmarked page. You can also add 
hypertext that links to the bookmarked page.

Here are ways to use bookmarks in your document:
m To create a bookmark, select the text you want to turn into a bookmark. Click Inspector 

in the toolbar, click the Link Inspector button, click Bookmark, and then click Add (+).

m To jump to the bookmark in the document, click a bookmark in the list.

m To change a bookmark’s name, double-click the bookmark in the list and make the 
change.

m To sort bookmarks by name or page number, click the Name or Page column header.

m To add new bookmarks, click the Add (+) button.

m To delete a bookmark, select the bookmark in the list and click the Delete (–) button.

m To add a hyperlink that links to a bookmark, select the text you want to turn into the 
hyperlink, click Hyperlink in the Link Inspector, select the “Enable as a hyperlink” 
checkbox, choose Bookmark from the Link To pop-up menu, and then choose the 
bookmark name.

 

Click Name or Page to sort 
the bookmark list.

Click Add or Delete
to add new bookmarks

or delete a bookmark
selected in the list.

Click a bookmark to jump to 
it in the document; double-
click it to edit its name.

Choose the 
bookmark name.
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Editing Hyperlink Text
There are several ways to edit hyperlink text.

Here are ways to edit hyperlink text:
m To activate and deactivate hyperlinks, click Inspector in the toolbar, click Link, click 

Hyperlink, and then select “Make all hyperlinks inactive”.

m Click outside the hyperlink text, and use the arrow keys to move the insertion point 
into the text.

Wrapping Text Around an Object
When you place an object (images, shapes, charts, and so on), you can decide how you 
want the text to wrap around it. You can choose to make the text hug the object 
tightly or loosely, or make the text stay only above and below or on one side of the 
object. To set these options, use the Wrap Inspector.

You cannot wrap text around the sides of a table. 

To open the Wrap Inspector:
m Click Inspector in the toolbar, and then click the Wrap Inspector button.

The settings in the Wrap Inspector affect floating objects and inline objects differently.

Wrapping Text Around a Floating Object
Use the Wrap Inspector to wrap text around a floating object.

Here are ways to wrap text around a floating object:
m To wrap text using the Format Bar, select the object, and choose a text wrap option 

from the Wrap pop-up menu in the Format Bar. 

The Wrap Inspector button

Select to place an
object inline with text

or floating on the page.

Select to make text wrap 
around the object using the 
buttons below.

Set how much space to 
leave between the object 
and the surrounding text.

Click to make the text
wrap tightly or loosely

around the object.

Set the transparency 
percentage at which text can 
be seen through the object.
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m To wrap text using the Wrap Inspector, select the object, click Inspector in the toolbar, 
click the Wrap Inspector button, and then select “Object causes wrap.”

Hover the pointer over the text wrap buttons to display a summary of the different text 
wrap options. Click the text wrap button that shows the way you want text to wrap 
around an object.

Wrapping Text Around an Inline Object
Use the Wrap Inspector to wrap text around an inline object.

Here are ways to wrap text around an inline object:
m To wrap text using the Format Bar, select the object, and choose a text wrap option 

from the Wrap pop-up menu in the Format Bar. 

m To wrap text using the Wrap Inspector, select the object, click Inspector in the toolbar, 
click the Wrap Inspector button, and then select “Object causes wrap.” 

Hover the pointer over the text wrap buttons to display a summary of the different text 
wrap options. Click the text wrap button that shows the way you want text to wrap 
around an object.

Adjusting Text Around an Inline or Floating Object
Use the Wrap Inspector to adjust text around an inline or floating object.

Here are ways to adjust text around an inline or floating object:
m To make the text wrap more tightly around an object with an alpha channel, click the 

right Text Fit button. To make the text wrap more loosely, click the left Text Fit button.

Text wraps to left
of object.

Text wraps above and 
below the object.

Text wraps to right 
of object.

Text wraps around only 
right or left side, whichever 
side has more space.

Text wraps around
the object.

Align object to the
left, and wrap text

around the right.
Object is centered 
between lines of text.

Align object to the 
right, and wrap text 
around the left.

Object is aligned left 
between lines of text.

Object is aligned right 
between lines of text.

Center object, and wrap
text around both sides.
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m To specify the minimum space you want to leave between the object and the 
surrounding text, enter a value in the Extra Space field.

m To set the alpha-channel percentage at which you want the text to appear through the 
transparency, see “Removing the Background or Unwanted Elements from an Image” 
on page 161. 

Inserting Page Numbers and Other Changeable Values
You can insert such values as page numbers, page count, and date and time in a 
document by using formatted text fields, which are automatically updated by Pages 
when they change. Although values such as these are common in headers and footers 
(see “Using Headers and Footers” on page 49), you can insert formatted text fields 
anywhere in your document.

Here are ways to insert formatted text fields:
m To add page numbers, place the insertion point where you want the page number to 

appear, and then choose Insert > Page Number.

To change the page number format, Control-click a page number and choose a new 
number format.

m To add the total page count, place the insertion point where you want the page count 
to appear, and then choose Insert > Page Count.

To include the total page count with each page number, such as “2 of 10,” add a page 
number, type “of,” and then choose Insert > Page Count.

To change the page count format, Control-click a page count and choose a new 
number format.

m To add and format the date and/or time, place the insertion point where you want the 
value to appear, and then choose Insert > Date & Time.

To change the date and time format, Control-click the date and time value, choose Edit 
Date & Time, and then choose a date and time format from the pop-up menu. If you 
want the document to always show the current date and time, select “Automatically 
update on open.”

Text wraps around
the rectangular bounds

of an object.
Text wraps around an object with 
an alpha channel more tightly.
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Using Automatic Hyphenation
By default, Pages automatically hyphenates words if they need to break at the end of a 
line.

Here are ways to turn hyphenation on or off:
m To turn hyphenation for the entire document on or off, click Inspector in the toolbar, 

click the Document Inspector button, and then select or deselect Hyphenate (in the 
Document pane).

m To turn off hyphenation for a particular paragraph, select the paragraph, click Inspector 
in the toolbar, click the Text Inspector button, click More, and then select “Remove 
hyphenation for paragraph.”

m To turn hyphenation on or off for a word, click the word while holding down the 
Control key, and then choose Never Hyphenate or Allow Hyphenation from the 
shortcut menu.

Automatically Substituting Text
 Pages can be set to recognize and replace text you don’t want with text you do want. 
For example, when you type “teh,” Pages can automatically change it to “the.”

To set up automatic text substitution:
1 Choose Pages > Preferences. 

2 Click Auto-Correction and make settings as desired.

To automatically convert single and double quotation marks to smart quotes so that 
opening and closing quotation marks are not identical, select “Use smart quotes.”

To make sure that the first word in a sentence begins with a capital letter, select “Fix 
capitalization.”

To automatically convert the letters in “1st,” “2nd,” “3rd,“ and so on into superscripts, 
select “Superscript numerical suffixes.”

To set Pages to automatically detect that something you’ve typed is an email address 
or a URL, select “Automatically detect email and web addresses.” Email and web 
addresses you type automatically become hyperlinks for Mail or Safari.

To use automatic list generation, select “Automatically detect lists.”

To replace one or more characters with one or more different characters, select “Symbol 
and text substitution.” Then use the rows in the table to define and activate specific 
substitutions. For example, when you type (c), you can have Pages automatically 
convert it to © by putting a checkmark in the On column. To add a row to the table to 
define your own substitution, click the Add (+) button. To remove a selected item, click 
the Delete (–) button.
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After you specify substitution settings, they’ll apply to any text you change or add in 
any Pages document.

Inserting a Nonbreaking Space
You can insert a nonbreaking space between words to make sure that the words 
always appear in the same line of text.

To insert a nonbreaking space:
m Press the Space bar while holding down the Option key.

Checking for Spelling and Proofreading Documents
Pages can catch spelling and writing errors in your document.

Finding Misspelled Words
You can set the spell checker to flag spelling errors as you type, or you can check your 
entire document or selected text at any time. 

Misspelled words appear with a red dashed line below them. 

Here are ways to find misspelled words:
m To check spelling as you type, choose Edit > Spelling > Check Spelling as You Type.

To turn off spell checking as you type, click Edit > Spelling > Check Spelling as You Type 
to deselect it (make sure the checkmark is not visible next to the menu command).

m To check spelling from the insertion point to the end of the document, click to place 
the insertion point and choose Edit > Spelling > Check Spelling. To limit spell checking 
to a specific part of the document, select the text you want to check before choosing 
the command.

The first misspelled word found is highlighted. You can correct it or choose the same 
menu command again to continue checking the document. 

To go through the text more quickly, press Command-semicolon (;) to continue 
checking the document.

m To check spelling and view suggestions for misspelled words, choose Edit > Spelling > 
Spelling.

The Spelling window opens, and you can use it as “Working with Spelling Suggestions” 
on page 114 describes.

Working with Spelling Suggestions
Use the Spelling window to work with alternative spellings.
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To work with spelling suggestions:
1 Choose Edit > Spelling > Spelling. 

The Spelling window opens and the first misspelled word is highlighted.

Each language has a different spelling dictionary. To make sure that the correct 
language is selected, click Inspector in the toolbar, click the Text Inspector button, and 
then click More. Select a language from the Language pop-up menu.

2 To replace the incorrect spelling in the text, double-click the correct word or spelling in 
the Guess list.

3 If the correct word doesn’t appear in the Guess list but you know the correct spelling, 
select the misspelled word in the Spelling window, type the correct word, and click 
Correct.

4 If the current spelling is correct and you want to leave it as it is, click Ignore or Learn. 
Use Learn if the term is one you use often and you want to add the term to the spelling 
dictionary. 

If you used Learn and want to undo the effect of the Learn operation, type the word 
into the text field below the Guess list, and then click Forget.

5 If no alternate spellings appear in the Guess list, select the misspelled word in the 
Spelling window and try a different spelling. Click Guess to see whether new 
possibilities appear in the Guess list.

6 Click Find Next and repeat steps 3 through 6 until you find no more spelling errors.

You can also hold down the Control key and click a misspelled word. From the pop-up 
menu you can choose an optional alternative spelling, click Learn, or click Ignore.

Proofreading Documents
You can set the Proofreader to flag writing errors as you type, or you can check your 
entire document or selected text at any time.

Proofreading identifies the following types of writing errors:

Â Improper capitalization
Â Punctuation errors (for example, inconsistent spacing around dashes)
Â Duplicated words
Â Overly complex word choices (for example, “eventuate” instead of “take place”)
Â Formatting errors (for example, abbreviations that should be spelled out in formal 

writing)
Â Parts-of-speech errors (for example, using “an” instead of “a”)
Â Jargon
Â Misspellings
Â Gender-specific expressions
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To find writing errors:
m To check writing errors as you type, choose Edit > Proofreading > Proofread as You 

Type.

To turn off proofreading as you type, click Edit > Proofreading > Proofread as You Type 
to deselect it (make sure the checkmark is not visible next to the menu command).

m To check writing errors from the insertion point to the end of the document, click to 
place the insertion point and choose Edit > Proofreading > Proofread. To limit checking 
to a specific part of the document, select the text you want to check before choosing 
the command.

The first error found is highlighted. You can correct it or choose the same menu 
command again to continue checking the document. 

m To check writing errors and view suggestions for corrections, choose Edit > 
Proofreading > Proofreader.

Finding and Replacing Text
You can find every instance of a word or phrase in your document, and optionally 
change it to something else. 

Here are ways to find and replace text:
m Choose Edit > Find > Find, click Simple or Advanced to set up find/replace criteria, and 

then click a button to conduct find/replace operations.

Simple: In the Find field, type the text you want to find, and type any text you want to 
replace it with in the Replace field.

Advanced: In addition to typing Find and Replace text, you can set up additional find/
replace criteria.

Replace All: Automatically conducts the find/replace operation without your review.

Replace: Replaces the current selection with the replacement text.

Replace & Find: Replaces the current selection with the replacement text and 
immediately finds the next occurrence of the Find text.

Next or Previous: Finds the next or previous occurrence of the Find text.

m Use the other commands on the Edit > Find submenu.

Find Next or Find Previous: Finds the next or previous occurrence of the current Find 
text.

Use Selection for Find: Finds the next occurrence of the selected text.

Jump to Selection: Displays the selected text when it’s not currently in view.
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Searching for All Occurrences of Words and Phrases
 You can generate a list of all occurrences of a specific word or phrase (including 
placeholder text) in your document. If you select a search result in the list, the page 
containing the matching text is displayed in the main viewing area, and the text is 
highlighted. 

After selecting an item in the search results list, double-click the item or press Return or 
Enter to select the matching text and edit it in the main view.

Pages searches for a match to the word or phrase in the main body text, headers and 
footers, tables, text boxes, shapes, footnotes and endnotes, and comments.

To conduct a search:
1 Show the search sidebar by clicking View in the toolbar and choosing Show Search.

2 Type the word or phrase you want to search for in the search field. Results, with page 
references and some text that appears before or after the word or phrase, are listed as 
you type. Searches are not case sensitive, and you can’t search for invisibles. For 
example, you can’t paste the paragraph symbol into the search field and search for it.

3 To view an item in the search results list on the page where it occurs, click the item. The 
page is displayed with the word or phrase highlighted. 

4 To edit a word or phrase selected in the search results list, double-click it or press 
Return or Enter. Type to replace the selected text, or click the text to edit it.

5 To list the results of any of the last ten searches since opening the document, click the 
disclosure triangle in the search field and select a previous search from the list. The 
results for the selected search string appear in the list.

To hide the search sidebar, click View in the toolbar and choose Hide Search.

Type the word or phrase.

Select an item in the 
resulting list to view where 
the word or phrase occurs 
in the document.
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6 Working with Styles

This chapter explains how to apply paragraph, character, and 
list styles to quickly and consistently change the appearance 
of text. It also describes how to modify existing styles or 
create your own.

As you write and format your document, you may want to create different looks for 
different types of text and paragraphs. For example, you may want to have all top-level 
headings use the same font, color, and line spacing, or you may want all callout text or 
photo captions to have the same look. 

The simplest way to make sure that text is consistently formatted is to apply styles. 
Pages Word Processing and Page Layout templates include a variety of styles that are 
suited to the type of document you are working in. The style names, such as Heading, 
Body, or Caption, suggest where the style should be used. If you are using a template, 
you can apply the preset styles where you need them. You can also change template 
styles or create your own styles.

Applying consistent styles is also important if you’re creating a table of contents in a 
word processing document. To learn more about creating a table of contents, see 
“Using a Table of Contents” on page 58.
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About Styles
A style is predefined formatting that you can apply to text with a click of your mouse. 
For example, if your document contains a style named Chapter Heading that centers 
text, makes it bold, and increases the font size to 18 points, you can select text, open 
the Styles drawer, and then click Chapter Heading. The text automatically centers, 
changes to bold, and resizes to 18 points.

There are three kinds of styles.

Â Paragraph styles:  These styles can be applied only to entire paragraphs (chunks of 
text that end with a carriage return), not to individual words within paragraphs. 
These include styles for headings, body text, callouts, captions, headers, and footers. 
Paragraph styles can include specifications for font, size, text color, character and line 
spacing, text shadow, background color, indentation and margins, tab settings, and 
more. If you want to create a table of contents for your word processing document, 
you need to use paragraph styles when creating headings in your document. Most 
documents will use a greater variety of paragraph styles than character or list styles.

Â Character styles:  You can apply a character style to any group of characters, including 
individual words or groups of words, or letters within a paragraph. Common 
examples of character styles are different colors or font sizes used to emphasize 
individual words or phrases. Character styles can be applied to text within a 
paragraph without changing its paragraph style.

Â List styles:  When you want to create simple lists or an outline, you can apply list styles 
to your text. List styles automatically format your text with bullets or numbering, 
depending on which kind of list style you choose. You can also indent paragraphs as 
a block by changing their list indent level (see “Using Bulleted, Numbered, and 
Ordered Lists (Outlines)” on page 95). Some list styles are very basic, for simple lists; 
others, such as Harvard and Legal, allow you to create outlines.

The Styles drawer displays all the styles for the document you’re working in. 

Here are ways to show or hide the Styles drawer:
m Click the Styles Drawer button in the Format Bar.

m Click View in the toolbar, and then choose Show Styles Drawer or Hide Styles Drawer.

If you don’t see character or list styles displayed in the Styles drawer, click the Show 
Character Styles or Show List Styles button in the bottom-right corner of the Styles 
drawer.
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Applying Styles
There are several techniques for applying styles to paragraphs, characters, and lists.

Here are ways to apply styles:
m To apply a style to one or more paragraphs, select the paragraphs you want to change, 

or select an entire text box, table, table cell, or shape that contains text. Click the 
Paragraph Styles button in the Format Bar, and then choose the style you want to 
apply.

A paragraph style applies to an entire paragraph. Applying a new paragraph style to 
already-styled text replaces the current paragraph or list style.

m To apply a character style, select the word or words you want to change, or select an 
entire text box, table, table cell, or shape that contains text. Click the Character Styles 
button in the Format Bar, and choose the style you want to apply. 

A character style can be applied to selected text without affecting margins, text 
alignment, or other types of paragraph or list formatting. Additionally, character styles 
are preserved even when you change the paragraph or list style of text.

m To apply a list style, place the cursor wherever you want to begin typing your list, click 
the List style button in the Format Bar, choose the style you want to apply, and then 
type your list, pressing Return to begin each new bulleted or numbered point.

A list style applies to an entire paragraph. It does not affect the appearance of text 
(such as font, text size, and so on) that’s governed by the underlying paragraph style.

In the Styles drawer, 
select the style you 
want to apply.
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If you don’t see character or list styles displayed in the Styles drawer, click the Show 
Character Styles or Show List Styles button in the bottom-right corner of the Styles 
drawer.

Importing Styles From Another Document
When you import a document from Microsoft Word, any styles it contains are imported 
into the Pages document and can then be used like any other styles created within 
Pages.

You can import styles that have already been defined in another Pages document 
without importing the document’s content.

To import styles from a Pages document:
1 Choose Format > Import Styles.

2 Select the document that contains the styles you want to import, and then click Open.

3 Select the styles you want to import in the dialog. Hold down the Command key as you 
click the style names to select multiple styles, or click Select All.

4 To replace styles in your document that have the same name as the styles you are 
importing, select “Replace duplicates.” Note that replacing a style will affect any text 
that uses this style; replacing a style also changes the style of text in locked objects, but 
the text retains its original appearance.

If an imported style has the same name as a style in the open document and you do 
not select “Replace duplicates,” a number is appended to the name of the imported 
style. For example, if you import a style called Body to a document that already 
contains a Body style, the imported style will be named Body 2.

5 Click OK.

Imported paragraph styles will be available by clicking the Paragraph Style pop-up 
menu in the Format Bar and in the Styles drawer of your document. Imported character 
and list styles will be available in the Styles drawer.

To maintain a consistent look among several documents, keep a master document that 
contains all the styles you need. When you need to change a style, change it in the 
master document and import the master document’s styles into the other documents.

Click to show list styles.

Click to show 
character styles.
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Changing the Style of Text
Most of the time you change the style of text by selecting the text and applying a 
different style. Usually you use the techniques described in “Applying Styles” on 
page 120, but you can also change styles by using a find/replace or copy/paste 
operation.

When you make changes to individual text attributes without selecting, replacing, or 
pasting a new style, you have created a style override. For example, you create a style 
override when you use the Font command in the Format menu to apply italics to a 
paragraph of text formatted with the paragraph style named Body. The text remains 
formatted in its original style (Body), but you have applied changes (italics) on top of 
the default style attributes. 

When you select text to which you have applied style overrides, the arrow next to the 
style name in the Styles drawer is red. (The arrow next to a paragraph style name also 
appears red if you have selected text with a character or list style applied.)

Overrides can occur when you change the font, typeface, size, or color of text, or apply 
the text formatting options in the Text submenu of the Format menu, in the Font panel, 
in the Format Bar, or in the Text Inspector.

If you apply style overrides to some text and then change your mind, you can easily 
return the text to the default attributes of the paragraph style.

To remove style overrides:
1 Click the Styles Drawer button in the Format Bar to open the Styles drawer. 

2 Select the text you want to change.

3 In the Styles drawer, click the arrow to the right of the selected style and choose Revert 
to Defined Style (or double-click the style name). The selected text takes on the default 
attributes of the selected style.

Finding and Replacing a Style
If you want to change the look of your document by changing all instances of a style to 
a different one, you can find and replace the style throughout the document without 
searching for specific text.

To find and replace a style:
1 Click on an example of text that uses the style you want to change in the document.

2 Click the Styles Drawer button in the Format Bar to open the Styles drawer. 

When the arrow next to a style 
name is red, it means that you 
have applied changes to this 
style in the selected text.
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3 In the Styles drawer, rest the pointer over the name of the style that you want to 
replace and click the arrow to the right of its name.

4 Choose “Select All Uses of style name.” All instances of the style in the text body 
throughout the document are selected.

To find and replace the styles in the text body plus all text boxes and shapes, choose 
Edit > Find > Find. Click Advanced to open the Advanced tab. Select the style to be 
replaced and the Style to replace it with. Click Replace All.

5 Select the name of the style to which you want to change the selected text.

Copying and Pasting Character and Paragraph Styles
You can copy the paragraph or character style of selected text and apply it to different 
text in the same document by pasting it.

You can also copy paragraph formatting to another Pages document.

To copy and paste a paragraph or character style:
1 Place the insertion point in a paragraph or word whose style you want to copy.

2 Choose Format > Copy Paragraph Style, or choose Format > Copy Character Style.

3 Place the insertion point in a paragraph or word you want to modify, or select multiple 
paragraphs or words to modify.

4 Choose Format > Paste Character Style, or choose Format > Paste Paragraph Style.

To copy a paragraph or character style to another Pages document, switch to the other 
document before choosing Format > Paste Style.

The text takes on the new style, but its content is not altered.

Modifying and Creating New Paragraph Styles
A paragraph is any block of text followed by a Return character. For these blocks of text 
(including headings, body text, footers, callout text, and so on) you can define the 
appearance, tab spacing, margins, background color, page breaks, and more using 
paragraph styles.

If you don’t find a paragraph style with exactly the look you want in the Pages 
templates, you can modify an existing style or create a new style.

Modifying Paragraph Styles
Change a paragraph’s appearance, tab stops, margins, background color, page breaks, 
and more by modifying its paragraph style.
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To modify a paragraph style:
1 Click the Styles Drawer button in the Format Bar to open the Styles drawer.

Select the paragraph style that most closely matches the style you want to design, or 
select Free Form.

2 Type some text and format it to look the way you want. For information about 
formatting the look of text, see “Formatting Text Size and Appearance” on page 75.

3 Set the text alignment, character and line spacing, and the spacing before and after the 
paragraph using the controls in the Format Bar or in the Text pane of the Text 
Inspector. For more information, see “Setting Text Alignment, Spacing, and Color” on 
page 84.

4 If the paragraph style requires special tab stops, set them in the Tabs pane of the Text 
Inspector. For more information, see “Setting Tab Stops Using the Text Inspector” on 
page 91.

5 If you want the paragraph style to be indented relative to the page margins, set the 
paragraph indents in the Tabs pane of the Text Inspector.

6 Click More in the Text Inspector to select more formatting options.

Set the first line indent.
Set the right indent for 
the paragraph.

Set the left indent for 
the paragraph.

Choose border and rules 
formatting options for 
selected text.

Select options to
determine how the

paragraph breaks
across pages. Choose a language for the 

spelling dictionary to use.
Remove automatic

hyphenation or ligatures,
if they are selected for

the document.

Set the text above or below 
the surrounding text.

Choose a paragraph style 
to follow the current one 
when you press Return.

Add a background
color to a character

or paragraph.
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Border & Rules:  Selected text can be separated in a document by adding a line above or 
below or by framing the text with a border. Specify line style, placement, and color 
using the Borders & Rules pop-up menu, buttons, and color well.

Background Fills:  Select a checkbox and click the color well to make a color background 
appear behind a character or a set of characters or one or more paragraphs. For 
example, you can create a heading style that presents white text against a dark 
background. The color extends from the left paragraph margin to the right.

Following Paragraph Style:  If you want a particular paragraph style to always follow the 
current style when you press the Return key, choose the style from the pop-up menu. 
For example, you might create a photo caption style that should always be followed by 
a byline style.

Pagination & Break:  Select how the paragraph can break across pages. You can specify 
that lines of this paragraph should always stay together on the same page, should stay 
with the following paragraph, or can only appear at the top of a page. The last two of 
these are particularly useful for heading styles. Select “Prevent widow & orphan lines” to 
prevent leaving individual lines on the following or previous pages.

Language:  Choose a language from the pop-up menu to specify the language used to 
spell-check this paragraph. If your document will include quotes or sections in another 
language, you can specify a language for the spelling dictionary used in those 
paragraphs. The spelling dictionary determines how words are spelled and hyphenated.

Remove hyphenation for paragraph:  Select this checkbox if you want to turn off 
automatic hyphenation for this paragraph style in a document that has automatic 
hyphenation turned on. (To turn it on for the document, select Hyphenate in the 
Document pane of the Document Inspector.)

Remove ligatures:  A ligature is a stylish flourish between letters or at the end or 
beginning of lines. Ligatures are used by some fonts to combine two or more text 
characters into one glyph. Select this checkbox if you don’t want to use ligatures in a 
selected paragraph that has ligatures turned on. (To turn it on for the document, use 
the Document Inspector. If any text is selected when you remove ligatures, it will be 
applied to the selected text as a style override, unless you complete step 7, below.)

Baseline Shift:  A negative number places the text lower than the surrounding text. A 
positive number places the text higher than the surrounding text. Enter a number in 
the field. (If any text is selected when you set the baseline shift, it will be applied to the 
selected text as a style override, unless you complete step 7, below.)
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7 In the Styles drawer, click the arrow to the right of the paragraph style name, and then 
choose an option.

Create New Paragraph Style From Selection:  This doesn’t alter the existing style, but 
creates a new style based on the formatting choices you’ve made in the previous steps. 
If you select this, type a name for the new style, and then click OK.

Redefine Style From Selection:  Redefines the existing paragraph style for the whole 
document. If you choose this, your formatting changes will apply to all other instances 
of this style throughout the document. (But any character styles that have been 
applied will not be affected.)

Revert to Defined Style:  Removes style overrides and the selected text takes on the 
default attributes of the selected style.

Creating New Paragraph Styles
Customize a paragraph’s appearance, tab stops, margins, background color, page 
breaks, and more by creating a new paragraph style.

To create a new paragraph style from scratch:
1 Click the Paragraph Styles button in the Format Bar, and select Free Form at the top of 

the Paragraph Styles list.

2 Select a paragraph of text.

3 Set up attributes for the selected paragraph text as “Modifying Paragraph Styles” on 
page 123 describes.

4 Press and hold the Add (+) button at the bottom of the Styles drawer, and then choose 
Create New Paragraph Style From Selection.

5 Type a name for the new style in the dialog that appears.

6 If you don’t want to apply the new style to the selected text, deselect “Apply this new 
style on creation.”

7 Click OK.

Styles you modify or create are available only in the document you’re working in. 
However, they can be imported into other documents. To learn how, see “Importing 
Styles From Another Document” on page 121.

Press and hold to 
create a style.
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Modifying and Creating New Character Styles
Character styles are formatting attributes that are applied to a set of text characters 
(such as a word or a group of words or letters) without changing the style of the entire 
paragraph. Character styles define the look of the text, including font, size, color, 
character spacing, ligature usage, baseline shift, and language. 

If you can’t find a character style that meets your needs, you can modify one of the 
existing character styles or create a new one.

Modifying Character Styles
Change the look of text, including font, size, color, character spacing, ligature usage, 
baseline shift, and language, by modifying its character style.

To modify a character style:
1 Click the Character Styles button in the Format Bar and select the character style that 

most closely matches the style you want to design, or select None.

2 Type some text and then apply some attributes.

Select a font typeface and size. For more information, see “Using the Format Bar to 
Format Text” on page 75.

Set the text color. For information about changing the color of text, see “Changing Text 
Color” on page 89.

Set the character spacing. For more information about setting character spacing, see 
“Setting Text Alignment, Spacing, and Color” on page 84.

3 Use the More pane of the Text Inspector to specify additional attributes.

Language:  Choose a language from the pop-up menu to specify the language used to 
spell-check this paragraph. If your document will include quotes or sections in another 
language, you can specify a language for the spelling dictionary used in those 
paragraphs. The spelling dictionary determines how words are spelled and hyphenated.

Remove ligatures:  A ligature is a stylish flourish between letters or at the end or 
beginning of lines. Ligatures are used by some fonts to combine two or more text 
characters into one glyph. Select this checkbox if you don’t want to use ligatures in a 
selected paragraph that has ligatures turned on. (To turn ligatures on for the 
document, select “Use ligatures” in the Document pane of the Document Inspector. If 
any text is selected when you remove ligatures, the change will be applied to the 
selected text as a style override, unless you complete step 4, below.)

Baseline Shift:  A negative number places the text lower than the surrounding text. A 
positive number places the text higher than the surrounding text. Enter a number in 
the field. (If any text is selected when you set the baseline shift, the change will be 
applied to the selected text as a style override, unless you complete step 4, below.)
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4 In the Styles drawer, click the arrow to the right of the character style name, and then 
choose an option.

Redefine Style From Selection:  Redefines the existing character style for the whole 
document. If you choose this, your formatting changes will apply to all other instances 
of this style throughout the document.

Create New Character Style From Selection:  This doesn’t alter the existing style, but 
creates a new style based on the formatting choices in the previous steps. If you select 
this, you can choose which attributes you want to include as part of the new character 
style. Click the disclosure triangle below the Name field in the “New character style” 
dialog, and then select the attributes you want. Type a name for the new style, and 
then click OK.

Creating New Character Styles
Customize the look of text, including font, size, color, character spacing, ligature usage, 
baseline shift, and language, by creating a new character style.

To create a new character style from scratch:
1 Select some text.

2 Set up attributes for the selected text as “Modifying Character Styles” on page 127 
describes.

3 Press and hold the Add (+) button at the bottom of the Styles drawer and choose 
Create New Character Style From Selection from the pop-up menu.

4 Type a name for the new style.

Click the disclosure
triangle to show

character attributes.

Click to select only those 
attributes that override the 
selected paragraph style.

Select the attributes 
to include in the new 
character style.
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5 If you want to include only some of the attributes you set in the new character style, 
click the disclosure triangle below the Name field, and then select the attributes you 
want.

6 If you don’t want to apply the new style to the selected text, deselect “Apply this new 
style on creation.”

7 Click OK.

Modifying and Creating New List Styles
List styles are used to create bulleted and numbered lists. You can also create ordered 
lists (outlines). 

If you can’t find a list style that meets your needs, you can modify one of the existing 
list styles or create a new one.

Modifying Bulleted or Numbered List Styles
Change the look of bulleted or numbered lists by modifying the list style.

To modify a bulleted or numbered list style:
1 Click Inspector in the toolbar, click the Text Inspector button, and then click List.

2 Make sure the insertion point is visible on the page, click the List Styles button in the 
Format Bar, and then select the bulleted or numbered list style that best matches the 
one you want to design. 

Click to advance to the 
next list indent level.

Adjust bullet size and 
position relative to text.

Choose bullets or
numbering.

Select an image
for image bullets.

Adjust bullet indentation 
relative to the first 
paragraph indent.

Set the text indent level
relative to the bullets.
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3 Choose one of the following bullet or numbering styles from the Bullets & Numbering 
pop-up menu in the List pane of the Text Inspector.

No Bullets:  Choose this if you don’t want visible bullets, but you want to be able to 
specify the amount of indentation for levels in an ordered list.

Text Bullets:  Choose this to use a text character as the bullet. You can select one from 
the list or type your own characters in the text field. Some fonts provide symbols that 
can be used as interesting bullets. To use them, open the Character Palette (choose 
Format > Font > Show Fonts, then choose Characters from the Action pop-up menu). 
Select the bullet symbol in the Text Inspector, and then double-click the symbol of your 
choice in the Character Palette. Then press the Return key.

Image Bullets:  Choose this to use one of the available image bullets provided by Pages, 
and then select one in the list.

Custom Image:  Choose this to use your own image as a bullet. Use the Open dialog to 
locate and select the image file you want to use. (To change the image, click Choose or 
drag a new image into the well.)

Select a color for 
the text bullet.

For text bullets, choose
an available character

or type a character
in the text field.

For image bullets, select 
one from the list.
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Numbers:  Choose this to create a numbered list. You must also choose a numbering 
style. You can choose Arabic numerals, Roman numerals, or letters.

4 Format the bullets.

To increase or reduce the size of a bullet, specify a number in the Size field. Selecting 
“Scale with text” maintains the image-to-text size ratio of the bullets even if you later 
change the font size.

To position the bullet symbol higher or lower relative to the text, specify a number in 
the Align box.

To set how far the bullets are indented from the margin, specify a number in the Bullet 
Indent field. A higher number indents the list further to the right.

To set how far text is indented from the bullet, specify a number in the Text Indent 
field. A higher number indents the text further to the right.

5 Click the Styles Drawer button in the Format Bar to open the Styles drawer.

Notice that one of the list styles is highlighted. This is the style that has been applied to 
the selected text. (If the list styles are not visible, click the button in the bottom of the 
Styles drawer.) The arrow to the right of the style name is red, indicating that you have 
applied overrides to the style by modifying it.

6 Click the red arrow to the right of the selected style in the Styles drawer and choose an 
option.

Redefine Style From Selection:  Redefines the existing list style for the entire document. If 
you choose this, your formatting changes will apply to all other instances of this style 
throughout the document.

Create New List Style From Selection:  This doesn’t alter the existing style, but creates a 
new style based on your formatting choices. If you select this, type a name for the new 
style, and then click OK.

For numbered lists, choose 
a numbering style.

Restart numbering, or continue 
with previous numbering.

Adjust number indentation 
relative to page margin.

Adjust text indentation 
relative to the bullet.
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Modifying a Tiered List Style for Ordered Lists
Change the look of Legal style lists by modifying the style.

To modify a tiered list style:
1 Make sure the insertion point is visible on the page, click the Styles Drawer button in 

the Format Bar to open the Styles drawer, and then select the Legal list style that best 
matches the one you want to design.

2 Click Inspector in the toolbar, click the Text Inspector button, and then click List.

3 Choose the numbering or lettering style that you want from the second pop-up menu.

4 Click the right indent level arrow to advance to the second list indent level.

5 Choose the numbering or lettering style that you want for the second list indent level.

6 Repeat steps 6 and 7 until you have set numbering or lettering styles for up to nine list 
indent levels.

7 Click the Styles Drawer button in the Format Bar to open the Styles drawer.

Notice that one of the list styles is highlighted. This is the style that has been applied to 
the selected text. (If the list styles are not visible, click the button in the bottom-right of 
the Styles drawer.) The arrow to the right of the style name is red, indicating that you 
have applied overrides to the style by modifying it.

8 Click the red arrow to the right of the list style name, and then choose an option.

Redefine Style From Selection:  Redefines the existing list style for the entire document. If 
you choose this, your formatting changes will apply to all other instances of this style 
throughout the document.

Create New List Style From Selection:  This doesn’t alter the existing style, but creates a 
new style based on your formatting choices in the previous steps. If you choose this, 
type a name for the new style, and then click OK.

Click to advance to the next 
list indent level.

 Tiered Numbers
is selected for a
Legal style list.

For each list indent level, 
choose a numbering style.

For each list indent level, set 
how far you want to indent the 
number and its associated text.
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Creating New List Styles
Customize the look of a list by creating a new list style.

To create a new list style:
1 Select some text.

2 Click Inspector in the toolbar, click the Text Inspector button, and then click List.

3 Format the selected list text so that it looks the way you want. See “Modifying Bulleted 
or Numbered List Styles” on page 129 and “Modifying a Tiered List Style for Ordered 
Lists” on page 132 for instructions.

4 Press and hold the Add (+) button at the bottom of the Styles drawer, and then choose 
Create New List Style From Selection from the pop-up menu.

5 Type a name for the new style.

6 If you don’t want to apply the new style to the selected text, deselect “Apply this new 
style on creation.”

7 Click OK.

Renaming a Style
You can change the name of any style that appears in the Styles drawer.

To rename a style:
1 Click the Styles Drawer button in the Format Bar to open the Styles drawer.

2 Hold the pointer over the style you want to rename, and then click the arrow to the 
right of the style and choose Rename Style.

3 Type a new name for the style and press Return.

Deleting a Style
When you delete a style from a document, you need to choose a different style to 
replace it.

To delete a style:
1 Click the Styles Drawer button in the Format Bar to open the Styles drawer.

2 Hold the pointer over the style you want to delete, and then click the arrow to the right 
of the style and choose Delete Style.

3 If the style you want to delete is being used in the current document, choose a style to 
replace it.

4 Click OK. 
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7 Working with Shapes, Graphics, 
and Other Objects

This chapter describes techniques for adding and modifying 
images, shapes, sound, and other objects.

An object is an item you can add to a document and then manipulate. Images, shapes, 
movies, sound files, tables, charts, and text boxes are all objects.

Images include photographs or PDF files. Movies and sound are for documents that will 
be viewed onscreen. Shapes include simple predrawn shapes (such as triangles and 
arrows) and custom shapes that you draw yourself. Text boxes hold text, shapes, 
images, movies, sound, tables, and charts.

This chapter tells you how to add specific kinds of objects, how to resize and move 
them around, and how to modify their color, shadows, alignment, and other settings.

Using Floating and Inline Objects
If you want an object to remain in place so that text on the page flows around it, use a 
floating object. 

Floating objects are anchored to a position on a page. Typing more text on the page 
does not affect the position of a floating object, but you can drag a floating object to 
reposition it. Drag any of its selection handles to resize it.

If you want the object embedded in text flow so it is pushed along as the text grows, 
use an inline object.

Drag any of the selection 
handles to resize floating 
objects.
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Inline objects are embedded in the text flow. If you type more text above them, they 
are pushed along as the text grows. The selection handles on the top of inline objects 
are inactive. You cannot drag these handles to resize the object; you can only resize it 
by dragging the active handles.

If you are placing a graphic or shape inside another shape, text box, or table cell, it can 
only be added as an inline object. Inline images are automatically resized to fit within 
the layout margins of the document. To move an inline object to a different position 
within the text, select it and drag it until you see the insertion point appear where you 
want to drop it.

If you’ve added an object as one kind of object and you want to turn it into the other 
kind of object, you can easily do so.

Here are ways to convert between floating and inline objects:
m Select the floating or inline object you want to convert, and then click the Floating or 

Inline button in the Format Bar.

m Select the floating or inline object you want to convert, click Inspector in the toolbar, 
click the Wrap Inspector button, and then select “Inline (moves with text)” or “Floating 
(doesn’t move with text)”.

Selecting Objects
Before you can move, modify, or perform other operations on objects, you must select 
them. A selected object has handles that let you move or manipulate the object.

Here are ways to select and deselect objects:
m To select a single object, click anywhere on the object (to select an object that has no 

fill, click the edge).

m To select several objects, hold down the Shift key as you click objects. All the objects 
must be floating, or they must all be inline.

m To select all the floating objects in a document, press the Command key, and then click 
anywhere outside the text areas so the insertion point isn’t visible. Press Command-A.

m To select all the inline text and objects in a document, place the insertion point in the 
text area and press Command-A.

The top selection 
handles are inactive 
for inline objects.

Drag the active selection 
handles down or to the 
right to resize.

A close-up view of 
inactive selection handle 
(top) and active selection 
handle (bottom)
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m To select an object that’s part of a group, you must first ungroup the objects. Select the 
group, and then choose Arrange > Ungroup.

m To deselect objects in a group of selected objects, hold down the Command key, and 
then click objects you want to deselect.

m To select a master object, first choose Format > Advanced > Make Master Objects 
Selectable.

m To select a floating object that’s behind text, place the pointer outside the text area, 
press the Command key, and then drag across the page until the object’s selection 
handles appear.

Copying or Duplicating Objects
The technique you use to copy an object depends on where you want to place the 
copy. When the copy will be far from the original or in another document, copying and 
pasting is generally easier. When you're working with an object that is floating on a 
page and the copy will be near the original, duplicating is generally easier.

Here are ways to copy objects:
m To copy and paste a floating or inline object, select it, and then choose Edit > Copy. 

Click where you want the copy to appear. Choose Edit > Paste.

m To duplicate a floating or inline object within the same document, you can hold down 
the Option key while you drag the object.

You can also duplicate the object. Select the object, and choose Edit > Duplicate. The 
copy appears on top of the original, slightly offset. Drag the copy to the desired 
location.

You can't duplicate an inline object. To duplicate an object, it must be floating on the 
page.

m To copy an image between documents, select the image and drag its icon from the File 
Info field in the Metrics Inspector to a page in another Pages document.

Deleting Objects
Deleting objects is quick and easy.

To delete objects:
m Select the object(s) and press the Delete key.

If you accidentally delete an object, choose Edit > Undo Delete.
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Moving Objects
The way you move an object depends on whether it’s a floating or inline object.

Here are ways to move objects:
m To move a floating object, click the object to select it (the selection handles appear), 

and then drag it to a new location.

m To constrain the object’s motion to horizontal, vertical, or a 45 degree angle, start 
dragging the object while holding down the Shift key.

m To move the object in small increments, press one of the arrow keys, causing the object 
to move a point at a time. To move the object ten points at a time, hold down the Shift 
key while pressing an arrow key.

m To show the position of the object when you move it, choose Pages > Preferences, and 
then select “Show size and position when moving objects” in the General pane. 

m To precisely align objects, you can also use alignment guides. See “Spacing Objects 
Evenly on a Page” on page 139 for additional information.

m To move an inline object, click the object to select it, and then drag it until the 
insertion point appears where you want the object in the text.

You can also select the object and choose Edit > Cut. Place the insertion point where 
you want the object to appear, and then choose Edit > Paste.

Avoid dragging an object by the selection handles because you may inadvertently 
resize the object.

Moving an Object Forward or Backward
When floating objects overlap or when text and floating objects overlap, you can 
change the order of objects in the stack.

To move a floating object in front or in back of text or another object:
1 Select the object you want to move.

2 To move an object a layer at a time, choose Arrange > Bring Forward or Arrange > 
Send Backward.

3 To move an object to the very top or bottom of the stack, choose Arrange > Bring to 
Front or Arrange > Send to Back.

If you’re unable to select an object, it may be a background object. For more 
information about working with background objects see, “Moving an Object to the 
Background” on page 138.

If you frequently layer objects, you can add the Front, Back, Forward, and Backward 
buttons to the toolbar to work more efficiently. To learn about customizing the toolbar, 
see “The Toolbar” on page 22.
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Moving an Object to the Background
In your word processing document, you can send an object to the background to have 
it automatically become non-selectable. This enables you to move other objects and 
select text without affecting the object in the background.

Here are ways to work with background objects:
m To make an object a background object, select the object, and then choose Arrange > 

Send Object to Background.

m To reposition or edit a background object, choose Arrange > Make Background Objects 
Selectable, select the object, and then reposition or edit the object.

m To move an object from the background to the foreground of the page, choose 
Arrange > Make Background Objects Selectable, select the background object, and 
then choose Arrange > Bring Background Objects to Front. Now you can move the 
object forward or backward as “Moving an Object Forward or Backward” on page 137 
describes.

m To determine whether an object is a background object, choose Arrange > Make 
Background Objects Selectable, and then move the pointer over the object. If the 
pointer becomes a white arrow, the object is a background object. When you move the 
pointer over an object that’s not a background object, it becomes a black arrow 
instead.

Aligning Objects
You can quickly align objects relative to one another if they appear on the same page.

To align objects:
1 Select the objects you want to align.

2 Choose Arrange > Align Objects, and then choose one of the alignment options in the 
submenu.

Left:  Positions objects so that their left edges align vertically to the first object you 
select.

Center:  Positions objects so that their centers align vertically to the first object you 
select.

Right:  Positions objects so that their right edges align vertically to the first object you 
select.

Top:  Positions objects so that their top edges align horizontally to the first object you 
select.

Middle:  Moves objects vertically so that their centers align horizontally to the first 
object you select.

Bottom:  Positions objects so that their bottom edges align horizontally to the first 
object you select.
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If you select a single object or several objects that don't appear on the same page, 
objects are aligned relative to the edges of the page.

You can also align floating objects relative to one another by dragging them and using 
alignment guides to determine when the objects are correctly positioned. See “Spacing 
Objects Evenly on a Page” for more information. 

Spacing Objects Evenly on a Page
You can quickly place an equal amount of space between objects, regardless of their 
size.

To space objects evenly:
1 Select the objects.

2 Choose Arrange > Distribute Objects, and then choose an option from the submenu.

Horizontally:  Adjusts the horizontal spacing between objects.

Vertically:  Adjusts the vertical spacing between objects.

Using Alignment Guides
As you move floating objects around in a document, blue alignment guides can be 
used to help you center and align objects on the page. 

Alignment guides will appear when the center or edge of an object aligns with the 
center or edge of another object, or with the center of the page, depending upon your 
preferences. You can also create your own alignment guides to help you place objects 
in the same position on different pages.

Alignment guides aren’t visible when you print your document; they are visible only 
when you’re editing a document.

To temporarily hide alignment guides, hold down the Command key while you drag an 
object. 

Changing How Alignment Guides Appear
You can turn alignment guides on or off in Pages preferences. You can also make 
alignment guides appear only when floating object edges are aligned, or only when 
object centers are aligned.

To change alignment guide settings:
1 Choose Pages > Preferences, and then click General.

2 To show or hide guides when an object’s center aligns with another object or the 
center of the page, select or deselect “Show guides at object center.”
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3 To show or hide guides when an object’s edges align with another object, select or 
deselect “Show guides at object edges.”

4 To change the color of alignment guides, click the color well and select a color in the 
Colors window.

Alignment guide settings apply to all documents viewed in Pages until you change the 
settings again.

Creating New Alignment Guides
You can create your own alignment guides to help you place floating objects in the 
same position on different pages.

To create an alignment guide:
1 Click View in the toolbar, and then choose Show Rulers.

2 Place the pointer over a ruler, click, and drag onto the page. An alignment guide 
appears.

3 Drag the guide where you want it on the page.

Note:  Alignment guides can’t be created if you have an insertion point in text, such as 
the body text or header. Select a floating object or Command-click the document page.

To remove an alignment guide that you’ve created, drag it off the edge of the page.

Setting Precise Positions of Floating Objects
You use the Metrics Inspector to precisely locate floating objects.

To set the precise position of a floating object:
1 Select the object you want to position.

2 Click Inspector in the toolbar, and then click the Metrics Inspector button.

3 Enter X and Y values in the Position fields.

The specified coordinates determine the position of the upper-left corner of the 
object’s container box.

Â The X value is measured from the left edge of the page.
Â The Y value is measured from the top edge of the page.

If an object is rotated, the X and Y coordinates specify the upper-left corner of the 
rotated container box.
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When you enter X and Y coordinates for line positions in the Metrics Inspector, the Start 
coordinates represent the first endpoint you created. If you later flip or rotate the line, 
the Start coordinates continue to represent the first endpoint.

Modifying Objects
You can resize objects, change their orientation, modify their border styles, add 
shadows and reflections to them, and adjust their opacity.

Resizing Objects
You can resize an object by dragging its handles or typing exact dimensions.

Here are ways to resize objects:
m To resize an object by dragging, select the object and then drag one of its selection 

handles. To resize an object in one direction, drag a side handle instead of a corner 
handle. For inline objects, only the bottom and right or left corner selection handles 
can be used.

To resize the object from its center, press the Option key as you drag.

To maintain an object's proportions, hold down the Shift key as you drag. You can also 
click Inspector in the toolbar, click the Metrics Inspector button, and then select 
“Constrain proportions” before dragging.

To show the size of an object when you drag a selection handle, choose Pages > 
Preferences, and then select “Show size and position when moving objects” in the 
General pane.

m To resize an object using exact proportions, select the object, click Inspector in the 
toolbar, click the Metrics Inspector button, and then use the Width and Height controls. 

m To resize several objects at once, select the objects, click Inspector in the toolbar, click 
the Metrics Inspector button, and then type new values in the Width and Height fields.

m Select the object, and then click Original Size in the Metrics Inspector.

Position a floating line on the page 
by specifying X and Y coordinates 
for its second endpoint.

Position a floating line on the page 
by specifying X and Y coordinates 
for its first endpoint.
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Flipping and Rotating Objects
You can flip or rotate any object. For example, if you have an image of an arrow that 
you want to use in your document, but you need it to point in a different direction, you 
can reverse its direction vertically or horizontally, or point it at any angle.

Here are ways to change an object’s orientation:
m To flip an object horizontally or vertically, select the object, and then choose Arrange > 

Flip Horizontally or Arrange > Flip Vertically.

You can also click Inspector in the toolbar, click the Metrics Inspector button, and then 
use the Flip buttons.

m To rotate an object, select the object, hold down the Command key and move the 
pointer toward an active selection handle until it changes to a curved, double-headed 
arrow, and then drag a selection handle.

To rotate an object in 45-degree increments, press the Shift and Command keys while 
dragging a selection handle.

You can also click Inspector in the toolbar, click the Metrics Inspector button, and then 
drag the Rotate wheel or use the Angle controls to set the angle of the object.

m To rotate a shape but keep its text horizontal, after rotating the shape choose Format > 
Shape > Reset Text and Object Handles.

You can’t rotate an inline table. To rotate a table, it must be a floating object.

Changing the Style of Borders
For shapes, chart elements, text boxes, and table cells, you can choose a line style and 
color for the object’s border, or you can specify no border. You can also put a border 
around imported images. You set border line style and color using the Graphic 
Inspector and the Colors window.

Use the Format Bar to quickly change the line style and color of a border. Select the 
object, and select the line style and line color from the controls in the Format Bar.

To set the line style and color of a border using the Graphic Inspector:
1 Select the object that you want to modify.

2 Click Inspector in the toolbar, and then click the Graphic Inspector button.

3 Choose Line from the Stroke pop-up menu.
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4 Choose a line style from the pop-up menu.

5 To change the line thickness, type a value in the size field (or click the arrows).

6 To change the line color, click the color well and select a color.

7 To give a line endpoints, such as arrowheads or circles, choose left and right endpoints 
from the pop-up menus.

Framing Objects
Enclose your images, shapes, text boxes, movies, and media placeholders with 
graphical borders, known as picture frames.

Here are ways to work with picture frame borders:
m To add a picture frame border, select the media or media placeholder, click Inspector in 

the toolbar, and then click the Graphic Inspector button. 

Choose Picture Frame from the Stroke pop-up menu, and then click the thumbnail to 
choose one.

Some picture frames can be adjusted. To adjust your border, use the Scale slider or type 
a specific percentage in the adjacent field. 

Enter the line thickness 
in this field.

Choose line endpoints 
from these pop-up menus.

Choose a solid line,
dotted line, dashed line,

or another line style.

Click the color well to 
choose a line color.

Click this arrow or the 
thumbnail to choose a 
frame style.
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m To change a picture frame, select a framed media or media placeholder, click Inspector 
in the toolbar, and then click the Graphic Inspector button. Choose Picture Frame from 
the Stroke pop-up menu, and then click the arrow next to the thumbnail to choose a 
new picture frame.

m To remove a border from your media or media placeholder, select the media or media 
placeholder and then choose a line style (or None) from the Stroke pop-up menu.

Adding Shadows
Shadows give your objects an appearance of depth. An object’s shadow appears on 
any object behind it. You can create a variety of shadow effects, or remove the shadow 
from an object.

Use the Shadow control in the Format Bar to quickly add a shadow to an object. Select 
the object, and then select Shadow in the Format Bar.

To add a shadow to an object using the Graphic Inspector:
1 Select the object.

2 Click Inspector in the toolbar, and then click the Graphic Inspector button.

3 Select Shadow to add a shadow to the object. Deselect Shadow to make a shadow go 
away.

4 Set the angle for the shadow using the Angle controls.

5 To set how far the shadow is from the object, use the Offset controls. A high shadow 
offset value makes an object’s shadow appear longer and slightly separated from the 
object.

6 To adjust the softness of the shadow’s edge, use the Blur controls. A high blur value 
makes the object’s shadow appear more diffuse; a low value gives the shadow more 
sharply defined edges.

7 To change the shadow’s transparency, use the Opacity controls. Don’t use the Opacity 
slider at the bottom of the Graphic Inspector, which is for controlling the opacity of the 
object itself.

Change the shadow
color in the color well.

Change the angle of the 
shadow with the Angle wheel.

Offset, Blur, and Opacity values can 
change the look of the shadow.

Select the checkbox to add a 
shadow to a selected object.
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8 To change the color for the shadow, click the Shadow color well and select a color.

You can also use the Graphic Inspector shadow controls to add shadows to text. Select 
the text to which you want to add shadows, and use the controls as described above.

Adding a Reflection
You can add a reflection to an object that reflects vertically downward.

Here are ways to add a reflection to an object:
m Select the object, and then select Reflection in the Format Bar.

m Select the object, click Inspector in the toolbar, click the Graphic Inspector button, 
select Reflection, and then drag the slider to increase or decrease the amount of 
reflection.

This object has
the default shadow

properties.

This object’s
shadow is set to a

different angle.

This object’s shadow has 
a high offset value.

This object’s shadow has 
the lowest blur factor.

This object has a different 
shadow color.

This object’s shadow has 
a high blur factor.
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Adjusting Opacity
Use the Opacity controls in the Format Bar or the Graphic Inspector to quickly create 
interesting effects by making objects more opaque or less opaque. 

When you put a low-opacity object on top of another object, the bottom object shows 
through the top object. Depending on how high or low you set the opacity, the objects 
below can be highly visible, partly obscured, or completely blocked from view (at 100-
percent opacity).

Here are ways to change an object’s opacity:
m Select the object, click the Opacity pop-up menu in the Format Bar, and then select a 

percentage.

m Select the object, click Inspector in the toolbar, click the Graphic Inspector button, and 
then drag the Opacity slider or enter a percentage in the adjacent field.

For shapes, you can set opacity for fill and stroke colors separately from object opacity. If 
you move the Opacity slider in the Colors window to modify a fill or stroke color, that 
opacity value becomes maximum object opacity. Then, when you change the object 
opacity in the Graphic Inspector, you are changing it relative to the opacity you set in 
the Colors window.

 

If you change an object's opacity and then can't restore the object's fill color to 100%, it 
may be because the opacity was set to less than 100% in the Colors window. To fix it, 
select the object, choose View > Show Colors, and then set the opacity in the Colors 
window to 100%.

This circle is set to 100% opacity in the 
Graphic Inspector. The fill color was set 
to 50% opacity in the Colors window. 
The circle’s outline was set to 100% 
opacity in the Colors window.

This circle is set to 100% 
opacity in the Graphic 
Inspector.

This circle is set to 50% opacity 
in the Graphic Inspector.
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Grouping and Locking Objects
Group objects you want to keep together, and lock objects you don’t want to 
inadvertently move.

Grouping and Ungrouping Objects
You can group floating objects together so that they can be moved, copied, resized, 
and oriented as a single object. You can edit text associated with a shape or text object 
in a group, but you can’t modify other attributes of individual objects in the group. 

To group objects:
1 Hold down the Command (or Shift) key as you select the objects you want to group. 

The objects can’t be locked.

2 Choose Arrange > Group. 

To ungroup a grouped object, select the group, and then choose Arrange > Ungroup. If 
the group is locked, unlock it first.

Locking and Unlocking Objects
You can lock floating objects to avoid inadvertently moving them as you work. Inline 
objects cannot be grouped or locked.

After you lock individual or grouped objects, you can’t move, delete, or modify them 
until you unlock them. A locked object can be selected, copied, or duplicated; when 
you copy or duplicate a locked object, the new object is also locked.

To lock objects:
1 Hold down the Command (or Shift) key as you select the objects you want to lock.

2 Choose Arrange > Lock.

To unlock an object, select the object, and then choose Arrange > Unlock.

Filling Objects
Fill an object with a solid color, a color gradient, or an image.

Filling an Object with Color
Use the Format Bar to quickly fill an object with a solid color or a color gradient, in 
which two colors gradually blend with each other. Select the object, click the Fill 
control in the Format Bar, and then select a fill color.

Use the Graphic Inspector to fill an object with a solid color or a color gradient, in 
which two colors gradually blend with each other.
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To change an object’s fill color using the Graphic Inspector:
1 Select the object.

2 Click Inspector in the toolbar, and then click the Graphic Inspector button.

3 To apply a solid fill color, choose Color Fill from the Fill pop-up menu. Click the color 
well below the Fill pop-up menu to open the Colors window, and then select a color in 
the Colors window.

4 To fill an object with a color gradient, choose Gradient Fill from the Fill pop-up menu. 
Click each color well and choose each color in the Colors window.

To set a direction for the gradient, use the Angle wheel or field. To flip it horizontally or 
vertically, click the Angle arrow buttons.

To invert the gradient, click the double-headed arrow next to the color wells.

Instructions for using the Colors Window follow.

Using the Colors Window
You use the Colors window to select color for objects.

Click each color well
to select colors.

Flip the gradient orientation 
or set its direction by using the 
arrow buttons or the Angle 
wheel, or by typing a value.

Click the double-headed 
arrow to invert the gradient.

The color selected in the color 
wheel appears in this box. (The 
two colors in this box indicate the 
opacity is set to less than 100%.)

Use the slider to set lighter or 
darker hues in the color wheel.

Drag colors from the color box to 
store them in the color palette.

Click to select a color
in the color wheel.

Drag the Opacity slider to the left to 
make the color more transparent.

Click the Search icon
and then click any
item on the screen
to match its color.

Click a button to view
different color models.



Chapter 7    Working with Shapes, Graphics, and Other Objects 149

 

You can use the color wheel in the Colors window to select colors. The color you select 
appears in the box at the top of the Colors window. You can save that color for future 
use by placing it in the color palette.

To apply the colors you select in the Colors window to an object on the page, you must 
place the color in the appropriate color well in an Inspector pane. You can select a color 
well in one of the Inspectors, and then click a color in the color wheel. Or you can drag 
a color from the color palette or color box to a color well in one of the Inspectors.

To select a color:
1 Open the Colors window by clicking the color well in the Format Bar and choosing 

Show Colors, or click Colors in the toolbar, or click a color well in one of the inspectors.

2 Click anywhere in the color wheel. The selected color is displayed in the color box at 
the top of the Colors window.

3 To make the color lighter or darker, drag the slider on the right side of the Colors 
window.

4 To make the color more transparent, drag the Opacity slider to the left or enter a 
percentage value in the Opacity field. 

5 To use the color palette, open it by dragging the handle at the bottom of the Colors 
window. Save a color in the palette by dragging a color from the color box to the color 
palette. To remove a color from the palette, drag a blank square to the color you want 
to remove.

6 To match the color of another item on the screen, click the magnifying glass to the left 
of the color box in the Colors window. Click the item on the screen whose color you 
want to match. The color appears in the color box. Select the item you want to color in 
the document window, and drag the color from the color box to the item. 

Filling an Object with an Image
You can fill a shape, text box, table, table cell, chart background, or chart series with an 
image.

To fill an object with an image:
1 Select the object you want to fill with an image.

2 Click Inspector in the toolbar, and click the Graphic Inspector button.

3 In the Graphic Inspector, choose Image Fill or Tinted Image Fill from the Fill pop-up 
menu, and then choose an image.
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You can also drag an image file from the Finder or Media Browser to the image well in 
the Graphic Inspector.

4 Choose an image scale from the pop-up menu.

Scale To Fit:  Resizes the image to fit the object’s dimensions as well as possible. If the 
object’s shape is different from the original image’s, parts of the image may not appear; 
blank space may also appear around the image.

Scale To Fill:  Makes the image appear larger or smaller, sizing it to leave minimum space 
around the image, even if the object and image have different shapes.

Stretch:  Sizes the image to fit the object’s dimensions but distorts it if the object has a 
shape different from the original image.

Original Size:  Places the image inside the object without altering its original 
dimensions. If the image is larger than the object, you see only a part of the image in 
the object. If the image is smaller than the object, there is blank space around it.

Tile:  Repeats the image inside the object, if the image is smaller than the object. If the 
image is larger than the object, you see only part of the image inside the object.

Use the pop-up menu to 
set the size of the image 
within the object.

To change the image, 
drag an image to the 
image well.

Scale to Fill

Tile (large image)

Original Size

StretchScale to Fit

Tile (small image)

Tile (large image)
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5 If you chose Tinted Image Fill, click the color well (to the right of the Choose button) to 
choose a tint color. Drag the Opacity slider in the Colors window to make the tint 
darker or lighter. (If you drag the Opacity slider in the Graphic Inspector, it will change 
the opacity of both the tint and the image.)

Using Shapes
Pages comes with a variety of predrawn shapes. You can also create your own shapes, 
as well as edit both shapes and custom shapes.

Adding a Predrawn Shape
You can insert predrawn shapes, such as triangles, arrows, circles, and rectangles, to use 
as simple graphics.

Here are ways to add a predrawn shape:
Â To add a floating predrawn shape, click Shapes in the toolbar and then choose a 

predrawn shape from the Shapes submenu.
Â To add an inline predrawn shape, place the insertion point where you want the 

predrawn shape to appear, and choose Insert > Shape > shape type. 

You can also draw a shape. Option-click Shapes in the toolbar, release the Option key 
and choose a shape from the Shapes submenu, and then drag the crosshair pointer 
across the document window to create a shape that’s the size you want. To constrain 
the shape (for example, to keep triangles equal on all sides), press the Shift key as you 
drag. 

Adding a Custom Shape
 You can use the Draw tool to create your own shapes. 

 When you first create a custom shape, it’s inserted as a floating object, but you can 
make it an inline object if you like.

To create a custom shape:
1 Click Shapes in the toolbar, and then select the Draw tool icon.

You can also choose Insert > Shape > Draw a Shape.

Click to select a tint color 
for the image.
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2 The pointer changes from an arrow to a small pen tip. 

Click anywhere in your document to create the first point of the custom shape.

3 To create a second point and connect it with the first point using a straight line, click a 
second location. 

To create a curved segment instead of a straight one, click in the second location and 
then drag the mouse to change the curve angle or extend the curve. Release the 
mouse when you’re satisfied with the curve.

The line that connects the two points has the default stroke style for the template 
you’re using. You can change the line into another kind of line later using the Stroke 
settings in the Graphic Inspector.

4 Repeat step 3 to create additional points as required. Every time you add a new point, 
Pages connects it with the preceding point using a line with the current stroke and 
with the first point using no stroke, and fills the shape with the default fill color for the 
template you’re using. You can change the fill color later using the Fill settings in the 
Graphic Inspector.

To delete a segment you’ve just created, press Delete. Pressing Delete again removes 
the preceding segment, too.

5 To stop drawing and close the shape (add a solid line between the last and first points), 
click the first point.

To stop drawing and leave the shape open (no line between the last and first points) so 
that you can work with it more later, press the Esc (Escape) key or double-click the last 
point created. 

To finish and close an open shape, click once in the shape to select it, and then click it a 
second time to show its points. Double-click one of the two points at either end of the 
open segment. The pointer changes to a pen tip.

If you want to add additional points, click other locations as needed. When you’re ready 
to stop drawing and close the shape, click the point at the end of the open segment.

Making Shapes Editable
Before you can edit a shape, you need to make it editable.

Here’s the open segment.
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Here are ways to make shapes editable:
m To make a predrawn shape editable, select the shape and then choose Format > 

Shape > Make Editable. 

Red dots appear on the shape. Drag the points to edit the shape. Later, to edit a 
predrawn shape that has been made editable, click it twice slowly.

m To make a custom shape editable, click once in the shape to select it, and then click a 
second time to show its points. You can also choose Format > Shape > Make Editable.

Manipulating Points of a Shape
You can change the contour of a shape by adding, moving, or deleting its points.

Here are ways to manipulate a shape’s points:
m To add a point, make the shape editable, press the Option key, and hold the pointer 

over the shape’s border. The pointer changes into a pen tip with a plus sign (+). Click 
the location on the border where you want to add a point, and move the point if 
needed.

m To move a point, make the shape editable, click the point, and then drag it to another 
location. You can move several points at the same time by Shift-clicking multiple points 
and then dragging. 

m To delete a point, make the shape editable, click the point, and then press the Delete 
key. You can delete several points at the same time by Shift-clicking multiple points 
and then pressing Delete.

Click a point and drag it 
to change the shape.
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Reshaping a Curve
You can expand or contract a curve, or change its angle.

To reshape a curve:
1 Make the shape editable.

2 Click a red circular control on the curve you want to reshape. A control handle appears 
on both sides of the circular control.

3 To expand or contract the curve, drag the circular control or one of the control handles.

4 To change the angle of the curve, move the control handles clockwise or counter-
clockwise. You achieve different effects when you move the handles together or 
independently of each other. Experiment until you achieve the desired effect.

To move the control handles together, press the Option key, and then drag one or the 
other of them. 

To move only one control handle, press the Command key before dragging a handle.

Reshaping a Straight Segment
You can change the angle between two segments, or change the length of a segment.

To reshape a straight segment:
1 Make the shape editable.

2 Click a corner point.

3 To change the angle between the two attached segments, drag the point clockwise or 
counter-clockwise.

4 To change the length of one of the segments, drag the point out or in.

Drag a control handle 
or rotate one or both 
control handles to 
change the curve.

You can also drag a point 
to modify the curve.
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Transforming Corner Points into Curved Points and Vice Versa
You can change one or more points into curves or curves into points.

Here are ways to transform corner points into curved points and vice versa:
m To change a corner point into a curved point, make the shape editable, and then 

double-click the corner point.

m To change a curved point into a corner point, make the shape editable, and then 
double-click the curved point.

m To change all corner points in one or more shapes into curved points, make the shapes 
editable, select the shape(s), and then choose Format > Shape > Smooth Path. 

m To change all curved points in one or more shapes into corner points, make the shapes 
editable, select the shape(s), and then choose Format > Shape > Sharpen Path.

After a shape is editable, you can use the Smooth Path and Sharpen Path commands 
without making the shape editable again.

Editing Specific Predrawn Shapes
Some predrawn shapes have special built-in editing controls.

Editing a Rounded Rectangle
The rounded rectangle has a circular control that lets you change the corners.

 To edit a rounded rectangle:
m Select the shape, and drag its circular control to the left to straighten the corners and 

to the right to round them.

Editing Single and Double Arrows
The arrows have three special controls.

Drag to straighten or 
round the corner.

Drag to change
the tail length.

Drag up or down to 
change the width of the 
tail. Drag left or right to 
resize the arrowhead.



156 Chapter 7    Working with Shapes, Graphics, and Other Objects 

 

 Here are ways to edit single and double arrows after selecting them:
m Drag the selection handle on the arrow’s tail or tip of the arrowhead to increase or 

decrease the tail’s length without changing the shape of the arrowhead.

m Drag the circular control up or down to change the width of the tail.

m Drag the circular control left or right to resize the arrowhead.

Editing a Star
The star shape has a slider for increasing and decreasing the number of points in the 
star and a circular control for changing the angles between points. 

Here are ways to edit a star:
m  When you select a star shape, the slider appears. Drag the slider to increase or 

decrease the number of points in the star.

m Drag the circular control to change the angles between points in the star.

Editing a Polygon
The polygon has a slider for increasing and decreasing the number of sides in the 
polygon.

To edit a polygon:
m When you select the polygon, the slider appears. Drag the slider to increase or 

decrease the number of sides in the polygon.

Drag to change the angles 
between points in the star.

View the number of points 
currently in the star.

Drag to increase or 
decrease the number 
of points in the star.

Drag to increase or 
decrease the number of 
sides in the polygon.

View the number of sides 
currently in the polygon.
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Using Media Placeholders
Many Pages templates contain media placeholders. You can drag your own images, 
movies, and audio files to these placeholders, and your media file is automatically sized 
and positioned for you. You can easily replace an item in a media placeholder by 
dragging a new file to it; you don’t have to delete the old file first.

You can recognize a media placeholder by letting the pointer rest over it; a help tag 
appears instructing you to drag your own image into its place.

Here are ways to work with media placeholders:
m Drag a file from the Media Browser, Finder, or other application to the media 

placeholder.

To open the Media Browser, click Media in the toolbar. Click a button at the top of the 
window to look for images, audio files, or movies.

m To change the content of a media placeholder, drag a new media file to the existing 
content.

m To convert a placeholder image to an image, select the image, choose Format > 
Advanced > Define as Media Placeholder (remove the checkmark).

m To delete a media placeholder, select it and press the Delete key.

Second, choose a source.

First, click a button to 
access your media files. 

Third, drag an item to the 
document or to an image 
well in one of the 
Inspectors.

Search for a file by typing 
its name here.
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m To create a media placeholder, follow the instructions in “Creating Media Placeholders” 
on page 238.

Working with Images
Pages accepts all QuickTime-supported formats, including the following graphics file 
types:
Â TIFF
Â GIF
Â JPEG
Â PDF
Â PSD
Â EPS
Â PICT

After importing an image into a document, you can mask (crop) it and change its 
brightness and other settings. You can place an image inside a shape, text box, chart 
element, or table cell. Pages also lets you work with graphics with transparency (alpha-
channel graphics). 

Adding Images
You can import an image as a floating object or as an inline object.

Importing an Image as a Floating Object
Import an image as a floating object when you want it to remain in a particular place 
on a page.

Here are ways to add an image file as a floating object:
m Drag an image file from the Finder to the document and position it where you want it.

m Click Media in the toolbar, click the Photos button in the Media Browser window, select 
the album where your picture is located, and then drag a thumbnail to position it 
where you want it.

m Command-click outside the text areas in the document so that no insertion point is 
visible, and then choose Insert > Choose. Select the file and click Insert. Drag the image 
to position it where you want it.

Importing an Image as an Inline Object
In a word processing document, you can import an image as an inline object when you 
want it to flow with its surrounding text.
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Here are ways to add an image as an inline object:
m Press the Command key, and then drag an image file from the Finder to the document 

window until you see the insertion point at the place where you want the image to 
appear. Release the image when you have placed it where you want it.

m Click Media in the toolbar, click the Photos button in the Media Browser window, select 
the album where your picture is located, press the Command key, and then drag a 
thumbnail to the document window, releasing the image when the insertion point is at 
the place where you want the image to appear.

m Place the insertion point wherever you want the image to appear, choose Insert > 
Choose, select the image file, and then click Insert.

Masking (Cropping) Images
You can crop images without actually changing the image files by masking parts of 
them. 

Cropping an Image Using the Default (Rectangular) Mask
You can use a rectangular mask to define the boundaries of an image.

To crop an image using the default (rectangular) mask:
1 Import the image you want to mask (see “Importing an Image as a Floating Object” on 

page 158 and “Importing an Image as an Inline Object” on page 158 for instructions).

2 Select the image, and then click the Mask button in the Format Bar or select the image, 
and then choose Format > Mask. A resizable mask appears over the image, and some 
mask controls are displayed.

3 To resize the image, drag the slider above the Edit Mask button.

4 Refine the mask by doing any of the following:

Â To resize the mask, drag the selection handles. To constrain the mask’s proportions, 
hold down the Shift key as you drag.

Â To rotate the mask, hold down the Command key as you drag a corner selection 
handle.

Drag the selection handles 
to resize the mask.

Drag the image to 
position the part you 
want to show.

Drag the slider to resize 
the image.

Click to show or hide the 
area outside the mask.
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5 Drag the image to position the part you want to show. To move the mask, click the 
dotted edge of the mask and drag it.

6 To make only the area under the mask visible, double-click the mask or image, press 
Return, click outside the image, or click Edit Mask.

7 To resize or rotate the masked image, drag or Command-drag its selection handles.

8 To reposition the image, drag it.

9 To deselect the image and hide the mask controls, click outside the image.

Masking an Image with a Shape
You can use a shape to define the boundaries of an image.

To mask an image with a shape:
1 Do one of the following:

Â Select the image and choose Format > “Mask with Shape” > shape. See “Importing an 
Image as a Floating Object” on page 158 and “Importing an Image as an Inline 
Object” on page 158 for instructions.

Â Shift-click to select a shape and an image, and choose Format > “Mask with Selected 
Shape.” See “Selecting Objects” on page 135 for more information about working 
with shapes. If the image you import is floating, the shape must be, too. If the image 
is inline, the shape must also be inline.

2 Drag the image to position it over the area you want to show. To move the mask, click 
the dotted edge of the mask and drag it.

3 To resize the image, drag the slider above the Edit Mask button.

4 To resize the mask, drag the selection handles.

5 To make only the area under the mask visible, double-click the mask or image, press 
Return, click outside the image, or click Edit Mask. 

6 To resize the masked image, click Edit Mask and drag the selection handles.

7 To deselect the image and hide the mask controls, click outside the image.

To modify a masked image, double-click it.

Note:  If you use a shape containing text as a mask, the text is deleted. To restore the 
text, choose Edit > “Undo Mask with Shape.”

To use a custom shape (as described in “Adding a Custom Shape” on page 151), drag an 
image to the shape, or select the image and the shape and then choose Format > Mask 
with Selected Shape.

You can also drag an image to mask a shape with an image.
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Unmasking an Image
You can remove a mask and restore the original image.

To unmask an image:
m Select the masked image, and click the Mask button in the Format Bar or choose 

Format > Unmask or click the Mask button on the Format Bar.

Removing the Background or Unwanted Elements from an Image
The Instant Alpha tool enables you to convert certain colors in an image to transparent. 
This feature is useful for removing an unwanted background or other colors. 

You’ll get the best results removing solid colors with clear boundaries around them. To 
remove areas that are less distinct, select a smaller area and repeat the process.

To remove unwanted elements:
1 Select the image.

2 Choose Format > Instant Alpha.

3 Click the color you want to make transparent, and then drag slowly over it.

As you drag, the selection grows to include the contiguous area that uses similar colors. 
You can control how much of the image is selected by dragging less or more.

4 Repeat step 3 as many times as you like.

Dragging selects the
contiguous area that
uses the same color.

Dragging more here...

...selects more of 
the image.
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You can restore the parts removed from the image at any time. To revert to the original 
image, choose Format > Remove Instant Alpha. To restore parts of the image removed 
using Instant Alpha, choose Edit > Undo Instant Alpha until the parts have been 
restored.

Changing an Image’s Brightness, Contrast, and Other Settings
 You can change the brightness, contrast, and other settings of images to improve their 
quality or to create interesting effects. Adjustments you make don’t affect the original 
image; they affect only the image’s appearance in Pages.

To adjust an image:
1 Select the image.

2 Click the Adjust Image Window button in the Format Bar or choose View > Show 
Adjust Image to display the Adjust Image window.

3 Use the controls to make adjustments.

Brightness:  Adjusts the lightness of the image.

Contrast:  Adjusts the contrast of light and dark tones. You can make shadows darker, 
sharpen the edges of objects, and make colors stand out more. If you increase the 
contrast of an image a lot, it looks more like an illustration.

Saturation:  changes the color intensity.

Adjust the contrast of light 
and dark tones.

Change the color intensity.
Introduce more

warmth or coolness. Change the amount of red 
or green tones.

Sharpen or soften
the focus.

Adjust shadows and highlights.

Understand the relationship 
between shadows and highlights.

Change the levels of dark 
and light tones.

Restore original settings.

Enhance colors automatically.

Adjust the lightness.
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Temperature:  Introduces more warmth (more orange tones) or coldness (more blue 
tones).

Tint:  Changes the amount of red or green tones in the image.

Sharpness:  Sharpens or softens the image’s focus.

Exposure: Adjusts shadows and highlights.

The histogram:  Helps you understand the relationship between shadows (depicted on 
the left side of the display) and highlights (depicted on the right side) in your image.

Levels:  Changes the levels of light and dark tones.

Auto Levels:  Has Pages enhance colors automatically.

4 To restore the original settings, click Reset Image. 

To save any changes you made, save the document. The settings at the time you save 
the document are visible anytime you open the Adjust Image window.

Using PDF Files as Graphics
If you intend to greatly enlarge or reduce a graphic’s dimensions, consider converting it 
to a PDF file before bringing it into Pages. PDF files don’t lose their crispness when they 
are significantly resized. Other file types may not retain their clarity as well when they 
are enlarged or reduced.

PDF files also provide a great way to move tabular data from Excel or AppleWorks 
documents into Pages. If you have extensively formatted tables in Excel or an 
AppleWorks spreadsheet that you want to display in your document, you can save the 
spreadsheet as a PDF file and then place that PDF file on a page as you would any 
other external graphics file.

To convert an Excel or AppleWorks file to a PDF file:
1 In your Excel or AppleWorks spreadsheet, select the table range you want to display in 

your document.

2 Choose File > Print.

3 In the Print dialog, choose Save as PDF from the PDF pop-up menu.

4 In the Save dialog, type a name for the PDF file and select a location, and then click 
Save.

You can copy a range of cells in an Excel document and paste the cells and their 
contents directly into your document. Pages creates a new table to hold the Excel data.

You can also convert an image to a PDF file by using Grab. Open Grab (it’s in the 
Applications/Utilities folder). Choose Capture > Selection to select what you want to 
create an image of. Choose File > Print to save the image as a PDF.
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Using Sound and Movies
You can add sound, movies, and Flash files to your document if it will be viewed 
onscreen. The movie or sound file plays when you double-click its icon on a document 
page.

Note:  Some media files are protected under copyright law. Also, some downloaded 
music may be played only on the computer where the download occurred. Make sure 
you have permission to use the files you want to include.

Pages accepts any QuickTime or iTunes file type, including the following:
Â MOV
Â FLASH
Â MP3
Â MPEG-4
Â AIFF
Â AAC

Important:  To make sure that the movies and other media can be played and viewed 
when your document is transferred to another computer, make sure that “Copy audio 
and movies into document” is selected; after you choose Save or Save As, click the 
disclosure triangle next to the field, and then click Advanced Options.

Adding a Sound File
Add a sound file that plays when you double-click its icon.

Here are ways to add a sound file:
m Drag a sound file from the Finder to your document. The sound file is added to your 

document as a floating object.

m Click Media in the toolbar, click Audio, select a sound file, and then drag it to your 
document. The sound file is added to your document as a floating object.

m To add a sound file using a media placeholder, see “Using Media Placeholders” on 
page 157.

m To convert a sound file from a floating object to an inline object, select a sound file and 
click the Inline button in the Format Bar.

m To add a sound file as an inline object, press the Command key and then drag the file 
from the Finder or Media Browser until you see the insertion point where you want the 
sound file to appear. Release the thumbnail when you’ve placed it where you want it.
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Adding a Movie File
Add a movie file that plays when you double-click it.

Here are ways to add a movie:
m Drag a movie file from the Finder to your document. 

m Click Media in the toolbar, click Movies, select a movie file, and then drag it to where 
you want it in your document.

To see your movies listed in the Movies pane of the Media Browser, you must place 
them in the Movies folder, in iTunes, or in iPhoto.

m Choose Insert > Choose, select the movie file, and then click Insert.

m To add a movie file using a media placeholder, see “Using Media Placeholders” on 
page 157.

m To convert a movie file from a floating object to an inline object, select a movie file and 
click the Inline button in the Format Bar.

m To add a movie as an inline object, press the Command key and then drag the file from 
the Finder or from the Movies pane of Media Browser until you see the insertion point 
where you want the movie file to appear. Release the thumbnail when you’ve placed it 
where you want it.

Adjusting Media Playback Settings
In the QuickTime Inspector, you can select the start and stop frames of your movie, set 
the playback volume for sound and movies in your document, and specify whether to 
play media files only once or continuously, or forward and backward (Loop Back and 
Forth). You can also specify a frame of a movie to display until the movie starts playing.

To set media playback preferences:
1 Click Inspector in the toolbar, and then click the QuickTime Inspector button.

2 Click the movie or sound object to select it.

3 To start and stop the movie at particular frames or times, drag the Start and Stop 
sliders.

4 To specify which frame of a movie to display until the movie starts playing (called the 
“poster frame”), drag the Poster Frame slider until the movie displays the image you 
want.

5 Choose a repeat option from the Repeat pop-up menu:

None:  Play only once.

Loop:  Repeat continuously.
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Loop Back and Forth:  Play backward and forward continuously.

6 To increase or decrease the playback volume, drag the Volume slider to the right or left.

Set the playback volume.

Set playback repeat options.

Select the frame to
display until the movie

begins playing.

Use these controls to view 
the movie or play sound as 
you edit your document.

The QuickTime Inspector 
button

Start and stop a movie at 
particular times.
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8 Using Tables

This chapter tells you how to add and format tables and cell 
values.

To learn about using formulas in table cells, see Chapter 9, “Using Formulas and 
Functions in Tables,” on page 189.

About Tables
Tables help you organize, analyze, and present data. 

Pages provides a wide variety of options for building and formatting tables and 
handling values of different types. You can also use special operations such as sorting 
and conditional formatting (a technique for automating the monitoring of cell values).

Â “Working with Tables” on page 168 teaches you how to add tables, resize them, move 
them, name them, and more.

Â “Selecting Tables and Their Components” on page 172 describes how to select tables, 
columns, and other table elements in order to work with them. 

Â “Working with Content in Table Cells” on page 175 tells you how to add text, 
numbers, dates, images, and other content to table cells as well as how to monitor 
cell values automatically.

Â “Working with Rows and Columns” on page 183 covers adding rows and columns, 
resizing them, and more.

Â “Working with Table Cells” on page 186 contains instructions for splitting cells, 
merging them, and copying and moving them as well as formatting cell borders.

Â “Sorting Table Cells” on page 188 describes how to sort and filter rows.
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Working with Tables
Use a variety of techniques to create tables and manage their characteristics, size, and 
location. 

Adding a Table
While some templates contain one or more tables, you can add additional tables to 
your Pages document.

Here are ways to add a table:
m Click Table in the toolbar.

m Choose Insert > Table.

m To draw a table on the page, hold down the Option key as you click Table in the 
toolbar. Release the Option key and move the pointer over the page until it becomes a 
crosshair. Drag across the page to create a table that’s the size you want. As you drag, 
the number of rows and columns increases or decreases with the size of the table. To 
size the table from the center, press the Option key while dragging. 

m To create a new table based on one cell or several adjacent cells in an existing table, 
select the cell or cells, click and hold the selection, and then drag the selection to the 
page. To retain values in the selected cells in the original table, hold down the Option 
key while dragging.

See “Selecting Tables and Their Components” on page 172 to learn about cell selection 
techniques.

Using Table Tools
You can format a table and its columns, rows, cells, and cell values using various Pages 
tools.

Here are ways to manage table characteristics:
m Select a table and use the Format Bar to quickly format the table.

Arrange text in 
table cells.

Select paragraph and 
character styles.

Set the number of
rows and columns.

Add background
color to a cell.Open the Styles drawer.

Format text in 
table cells.
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m Use the Table Inspector to precisely control column width and row height, add headers 
and a footer, format borders, and more. To open the Table Inspector, select a table or 
cell(s), click Inspector in the toolbar, and click the Table Inspector button.

m Use the Format pane of the Table Inspector to format table cell values. For example, 
you can display a currency symbol in cells containing monetary values. 

You can also use the Format pane of the Table Inspector to set up conditional 
formatting. For example, you can make a cell red when its value exceeds a particular 
number. 

Adjust the size of rows 
and columns.

Set the style, width, and 
color of cell borders.

Add color or an image 
to a cell.

Change the behavior of the 
Return and Tab keys.

Control the visibility of header 
cells in multipage tables.

Click to open the Edit Rows 
& Columns pop-up menu.

Set the number of rows and columns. 
Add and remove a header row, a 
header column, and a footer row.

Select to wrap in 
selected cells.

Use color to highlight 
cells whose values obey 
your rules.

Choose a formula or 
choose the Formula Editor 
to perform a calculation.

Set up the format for 
displaying values in 
selected cells.
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m Use the Graphics Inspector to create special visual effects, such as shadows and 
reflections. To open the Graphics Inspector, click Inspector in the toolbar and then click 
the Graphics Inspector button.

m Access a shortcut menu by selecting a table or cell(s) and then holding down the 
Control key as you click again. 

You can also use the Edit Rows & Columns pop-up menu in the Table Inspector.

m Use the Formula Editor to add and edit formulas. 

See “Using the Formula Editor” on page 194 for details.

m Use the Formula Browser to add and edit functions.

See “Using Functions” on page 200 for details.

Resizing a Table
You can make a table larger or smaller by dragging one of its selection handles or by 
using the Metrics Inspector. You can also change the size of a table by resizing its 
columns and rows.

Before resizing a table, you must select it, as “Selecting a Table” on page 172 describes.

Here are ways to resize a table that’s selected:
m Drag one of the square selection handles that appears when a table is selected. For 

inline tables in a word processing document, only the active selection handles on the 
right side can be used.

To maintain a table's proportions, hold down the Shift key as you drag to resize the 
table.

To resize from the table’s center, hold down the Option key as you drag.

Drag an active selection handle 
to resize an inline or floating table.
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m To resize a table in one direction, drag a side handle instead of a corner handle. For 
inline tables, only the active selection handles on the right side can be used.

m To resize by specifying exact dimensions, click Inspector in the toolbar, and then click 
the Metrics Inspector button. In this pane, you can specify a new width and height, 
control the angle of rotation, and change the table’s distance from the margins.

If a table spans more than one page, you must use the Metrics Inspector to resize the 
table.

m To resize by adjusting the dimensions of rows and columns, see “Resizing Table Rows 
and Columns” on page 185.

Moving Tables
You can move a table by dragging it, or you can relocate a table using the Metrics 
Inspector.

Here are ways to move a table:
m To move a floating table, select the table, click and hold anywhere in the table, and 

drag the table.

m To move an inline table, click the table to select it, and then drag it until the insertion 
point appears where you want the table in the text.

You can also select the table and choose Edit > Cut. Place the insertion point where 
you want the table to appear, and then choose Edit > Paste.

m To constrain the movement to horizontal, vertical, or 45 degrees, hold down the Shift 
key as you drag.

m To move a table more precisely, click any cell, click Inspector in the toolbar, click the 
Metrics Inspector button, and then use the Position fields to relocate the table.

m To copy a table and move the copy, hold down the Option key, click and hold at the 
edge of an unselected table, and drag.

Copying Tables Among iWork Applications
You can copy a table from one iWork application to another.

The table retains its appearance, data, and other attributes, but some Pages features 
aren’t supported in the other applications:
Â Rows or columns that are hidden in Pages aren’t visible in the other applications until 

you select the table and choose Format > Table > Unhide All Rows or Unhide All 
Columns.

Â Comments added to Pages table cells aren’t copied.
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To copy a table from one iWork application to another:
1 Select the table you want to copy, as “Selecting a Table” on page 172 describes.

2 Choose Edit > Copy.

3 In the other application, create an insertion point for the copied table, and then choose 
Edit > Paste.

Converting Text to a Table
You can quickly convert text into a table and vice versa.

Here are ways to convert between text and tables:
m To convert text to a table, select the text, and choose Format > Table > Convert Text to 

Table.

When Pages encounters a paragraph return, it creates a new row. When Pages 
encounters a tab stop, it creates a new column.

m To convert a table to text, select the table, and choose Format > Table > Convert Table 
to Text.

Selecting Tables and Their Components
You select tables, rows, columns, table cells, and table cell borders before you work 
with them.

Selecting a Table
When you select a table, selection handles appear on the edges of the table.

Here are ways to select a table:
m If a cell isn’t selected, click anywhere in the table.

m If a table cell is selected, press Command-Return, or click outside the table and then 
click anywhere in the table.

Selecting a Table Cell
When you select a cell, the border of the selected cell is highlighted. 

To select a single table cell:
m Select the table, and then click the cell. 
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When a cell is selected, use the Tab, Return, and arrow keys to select another cell. 
Selecting “Return key moves to next cell” under Table Options in the Table Inspector 
sometimes changes the effect of the Return and Tab keys. 

Selecting a Group of Table Cells
You can select adjacent or nonadjacent cells.

Here are ways to select a group of cells:
m To select adjacent table cells, select a single cell, and then hold down the Shift key as 

you select adjacent cells.

You can also click a cell, hold it, and then drag through a range of cells.

m To select nonadjacent table cells, hold down the Command key as you select cells. Use 
Command-click to deselect a cell in the group.

To select
If “Return key” option is 
selected

If “Return key” option isn’t 
selected

The next cell to the right Press Tab. 
If you press Tab in the last cell in 
a column, a new column is 
added.
If you add or change data in the 
last column, press Tab twice to 
add a new column.

Press Tab. 
If you press Tab in the last 
column, the first cell in the next 
row is selected. 
If you press Tab in the last cell of 
the table, a new row is added.

The previous cell Press Shift-Tab. Press Shift-Tab.
If you press Shift-Tab in the first 
cell, the last cell is selected.

The next cell down Press Down Arrow or Return.
If you’ve been using the Tab key 
to navigate between cells, 
pressing Return selects the next 
cell down from the cell in which 
you started tabbing.
If you press Return when the last 
cell in a row is selected, a new 
row is added.
If you add or change data in the 
last cell, press Return twice to 
add a new row.

Press Down Arrow.

The next cell up Press Up Arrow or Shift-Return. Press Up Arrow.
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Selecting a Row or Column
The fastest way to select entire rows and columns is to use the Table Inspector.

Here are ways to select rows and columns:
m To select a single row or column, choose Select Row or Select Column from the Edit 

Rows & Columns pop-up menu in the Table Inspector.

You can also use the techniques described in “Selecting a Group of Table Cells” on 
page 173.

m To select multiple rows, select two or more vertically adjacent cells before choosing 
Select Row.

m To select multiple columns, select two or more horizontally adjacent cells before 
choosing Select Column. 

Selecting Table Cell Borders
Select cell border segments when you want to format them. A single border segment is 
one side of a cell. A long border segment includes all adjacent single border segments.

Here are ways to select borders and border segments:
m To select specific borders for multiple cells: Select the table, row, column, or cells, click 

Inspector in the toolbar, and then click the Table Inspector button. Click one of the Cell 
Borders buttons in the Table pane.

m To select a border: If the table is selected, click the border. If the table isn’t selected, 
double-click the border.

m To select a border segment: If the table is selected, double-click the segment. If the table 
isn’t selected, click a segment three times. To select (or deselect) additional segments, 
press the Shift or Command key while you click.

When a table border is selected, clicking another border selects the border. Clicking the 
same border selects a segment.

When a segment is selected, clicking another segment selects the segment. Clicking 
the same segment selects the border.

When a cell, border, or segment is selected, the pointer appears to straddle the border 
or segment. You can drag these pointers to move a border.

The pointer looks like 
this when it’s over a 
horizontal segment.

The pointer looks like 
this when it’s over a 
vertical segment.
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Working with Content in Table Cells
You can add text, numbers, and dates to table cells, and you can format values in cells. 
You can also add images and background color. And you can use autofilling to use the 
content in one or more cells to automatically add values to adjacent cells.

Adding and Editing Cell Values
You can add, change, and delete the content in cells.

Here are ways to add and edit values:
m If the cell is empty, select it and then type a value. “Selecting a Table Cell” on page 172 

tells you how to select cells.

m To replace specific content already in the cell, select the cell and then select what you 
want to replace by double-clicking; hold down the Shift key and select more content if 
you want to replace more. Type to replace the selected content.

m To replace everything in the cell, select the cell and then begin typing. 

If “Return key moves to next cell” isn’t selected in the Table Inspector, you can also 
select the cell and then press Return or Enter, which selects everything in the cell, and 
then start typing.

m To insert content within existing content, select the cell, click to set the insertion point, 
and begin typing.

m To undo changes made to a table cell since selecting the cell, press Esc.

m To delete the content of table cells, rows, or columns, select the cells, rows, or columns 
and then press the Delete key or choose Edit > Delete.

To delete the contents, background fill, and any style settings, choose Edit > Clear All. 
The default style is applied to the selection.

m To copy, paste, and move cell values, see the instructions in “Copying and Moving Cells” 
on page 187

m To add formulas and functions to cells, see the instructions in “Using Formulas” on 
page 189 and “Using Functions” on page 200.

Working with Text in Cells
You can control the format and alignment of text in table cells, and you can use find/
replace and spell-checking features.

Here are techniques for working with text in table cells:
m To insert a line break, press Control-Return. 

m To insert a paragraph break, If “Return key moves to next cell” under Table Options in 
the Table Inspector isn’t selected, press Return. Otherwise, press Option-Return.

m To insert a tab in a table, press Option-Tab.
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m To change the color, alignment, and spacing of text within a cell, use the controls in the 
Format Bar.

You can also adjust color, alignment, and spacing of text within a cell using the Text 
Inspector (click Inspector in the toolbar and click the Text Inspector button).

m To modify font attributes, use the controls in the Format Bar.

You can also adjust font attributes using the Font panel (click Fonts in the toolbar).

m To check spelling and writing errors, follow the instructions in “Checking for Spelling 
and Proofreading Documents” on page 114.

m To find and optionally replace text in cells, follow the instructions in “Finding and 
Replacing Text” on page 116.

m To avoid having Pages interpret what you type as a number, place an apostrophe in 
front of the text string. 

Note:  Text strings are ignored in functions that use values to perform calculations.

Working with Numbers in Cells
Some table operations, such as formulas and functions that perform mathematical 
operations, depend on cells containing numeric values.

Here are techniques for working with numbers in table cells:
m In a numeric cell, use only numbers (0 through 9) or one of the following characters: +, 

–, (,), /, $, %, a period, E, or e.

m You can type some characters (such as %) into a cell, or you can use a cell format, as 
“Formatting Cell Values” on page 178 describes.

m To specify a negative number, precede it with the minus sign (–).

When you put a number in a table cell that’s too large to display, Pages converts the 
number:

Â When a decimal number doesn’t fit in a cell, the number is rounded. For example, 
1.77777777777777777777 becomes 1.77777777777778.

Â When a whole number doesn’t fit in a cell, the number is displayed using scientific 
notation. For example, 77777777777777777777 becomes 7.7.77778E+19.
Scientific notation displays numbers using an exponent raised by the power of 10. 
The exponent is displayed following the E.

If the converted number still doesn’t fit, it’s clipped. See “Displaying Content Too Large 
for Its Cell” on page 177 for suggestions.

Instructions for using formulas and functions in table cells are in “Using Formulas” on 
page 189 and “Using Functions” on page 200.
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Working with Dates in Cells
Unless a cell has a date and time format associated with it, when you type a value that 
can be interpreted as a date or time value, Pages might reformat the value.

For example, if you type 1/22/45 or 1-22-45 into a table cell with the Automatic cell 
format and leave the cell, the value changes to Jan. 22, 2045. If you enter a 2-digit year 
value greater than or equal to 50, Pages adds the prefix “19”; otherwise Pages adds the 
prefix “20.”

And if you type 12 pm, the value becomes 12:00 PM. You can edit the value if you need 
to change it.

See “Using the Date and Time Format” on page 180 to learn about the date and time 
format.

Displaying Content Too Large for Its Cell
When a cell is too small to display all its content, a clipping indicator (a small plus sign 
in the bottom right corner of the cell) appears.

You can enlarge a cell so that it displays more content, or you can let the cell’s content 
spill into adjacent blank cells.

To avoid clipping and spilling, you can set up a table so that all its cells automatically 
shrink or expand in height to accommodate content by selecting “Automatically resize 
to fit content” in the Table Inspector’s Table pane.

Here are ways to handle content too large for a cell:
m To let the content in a cell spill into adjacent cells, deselect Wrap Text in Cell in the 

Table Inspector’s Format pane and deselect “Automatically resize to fit content” in the 
Table pane.

If the adjacent cells are empty, they’ll display spilled content. But if they contain data, 
content that doesn’t fit isn’t displayed and the clipping indicator appears.

m To cause content to wrap instead of spill, select Wrap Text in Cell in the Table 
Inspector’s Format pane.

m To resize a column so that all of a particular cell’s value is visible, click its right border 
and drag right, or use the Column Width controls in the Table Inspector’s Table pane.

m To resize a row so that all of a particular cell’s value is visible, click its bottom border 
and drag down, or use the Row Height controls in the Table Inspector.

The clipping indicator appears 
when a table cell contains more 
content than can be seen.
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Formatting Cell Values
You can apply a format to a cell so its value is displayed in a particular way. For 
example, you can format cells that hold monetary values so that a currency symbol 
(such as $, £, or ¥) appears in front of numbers in them.

You define cell formats using the Cell Format pop-up menu in the Table Inspector’s 
Format pane. To display cell values exactly as you type them, choose Automatic from 
the pop-up menu; otherwise, choose the item that provides the specific formatting you 
want to use.

Here are ways to work with cell formats:
m To add a value to an empty cell that has a format, select the cell and enter a value. The 

format is applied when you leave the cell.

m To apply a cell format to an existing value, select one or more cells that contain values. 
Use the Cell Format pop-up menu in the Table Inspector’s Format pane to define a cell 
format. The format you define is applied to values in the selected cell(s). 

m To remove a format from a cell, select the cell, and then choose Automatic from the 
Cell Format pop-up menu in the Table Inspector’s Format pane. The value remains, but 
its formatting is removed.

m If you delete a value from a cell with a format, the format isn’t deleted. To delete the 
format, choose Automatic from the Cell Format pop-up menu in the Table Inspector’s 
Format pane.

m After you define a cell format, you can associate the format with multiple cells by using 
autofilling. See “Autofilling Table Cells” on page 182 for instructions.

Using the Number Format
Use the number format to format the display of a number’s decimal places, thousands 
separator, and negative values.

To define a number format for one or more cells:
1 Select the cell or cells. 

2 Click Inspector in the toolbar, click the Table Inspector button, and then click Format.

3 Choose Number from the Cell Format pop-up menu.

4 To specify how many decimal places to display, use the Decimals field. If a value 
contains more decimal places than you specify, the decimal value displayed is rounded, 
not truncated. For example, if a cell is formatted to display two decimal places, the 
value 3.456 is displayed as 3.46, not 3.45.

5 To specify how to display negative values, choose an entry from the pop-up menu 
adjacent to the Decimals field.

6 To specify whether to use a thousands separator, select Thousands Separator.
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Using the Currency Format
Use the currency format to format the display of monetary values.

To define a currency format for one or more cells:
1 Select the cell or cells. 

2 Click Inspector in the toolbar, click the Table Inspector button, and then click Format.

3 Choose Currency from the Cell Format pop-up menu.

4 To specify a currency symbol, choose an option from the Symbol pop-up menu.

5 To specify how many decimal places to display, use the Decimals field. If a value 
contains more decimal places than you specify, the decimal value displayed is rounded, 
not truncated. For example, if a cell is formatted to display two decimal places, the 
value 3.456 is displayed as 3.46, not 3.45.

6 To specify how to display negative values, choose an entry from the pop-up menu 
adjacent to the Decimals field.

7 To specify whether to use a thousands separator, select Thousands Separator.

8 To display the currency symbol at the edge of the cell, select Accounting Style.

Using the Percentage Format
Use the percentage format to display numeric values followed by the % symbol.

If the value is used in a formula, its decimal number version is used. For example, a 
value that displays as 3% is used as 0.03 in a formula.

If you type 3% in a cell formatted using the automatic format and then apply the 
percentage format to the cell, the value displayed is 3%. However, if you type 3 in a cell 
formatted using the automatic format and then apply the percentage format to the 
cell, the value displayed is 300%.

To define a percentage format for one or more cells:
1 Select the cell or cells. 

2 Click Inspector in the toolbar, click the Table Inspector button, and then click Format.

3 Choose Percentage from the Cell Format pop-up menu.

4 To specify how many decimal places to display, use the Decimals field. If a value 
contains more decimal places than you specify, the decimal value displayed is rounded, 
not truncated. For example, if a cell is formatted to display two decimal places, the 
value 3.456 is displayed as 3.46, not 3.45.

5 To specify how to display negative values, choose an entry from the pop-up menu 
adjacent to the Decimals field.

6 To specify whether to use a thousands separator, select Thousands Separator.
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If a cell you’re formatting already contains a value, the value is assumed to be a decimal 
value, and it’s converted into a percentage. For example, 3 becomes 300%. 

Using the Date and Time Format
Use the date and time format to display date and/or time values.

To define a date and time format for one or more cells:
1 Select the cell or cells. 

2 Click Inspector in the toolbar, click the Table Inspector button, and then click Format.

3 Choose Date & Time from the Cell Format pop-up menu.

4 To specify how you want a date formatted, choose a format from the Date pop-up 
menu.

5 To specify how you want a time value formatted, choose a format from the Time pop-
up menu.

Using the Fraction Format
Use the fraction format to control the display of values smaller than 1. For example, 27.5 
displays as 27 1/2 when the format is Halves and as 27 4/8 when the format is Eighths.

To define a fraction format for one or more cells:
1 Select the cell or cells. 

2 Click Inspector in the toolbar, click the Table Inspector button, and then click Format.

3 Choose Fraction from the Cell Format pop-up menu.

4 To specify how you want the fractional part of a value formatted, choose an item from 
the Accuracy pop-up menu.

Using the Scientific Format
Use the scientific format to display numbers using an exponent raised by the power of 
10. The exponent is displayed following an “E.” For example, the value 5.00 in scientific 
format displays as 5.00E0. And the value 12345 displays as 1.2345E4.

To define a scientific format for one or more cells:
1 Select the cell or cells.

2 Click Inspector in the toolbar, click the Table Inspector button, and then click Format.

3 Choose Scientific from the Cell Format pop-up menu.

4 Use the Decimals field to specify the number of decimal places to display.

Using the Text Format
Use the text format when you want all of a cell’s content to be treated as text, even 
when it’s a number.
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To define a text format for one or more cells:
1 Select the cell or cells. 

2 Click Inspector in the toolbar, click the Table Inspector button, and then click Format.

3 Choose Text from the Cell Format pop-up menu.

Monitoring Cell Values
You can have Pages change a cell’s fill and/or text color when its content exhibits a 
particular condition. 

You define simple rules that test for the condition and then change fill and/or text color 
if the condition is met. For example, you can define a rule that turns a cell blue if it 
contains a particular value and another rule that turns the cell green if it contains 
another value.

You can apply a rule to a single cell or to a range of cells. Rules applied to multiple cells 
trigger color changes when any of the cells meet the rule’s condition. 

To define rules:
1 Select one or more cells. 

2 Click Inspector in the toolbar, click the Table Inspector button, and then click Format.

3 Select Conditional Format, and then click “Show rules.”

4 Choose a condition from the “Choose a rule” pop-up menu. 

The conditions in the top section of the menu apply tests to numeric values. 
Conditions for text values are in the middle section of the list, and date conditions are 
at the bottom.

Note that the Between condition requires that you specify two numbers. The condition 
is met if either of the numbers or any number in between them appears in the cell(s).

5 Provide additional information as required to fully specify a particular condition to test 
for.

6 Select Fill Color and/or Text Color and click the color wells (see “Using the Colors 
Window” on page 148) to define the background and value colors to apply to the cell if 
the condition is met.

7 To add another rule, click + and repeat steps 4 through 6.

If more than one rule is defined for a cell and the cell’s content satisfies the conditions 
of multiple rules, the colors associated with the higher rule in the list of rules are 
applied to the cell.

To stop using a rule, click its – button to delete the rule, or deselect Fill Color and Text 
Color to disable the rule. To stop using a list of rules, deselect “Highlight cells using the 
following rules.”
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Adding Images or Color to Cells
You can add graphics or color to individual table cells or to an entire table. 

To add an image or color to a table cell:
1 Select the cell.

2 Click Inspector in the toolbar, click the Table Inspector, and then click Table.

3 To add an image, choose Image Fill from the Cell Background pop-up menu. See 
“Filling an Object with an Image” on page 149 for instructions.

4 To add background color, choose Color Fill or Gradient Fill from the Cell Background 
pop-up menu. See “Filling an Object with Color” on page 147 for more information.

Autofilling Table Cells
Autofilling lets you use the content in one or more cells to automatically add values to 
adjacent cells.

Here are ways to autofill table cells:
m To paste the content and fill of a cell into adjacent cells, select the cell and then drag 

the Fill handle in its lower right corner over the cells into which you want to paste.

Any data, cell format, formula, or fill associated with the selected cell is pasted. If any 
target cell contains data, autofilling overwrites that data with the value you’re 
repeating.

m To paste the content and fill of a cell into one or more cells in the same row or column, 
select two or more adjacent cells. Choose Insert > Fill Right to assign selected cells the 
value that resides in the leftmost selected cell(s). Choose Insert > Fill Down to assign 
selected cells the value that resides in the topmost  selected cell(s).

Any data, cell format, formula, or fill associated with the selected cell is pasted. If any 
target cell contains data, autofilling overwrites that data with the value you’re 
repeating.

m You can also add values to cells based on value patterns. For example, if a cell contains 
a day of the week or a month, you can select the cell and then drag to the right or 
down to add the next day of the week or month to the adjacent cell.

To create new values based on numeric patterns, select two or more cells before 
dragging. For example, if two selected cells contain 1 and 2, the values 3 and 4 are 
added when you drag through the adjacent two cells. And if two selected cells contain 
1 and 4, the values 7 and 10 are added when you drag through the adjacent two cells 
(values are incremented by 3).

Autofilling doesn’t set up an ongoing relationship among cells in the group. After 
autofilling, you can change the cells independently of each other. 
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Working with Rows and Columns
You can quickly add or remove rows and columns, create a header row or column or a 
footer row, and more. 

Adding Rows
You can add rows within a table or at the end of a table. If the table contains a footer 
row, rows added at the bottom of the table are added above the footer row.

Here are ways to add rows:
m To add one or more rows at the end of a table, use the Rows controls in the Table pane 

of the Table Inspector.

You can also add one or more rows at the end of a table by using the controls in the 
Format Bar.

m To add a single row, select a cell and then choose Format > Table > Add Row Above or 
Add Row Below. You can also choose these commands from the Edit Rows & Columns 
pop-up menu in the Table Inspector.

m To add a row at the end of the table, press Return when the last cell is selected. Press 
Return twice if you’ve just added or changed the cell value.

If “Return key moves to next cell” under Table Options in the Table Inspector isn’t 
selected, press Tab instead from the last cell in the row.

m You can split cells into two equal rows. “Splitting Table Cells” on page 186 tells you how.

Adding Columns
You can add new columns to a table.

Here are ways to add columns:
m To add one or more columns to the right side of a table, use the Columns controls in 

the Table pane of the Table Inspector.

You can also add one or more columns to the right side of the table by using the 
controls in the Format Bar.

m To add a single column, select a cell and then choose Format > Table > Add Column 
Before or Add Column After. You can also choose these commands from the Edit Rows 
& Columns pop-up menu in the Table Inspector.

m You can use the Tab key to add a column to the right side of the table when “Return 
key moves to next cell” under Table Options in the Table Inspector is selected.

Press Tab when the last cell is selected. Press Tab twice if you’ve just added or changed 
the cell value.

m You can split cells into two equal columns. “Splitting Table Cells” on page 186 tells you 
how.
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Deleting Table Rows and Columns
There are several techniques available for deleting one or more rows or columns of a 
table.

Here are ways to delete rows or columns:
m Select the row(s) or column(s) or a cell in them, and then choose Format > Table > 

Delete Row or Format > Table > Delete Column.

m To delete one or more rows or columns, select them and then choose Delete Row or 
Delete Column from the Edit Rows & Columns pop-up menu in the Table Inspector. You 
can also access these commands by choosing Format > Table > Delete Row or 
Format > Table > Delete Column.

You can also delete rows and columns by using the controls in the Format Bar.

Using a Table Header Row or Column
Use header rows and columns to label the data in rows and columns. Header rows and 
columns are formatted so that they stand out from the other rows and columns. A 
header row consists of the topmost cell in each column. A header column consists of 
the leftmost cell in each row.

Header rows appear on each page of inline tables if the table spans more than one 
page. Header rows appear at the beginning of each column or linked text box if the 
table spans columns or linked text boxes. If a table spans multiple pages, columns, or 
text boxes, editing the text or changing the look of the header row or column in one 
place changes it consistently throughout the table.

You can’t split a header row or footer row into multiple rows or header columns into 
multiple columns.

Here are ways to add or delete a header row or column:
m Select the table, and then select Header Row or Header Column in the Table pane of 

the Table Inspector.

m Select the table and choose one of the following options: Format > Table > Add Header 
Row, Format > Table > Delete Header Row, Format > Table > Add Header Column, or 
Format > Table > Delete Header Column.

m If a table spans pages and you want to repeat headers at the top of each page, select 
“Repeat header cells on each page” in the Table Options area of the Table Inspector.

The cells in a header row or header column are referred to as header cells. Header cells 
play an important role in making formulas in table cells easier to read and create. See 
“Using Cell References” on page 195 and “Applying a Formula Once to Cells in a Column 
or Row” on page 197 to learn more.
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Using a Footer Row
Use a footer row when you want to draw attention to the last row in a table. A footer 
row can contain the same content as any other row, but its formatting makes it visually 
prominent.

Here are ways to add or delete a footer row:
m Select the table, and then select Footer Row in the Table pane of the Table Inspector.

m Select the table and then choose Format > Table > Add Footer Row or Format > 
Table > Delete Footer Row from the Table menu

Resizing Table Rows and Columns
Resize all rows and columns so they’re equal in size, or resize only specific rows and 
columns in a table.

Here are ways to resize rows and columns:
m To make all rows the same size, select the table and choose Format > Table > Distribute 

Rows Evenly.

m To make all columns the same size, choose Format > Table > Distribute Columns Evenly.

m To resize a single row, select a cell in the row and use the Row Height field in the Table 
Inspector.

m To resize a single column, select a cell in the column and use the Column Width field in 
the Table Inspector.

m To make several rows the same size, select one or more cells in the rows and choose 
Format > Table > Distribute Rows Evenly. The rows don’t have to be adjacent.

You can also use the Row Height field in the Table pane of the Table Inspector.

m To make several columns the same size, select one or more cells in the columns and 
choose Format > Table > Distribute Columns Evenly. The columns don’t have to be 
adjacent.

You can also use the Column Width field in the Table pane of the Table Inspector.

Alternating Row Colors
Use a different color background for alternate rows to give a table a banded effect.

To alternate row colors:
1 Select the table.

2 Click Inspector in the toolbar, click the Table Inspector button, and then click Table.

3 Select Alternating Row Color.

4 Click the adjacent color well to open the Colors Window, and then choose a color for 
the alternate rows. See “Using the Colors Window” on page 148 for instructions.
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5 To change the fill attributes of the other rows, use the Cell Background controls in the 
Table Inspector. See “Filling an Object with Color” on page 147 for instructions.

Working with Table Cells
You can split and merge table cells, resize them, format them, hide them, add 
comments, and more.

Merging Table Cells
Merging table cells combines adjacent cells into one, eliminating the borders so that 
they behave as a single cell.

To merge table cells:
1 Select a group of two or more adjacent table cells. The group of cells you choose must 

form a rectangle, and they must be all body cells or all header cells.

2 Choose Format >Table > Merge Cells.

You can also choose Merge Cells from the Edit Rows & Columns pop-up menu in the 
Table Inspector.

Merging horizontally contiguous cells containing only text or a mixture of text, 
numbers, formatted values, and formulas joins the content from all the original cells as 
text separated by tabs. Merging vertically contiguous cells containing only text or a 
mixture of text, numbers, formatted values, and formulas joins the content from all the 
cells as text separated by carriage returns. 

When you merge column cells, the cell background takes on the image or color that 
was in the topmost cell. When you merge row cells, the cell background takes on the 
image or color that was in the leftmost cell.

When a cell containing text, a number, a formula, or a cell format is merged with an 
empty cell, the new cell retains the content of the nonempty cell.

When a cell containing a number is merged with an empty cell, the new cell retains the 
number format. 

Splitting Table Cells
Splitting cells divides each selected cell into two equal parts, horizontally (rows) or 
vertically (columns). Both of the new cells have identical background colors or images. 
Any text that was in the original cell remains in the topmost or leftmost cell.

To split cells horizontally or vertically:
1 Select a table cell or cells. To split an entire row or column, select all the cells in the row 

or column. 
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2 To split cells into rows, choose Format > Table > Split into Rows. To split cells into 
columns, choose Format > Table > Split into Columns.

You can also choose Split Rows or Split Columns from the Edit Rows & Columns pop-up 
menu in the Table Inspector.

3 To create smaller and smaller units, repeat steps 1 and 2 for the split cells.

To rejoin split cells, merge them as “Merging Table Cells” on page 186 describes.

Formatting Table Cell Borders
You can change the line thickness and color of table cell borders. Or you can hide the 
cell border of any cell.

To format table cell borders:
1 Select the cell border segments you want to format. See “Selecting Table Cell Borders” 

on page 174 for instructions.

2 Click Inspector in the toolbar, and then click the Table Inspector button. Use the 
controls for Cell Borders.

Stroke pop-up menu:  Lets you choose a stroke style. Choose None to hide borders.

Line thickness:  Controls the thickness of the stroke.

Color well:  Lets you choose a stroke color. 

When you click the color well in the Format Bar, a color matrix appears. Select a color 
by clicking it in the matrix, or click Show Colors to open the Colors window for 
additional color options.

When you click the color well in the Table Inspector, the Colors window opens.

“Using the Colors Window” on page 148 provides instructions for using this tool.

Copying and Moving Cells
You can use commands or dragging to move or copy table cells.

Here are ways to copy and move cells:
m To move cells within a table or to another table, select a cell or several adjacent cells, 

and then drag the selection by its border until the destination cells are selected. Any 
values in the destination cells are replaced.

m To copy cells within or between tables, drag selected cells while holding down the 
Option key. Any values in the destination cells are replaced.

You can copy cells by selecting them, choosing Edit > Copy, selecting destination cells, 
and then choosing Edit > Paste.
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Sorting Table Cells
You can arrange values in some or all the cells in a column in ascending or descending 
order. Rows containing cells being sorted are reordered. Header cells aren’t sorted.

Here are ways to sort:
Â To sort all the cells in a column, select one of the column’s cells, open the Table 

Inspector, click Table, and then choose Sort Ascending or Sort Descending from the 
Edit Rows & Columns pop-up menu.

Â To sort only some of the cells in a column, select the cells before choosing Sort 
Ascending or Sort Descending.

The following table describes how different types of data are sorted in ascending or 
descending order. 

Type of data Ascending order Descending order

Text aA–zZ Zz–Aa

Dates Year (earliest first), then Month 
(January first), then day (1–31)

Year (most current first), then 
month (December first), then 
day (31–1)

Numbers –2, –1, 0, 1, and so on 1, 0, –1, –2, and so on

Cells containing only text, mixed 
with cells containing only 
numbers

–2, –1, 0, 1, and so on, then aA–
zZ

Zz–Aa, then 1, 0, –1, –2, and so 
on

Cells containing a mixture of 
text and numbers

Values starting with numbers 
first (1z, 1Z, a1, A1)

Values starting with text first (A1, 
a1, 1A, 1z)

Empty cells At the bottom At the bottom

Boolean (TRUE, FALSE) Below text and above an empty 
cell

Above text
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9 Using Formulas and Functions 
in Tables

This chapter tells you how to perform calculations in table 
cells using formulas and functions.

See Chapter 8, “Using Tables,” on page 167 for instructions for adding and formatting 
tables and data in them. See online help for complete information about individual 
functions.

Using Formulas
A formula is a mathematical expression that uses operations to derive a value. You can 
add a formula to a table cell to display a value derived from values in other table cells. 

For example, you can add a formula to the bottom cell of a column that adds the 
numbers in all the other cells in the column. If any of the column values change, the 
total in the bottom cell changes automatically.

Formulas derive values by using operators and functions. 

Â Operators perform operations such as addition (+) and multiplication (*).
Here’s a formula that adds values: =A2 + 16. A2 is called a cell reference; A2 refers to 
the second cell in the first column. The value 16 is called a constant, because it’s a 
specific value that uses no operators or functions.

The value in cell A2 is added to the value 16, and the result is displayed in the cell 
that contains the formula.

Formulas always begin with an equal sign (=). For simplicity, the examples 
throughout the Pages documentation omit the equal sign.

Â Functions are predefined, named operations, such as SUM and AVERAGE.
To use a function, you name the function and, in parentheses following the name, 
you provide the arguments it needs. Arguments specify the data the function will use 
when it performs its operations.
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Here’s a formula that adds the values in nine cells of the first column: SUM(A2:A10). 
There is one argument, A2:A10. The colon means the function should use the values 
in cells A2 through A10.

You don’t need to understand more than this to use formulas in tables. Templates (such 
as the Invoice template) and formula editing tools (such as the Formula Editor) make 
basic formulas easy to use.

A Tour of Using Formulas
Reviewing the formulas built into the Invoice template is a good introduction to Pages 
formulas.

1 Create a new Pages document using the Invoice template. 

Open Pages, choose File > New, click Forms, select Invoice, and then click Choose.

The table in this template uses formulas to derive the values in the Cost column.

2 Select the table, and then double-click the value in the Cost cell in the first row. The 
Formula Editor opens, revealing that the value is derived using a formula.

The asterisk symbol (*) is the multiplication operator. 

A formula in each cell in the 
Cost column automatically 
updates totals when quantity 
or unit price changes.

The formula in the Cost cell in 
the first row multiplies the values 
in two other cells—B2 and C2.
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3 To understand which cells B2 and C2 are, look at the reference tabs that appeared on 
the table’s top and left sides when the Formula Editor opened.

The reference tabs help you quickly identify any cell in a table. In a formula, you refer to 
a cell by identifying the column, then the row, creating what’s known as a cell reference.

B2 is the cell reference for column B (Quantity), row 2. C2 is the cell reference for 
column C (Unit Price), row 2. The value in row 2 of the Cost column (E2) is derived by 
multiplying Quantity by Unit Price values that reside in row 2.

4 The values in the Unit Price and the Cost column are displayed using a number format. 

To see the number format settings, close the Formula Editor by clicking outside the 
table. Then click the table, click the Unit Price cell in the second row, click Inspector in 
the toolbar, select the Table Inspector, and then click Format.

See “Formatting Cell Values” on page 178 for instructions for using formatted numbers.

Columns are referenced 
alphabetically.

Rows are referenced 
numerically.

This is cell B2.

The comma is used as the 
thousands separator.

A $ is displayed
in front of numbers

in the cells.

Numbers are displayed 
using two decimal places.
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5 If the value in a Quantity cell or in a Unit Price cell changes, the formula associated with 
the Cost cell updates the value it displays.

Double-click the value in B2, type a different number, click outside B2, and notice that 
the value in E2 changes.

6 The value displayed for each cell in the Cost column above the subtotal is derived using 
values in each row. 

To view the formula for a different Cost cell, double-click the cell. For example, double-
click the Cost cell in the third row (E3). Its formula is B3*C3.

7 Click outside the table, click the table, and then double-click E10, the cell in the Cost 
column that’s next to the label “Subtotal.” The formula uses the SUM function to add 
the values in cells E2 through E9. 

In the formula, the cell references are enclosed in parentheses following the function 
name: SUM(E2:E9). E2 and E9 are separated using a colon. The colon is a shorthand way 
to refer to a range of cells, in this case, a range of eight cells.

8 Cells E11 and E12 also contain formulas. Examine the formulas in these cells by clicking 
outside the table, selecting the table, then double-clicking cell E11 or E12. Cell E11 
contains a formula that computes sales tax, and cell E12 contains a formula that sums 
the subtotal and the sales tax.

Adding a Quick Formula
An easy way to perform a basic calculation using values in a range of adjacent table 
cells is to add a quick formula using the Quick Formula pop-up menu in the Format 
pane of the Table Inspector.

You can also choose Insert > Function and use the submenu that appears.
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Here are operations you can perform using the pop-up menu or submenu:
m Choose one of the following to perform calculations using values in the selected cells. 

Empty cells and cells containing values that aren’t mentioned are ignored.

Sum:  Totals numeric values in the cells.

Average:  Calculates the arithmetic mean of numeric values in the cells.

Minimum:  Determines which numeric value in the cells is the smallest.

Maximum:  Determines which numeric value in the cells is the largest.

Count:  Determines how many of the values in the cells are numeric or date/time 
values.

Product:  Multiplies all the numeric values in the cells.

m Choose Insert > Function > More Functions to open the Function Browser. See “Using 
Functions” on page 200 for details about this tool.

m Choose Formula Editor to open the Formula Editor. See “Using the Formula Editor” on 
page 194 for instructions.

Performing a Basic Calculation Using Column Values
Using the Table Inspector’s Quick Formula pop-up menu makes it easy to perform basic 
calculations on adjacent values in a column and display the results.

Here are ways to perform basic calculations using values in a column:
m To use values in a range of adjacent cells, select the cells, click Inspector in the toolbar, 

click the Table Inspector button, and then click Format. Choose a formula from the 
Quick Formula pop-up menu.

Pages places the formula and its result in the first empty cell beneath the selected cells. 
If there is no empty cell, Pages adds a row to hold the result.

m To use all the values in a column, click the column’s header cell or reference tab. In the 
Table Inspector, click Format, and then choose a formula from the Quick Formula pop-
up menu.

Pages places the formula and its result in a footer row. If a footer row doesn’t exist, 
Pages adds one.

Performing a Basic Calculation Using Row Values
Using the Table Inspector’s Quick Formula pop-up menu makes it easy to perform basic 
calculations on adjacent values in a row and display the results.

Here are ways to perform basic calculations using values in a row:
m To use values in a range of adjacent cells, select the cells, click Inspector in the toolbar, 

click the Table Inspector button, and then click Format. Choose a calculation from the 
Quick Formula pop-up menu.

Pages places the formula and its result in the first empty cell to the right of the selected 
cells. If there is no empty cell, Pages creates a column to hold the result.
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m To use all the values in a row, click the row’s header cell or reference tab. In the Table 
Inspector, click Format, and then choose a formula from the Quick Formula pop-up 
menu.

Pages places the formula and its result in a in a new column.

Removing a Formula
If you no longer want to use a formula that's associated with a cell, you can quickly 
remove the formula.

To remove a formula from a cell:
1 Select the cell.

2 Press the Delete key.

Using the Formula Editor 
The Formula Editor lets you create and modify formulas. 

Here are ways to open the Formula Editor:
m Select a table cell and then type the equal sign (=).

m Select the table, and then double-click a table cell that contains a formula.

m Select a table, and then choose Formula Editor from the Quick Formula pop-up menu 
in the Format pane of the Table Inspector. 

m Select a table cell, and then choose Insert > Function > Formula Editor.

When the Formula Editor opens, it appears over the selected cell. To move the Formula 
Editor, hover the cursor over the left side of the Formula Editor until the cursor changes 
into a hand, then click and drag.

When you select a cell that contains a formula, its arguments are highlighted in color.

Adding a New Formula with the Formula Editor
Use the Formula Editor to create a formula.

To add a new formula using the Formula Editor:
1 Select the cell in which you want to display the result of the formula.

2 Open the Formula Editor. For example, type the equal sign (=).

Move the Formula
Editor by grabbing
here and dragging. Text field 

View or edit a formula.

Cancel button
Discard changes.

Accept button
Save changes.
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3 Use the text field to specify the formula, making sure the equal sign is the first 
character in your formula.

To learn techniques for including cell references in your formulas, see “Using Cell 
References” on page 195.

To learn about using operators in formulas, see “Using Operators” on page 197.

To learn how to insert a function into a formula, see “Using Functions” on page 200.

4 To save changes, press Return, press Enter, or click the Accept button in the Formula 
Editor. You can also click outside the table.

To close the Formula Editor and discard changes, press Esc or click the Cancel button in 
the Formula Editor.

Editing a Formula with the Formula Editor
You can use the Formula Editor when you want to edit a formula.

To edit a formula:
1 Double-click a table cell that contains a formula. The Formula Editor opens, with the 

formula displayed in the text field and its arguments highlighted in color. 

2 Make changes as required. You can use the arrow keys to move the insertion point 
around in the text field.

3 To save changes, press Return, press Enter, or click the Accept button in the Formula 
Editor. You can also click outside the table.

To close the Formula Editor and discard changes, press Esc or click the Cancel button in 
the Formula Editor.

Using Cell References
You use cell references to identify specific cells in formulas. For example, if you add a 
formula that averages the values in two cells, you use cell references to identify those 
cells. 

You can create cell references using the letters and numbers of reference tabs or using 
header cell names:

Â If your table has both a header row and a header column, you can identify a cell 
using the column name followed by the row name.
For example, if a column is named 2006 and a row is named Class Enrollment, the 
cell where the row and column intersect would be referred to as 2006 Class 
Enrollment.

Â You can use the letters and numbers of reference tabs to identify a specific cell. You 
specify the column letter and then the row number.
For example, C55 refers to the fifty-fifth row in the third column.
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Adding Cell References to a Formula
To insert a cell reference, you can click a cell, click a reference tab, or select a range of 
cells when there’s an insertion point in the text field of the Formula Editor. You can also 
insert a cell reference by typing

When you insert a cell reference by selecting cells or reference tabs, Pages adds cell 
references that use header cell names if “Use header cell names as references” is 
selected in the General pane of Pages preferences.

Here are ways to add a cell reference at the insertion point in the text field:
m To create a reference to a specific cell by using your mouse, click the cell. 

You can also type a reference to a specific cell. Use the column letter followed by the 
row number (A4) in the reference tabs or use the column name followed by the row 
name (2006 Class Enrollment).

m To add a reference to a list of individual cells, click each cell. If the references are 
arguments in a function, Pages automatically inserts a comma (,) between the 
references, which you can replace with a different character if needed. For example, if 
you’re in a location where the decimal separator is a comma, you can separate multiple 
cell references using a semicolon instead of a comma.

m To add a reference to a range of adjacent cells, drag over the cells you want to add.

You can also type or click the first cell, type a colon, and then type or click the last cell. 
For example B2:B5 refers to four cells in the second column. B2:C3 refers to two cells in 
the second column and two cells in the third column.

m To refer to all the cells in a column, click the column’s reference tab or click its header 
cell if there is one.

You can type the reference by using the column letter (C or C:C) or the column name if 
there’s a header cell. For example, SUM(B) or SUM(B:B) adds all the values in the cells of 
the second column.

m To refer to all the cells in a row, click the row’s reference tab or click its header cell if 
there is one.

You can type the reference by using the row number (1:1) or the row name if there’s a 
header cell. For example, SUM(1:1) adds all the values in the cells of the first row.

Copying or Moving Formulas with Cell References
You can copy or move a formula that contains cell references without invalidating the 
references.

Here are techniques for relocating formulas:
m To move a formula to a different cell, move the formula’s cell by dragging it to another 

cell.
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m To paste a copy of a formula in a different cell and use the same cell references in both 
formulas, place a dollar sign ($) in front of column and row identifiers (=$A$1). This 
technique creates what’s called an absolute cell reference.

For example, if the formula =A1 appears in cell D1 and you want to paste a copy of the 
formula in cell E1, change the formula to =$A$1, select D1, copy it, and paste the copy 
into E1. The formula $A$1 is copied into cell E1. If you didn’t change the formula to use 
an absolute cell reference the formula in E1 would be =B1.

Applying a Formula Once to Cells in a Column or Row
When a table has header cells, you can use them to quickly apply a formula to all the 
cells in a row or column. The values in the cells are recomputed using the formula. This 
formula is called a header formula.

To apply a header formula to cells in a column or row:
1 Select the header cell for the column or row. 

2 Open the Formula Editor. For example, type the equal sign (=).

3 Type the formula you want to apply to each cell in the column or row.

For example, to assign values to the cells of column C that are five times greater than 
the corresponding cell in column B, you’d use the formula B*5 or B:B*5.

The formula is duplicated in all the cells in the column or row. In this example, cell C4 
would contain the value computed by using the formula B4*5.

4 Click the Accept button or press Return or Enter to save the formula.

Handling Errors and Warnings
When a formula in a table cell is incomplete, contains invalid cell references, or is 
otherwise incorrect, or when an import operation creates an error condition in a cell, 
Pages displays an icon in the cell. A blue square in the upper left of a cell indicates one 
or more warnings. A red triangle in the middle of a cell means that a formula error 
occurred.

To view error and warning messages:
m Click the icon.

A message window summarizes each error and warning condition associated with the 
cell. To ignore warnings, click Ignore or click the x icon associated with a warning 
message.

Using Operators
Use operators in formulas to perform arithmetic operations and compare values:
Â Arithmetic operators perform arithmetic operations, such as addition and subtraction, 

and return numerical results.
Â Comparison operators compare two values and return TRUE or FALSE.
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Performing Arithmetic Operations
To create a formula that performs an arithmetic operation, you use arithmetic 
operators. For example, to add three values in a column, you could create a formula 
that looks like this:  A2 + A3 + A5.

Here are the basic arithmetic operators. For complete information about arithmetic 
operators that Pages supports, see “Understanding the Arithmetic Operators” on 
page 198. 

To add an arithmetic formula to a cell:
1 Select an empty cell for displaying the results of the formula.

2 Open the Formula Editor. For example, type an equal sign (=).

3 Enter the formula in the text field following the equal sign. 

For example, to enter the formula A3 * B5 + B6, in the text field following the equal 
sign you could click or type A3, type * (the multiplication operator), click or type B5, 
and then click B6 (if you don’t type an operator before clicking, Pages adds the plus 
sign (+) automatically when you’re not specifying function arguments).

4 Click the Accept button or press Return or Enter to save the formula.

Understanding the Arithmetic Operators 
Arithmetic operators in table cell formulas perform arithmetic operations and return 
numerical results.

Here are the arithmetic operators (examples presume that cell A2 contains 20 and 
that B2 contains 2):

m The operator + returns the sum of two values.

For example, A2 + B2 returns 22.

m The operator – returns the difference between two values.

For example A2 – B2 returns 18.

m The operator * returns the product of two values.

For example, A2 * B2 returns 40.

m The operator / returns the result of dividing one value by another value.

To perform this operation Use this arithmetic operator For example

Sum two values + A2 + B2

Subtract one value from another 
value

– A2 – B2

Multiply two values * A2 * B2

Divide one value by another 
value

/ A2 / B2
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For example, A2/B2 returns 10.

m The operator ^ returns the result of raising one value to the power of another value.

For example, A2 ^ B2 returns 400.

m The operator % returns the result of dividing a value by 100.

For example, A2% returns 0.2, formatted for display as 20%.

When a cell reference points to an empty cell, 0 is the value used.

When a cell reference points to a cell containing FALSE, 0 is used. If the cell contains 
TRUE, 1 is used. For example, TRUE + 1 returns 2.

Using a string with an arithmetic operator returns an error. For example, 3 + "hello" is 
not a correct arithmetic operation.

Understanding the Comparison Operators 
Comparison operators compare two values and return TRUE or FALSE.

Here are the comparison operators (examples presume that cell A2 contains 20 and 
that B2 contains 2):

m The operator = returns TRUE if two values are equal.

For example, A2 = B2 returns FALSE.

m The operator <> returns TRUE if two values aren't equal.

For example, A2<>B2 returns TRUE.

m The operator > returns TRUE if the first value is greater than the second value.

For example, A2 > B2 returns TRUE.

m The operator < returns TRUE if the first value is less than the second value.

For example, A2 < B2 returns FALSE.

m The operator >= returns TRUE if the first value is greater than or equal to the second 
value.

For example, A2 >= B2 returns TRUE.

m The operator <= returns TRUE if the first value is less than or equal to the second value.

For example, A2 <= B2 returns FALSE.

Strings are larger than numbers. For example, "hello" > 5 returns TRUE.

TRUE and FALSE can be compared with each other, but not with numbers or strings. 
TRUE > FALSE, and FALSE < TRUE, because TRUE is interpreted as 1 and FALSE is 
interpreted as 0. TRUE = 1 returns FALSE, and TRUE = "SomeText" returns FALSE.



200 Chapter 9    Using Formulas and Functions in Tables 

 

Using Functions
A function is a predefined, named operation (such as SUM and AVERAGE) that you can 
use to perform a calculation in a table cell. 

There are several families of functions, ranging from financial functions that calculate 
interest rates, investment values, and more to statistical functions that calculate 
averages, probabilities, standard deviations, and more. See Pages Help for complete 
information about all the functions, including the arguments you specify to provide the 
data for functions to use in their calculations. 

Although you can type a function into the text field of the Formula Editor, using the 
Function Browser is the quickest way to add a function to a formula.

To use the Function Browser to add a function:
1 Select the cell in which you want to add a function.

2 Choose Insert > Function > More Functions. The Function Browser opens.

3 Select a function.

To find a function, scroll through the list on the right, optionally subdividing the list by 
selecting a function category on the left. You can also search for a specific function 
within the selected function category by using the search field in the upper right.

4 Click Insert. The Formula Editor is displayed in the cell.

Pages inserts the function into the text field, followed by one or more argument 
placeholders, within parentheses. 

5 Use the Formula Editor to replace each placeholder with a cell reference or other value 
or perform any additional formula editing required. 
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10 Using Charts

You can convert data into attractive charts. This chapter 
describes how to create and format charts.

Pages provides tools for creating visually appealing charts to present numerical data. 
You can copy and paste your data from a document, or type it directly into the Chart 
Data Editor to create and edit your charts right on the page. By default, the appearance 
of charts is coordinated with the template you’re using, but you can adjust colors, 
textures, shadows, labels, and more to emphasize various chart elements.

About Charts
You can display data in a chart to visually reveal trends or relationships that aren’t as 
apparent when you view the data in rows and columns. You can choose from a variety 
of chart types to present your data, including pie charts, line charts, bar charts, column 
charts, area charts, and scatter charts. Most charts have two-dimensional and three-
dimensional versions.

To enter the data to show in a chart, you use the Chart Data Editor, as “Editing Chart 
Data” on page 206 describes. If you change data in the Chart Data Editor, the chart 
updates automatically.
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For example, you may want to create a chart that shows how many employees work in 
Region 1 and Region 2 each year. Such a table might have two rows (one for Region 1 
and one for Region 2) and four columns (one for each year from 2007 through 2010).

There are several ways to represent this data in a chart. In a bar chart, for example:

Â You can plot 2007 employee counts for Region 1 and Region 2 in side-by-side bars, 
followed by pairs of bars for 2008, 2009, and 2010. Such a chart would have two data 
series and four data sets.
Region 1 and Region 2 are called data series; each region is represented by a series of 
data values. Data values (data points) for each region are represented by bars that are 
grouped side by side in the chart; each group is called a data set (2007 is a data set, 
2008 is a data set, and so on).

These squares indicate 
which color represents 
each data series.

The chart legend denotes 
the two data series.

The data sets contain one 
data point (one bar) from 
each of the data series.

These four bars represent 
one data series.
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Â Alternatively, you can change the chart orientation so that data points are grouped 
by region rather than by year. In this case, the years are data series and the regions 
are data sets. The bar chart would contain two groups of bars, one for Region 1 and 
one for Region 2.

You can easily switch between using columns and rows as data series by using the Plot 
Row vs. Column button in the Chart Data Editor.

Data series are represented differently in different kinds of charts:

Â In column charts and bar charts, a data series is represented by a series of bars in the 
same fill (color or texture). 

Â In a line chart (also called a graph), a data series is represented by a single line. 
Â In an area chart, a data series is represented by an area shape. 
Â In a pie chart, only a single data set (the first data point in each series) is represented 

on the chart (whichever is listed first in the Chart Data Editor).
Â In a scatter chart, two columns of data are used to plot values for a single data series. 

Each pair of values determines the position of one data point.

These two bars represent 
one data series.

The data sets contain one 
data point (one bar) from 
each of the four data series.

This button makes the rows 
of data in the Chart Data 
Editor the data series.

This button makes the 
columns of data in the Chart 
Data Editor the data series.
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Adding a Chart
Charts can be added inline with text or floating on the page.

Here are ways to add a chart:
m To add an inline chart in a word processing document, choose Insert > Chart or click 

Chart in the toolbar. Drag the chart to wherever you want the chart to appear in the 
text flow.

In a word processing document, you can convert an inline chart to a floating chart and 
vice versa. Select the chart you wish to convert, and click the Inline or Floating button 
in the Format Bar.

In a page layout document, charts are floating. For more information about using inline 
and floating objects, see “Using Floating and Inline Objects” on page 134.

m To draw a chart on the page, hold down the Option key as you click Chart in the 
toolbar. Release the Option key and move the pointer over the page until it becomes a 
crosshair. Drag across the page to create a chart that’s the size you want. To constrain 
the chart’s proportions, hold down the Shift key as you drag.

A chart containing placeholder data appears on the page, and the Chart Inspector and 
Chart Data Editor open. Use the Chart Inspector to select the initial chart type and to 
format your chart. Use the Chart Data Inspector to edit chart data. 

See “Picking an Initial Chart Type” on page 204, “Formatting General Chart Attributes” 
on page 207, “Formatting Specific Types of Charts” on page 214, and “Editing Chart 
Data” on page 206 for instructions. 

Selecting a Chart Type
After you’ve added a chart, you can set or change its type. Choose from a wide variety 
of chart types, including bar charts, 3D bar charts, line charts, 3D line charts, and more.

Picking an Initial Chart Type
When you first add a chart, a default chart is inserted for you. You can change the type 
of the chart if you like.
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Here are ways to specify a chart type:
m Select the chart, click Inspector in the toolbar, click the Chart Inspector button, and 

then choose a chart type from the pop-up menu that appears when you click the chart 
icon in the upper left.

m Choose Format > Chart > Chart Type > chart type.

Changing a Chart from One Type to Another
You can change a chart’s type anytime you like.

To change a chart from one type to another:
1 Select the chart.

2 Click Inspector in the toolbar, click the Chart Inspector button, and then choose a 
different chart type from the pop-up menu that appears when you click the chart icon 
in the upper left.

If you switch to a pie chart, the first data point in each series is represented as a wedge. 
See “Pie Charts” on page 214.

If you switch to a scatter chart, each point in the chart requires two values. If the chart is 
based on an odd number of rows or columns, the last row or column isn’t plotted. See 
“Scatter Charts” on page 218.

If you switch to a bar, column, area, or line chart, each series in the new chart 
corresponds to a row or column in the Chart Data Editor.

The Chart Inspector 
button

Choose a chart type from the 
pop-up menu. 2D charts are 
on the left, and 3D charts are 
on the right.
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If you switch to a 3D version of a chart, the Chart Inspector provides controls for 
managing object depth, lighting style, and more. See “3D Charts” on page 219.

Formatting you’ve applied to the chart you’re changing may not be applied to the new 
chart. For example, the color fill attribute of data point elements (bars, wedges, and so 
on) has a different default value for each type of chart. If you’ve changed a column fill 
color and then change the chart to be a bar chart, the fill color change isn’t retained. 

Â Depending on the type of chart, the attributes that may change when you change a 
chart’s type are show value label, value label position, text style, series stroke, series 
shadow, series fill, data point symbol, and data point fill. 

Â Bar/column charts and stacked bar/column charts share attributes except for value 
label position. Also, bar/column charts have separate fills.

Â 3D chart shadows are shared across chart types.

When you change a chart’s type and the new type has some of the same attributes, 
those attributes don’t change. Shared attributes include axes, gridlines, tick marks, axis 
labels, show minimum value, number format, borders, rotation, shadows, and 3D 
lighting style.

You’ll learn more about these attributes throughout the remainder of this chapter.

Editing Chart Data
To edit chart data, open the Chart Data Editor and enter your data by typing it or by 
copying and pasting from Excel, AppleWorks, or other spreadsheet applications.

To open the Chart Data Editor:
1 Select the chart.

2 Click Inspector in the toolbar, click the Chart Inspector button, and then click Edit Data. 

You can also choose Format > Chart > Show Data Editor.

Drag labels to 
reorder them.

Type chart data 
directly into these 
spreadsheet cells.

Click these buttons 
to add another row 
or column for data.
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Copying Data into the Chart Data Editor
Copy data from Excel, AppleWorks, or other spreadsheet applications and paste it into 
the Chart Data Editor.

To use data from another spreadsheet:
1 Open the spreadsheet, and select all the relevant cells.

2 Press Command-C.

3 Click Inspector in the toolbar, click the Chart Inspector button, and then click Edit Data 
to open the Chart Data Editor.

4 Select the top cell in the first column of the Chart Data Editor.

5 Press Command-V.

Working with Rows and Columns in the Chart Data Editor
Change the name of rows and columns and reorder, add, or delete rows and columns.

Here are ways to work with rows and columns in the Chart Data Editor:
m To edit the names of rows and columns or the data in a cell, double-click a cell or a row 

or column label, and then type.

m To reorder rows or columns, drag a row or column label to a new position.

m To add rows or columns, click Add Row or Add Column to place a row above the 
selected row or a column to the left of the selected column. If no row or column is 
selected, the new row or column appears at the bottom or right edge of the 
spreadsheet. (To see the new row or column, you may have to press the Return key or 
the Tab key, expand the Chart Data Editor window, or scroll.)

Alternatively, select any blank cell, type your data, and then press Return. A new row or 
column is automatically created.

m To delete rows or columns, select the row or column label, and then press Delete.

m To choose whether the chart’s data series are represented by rows or columns in the 
Chart Data Editor, click a “Plot Row vs. Column” button.

Formatting General Chart Attributes
You can resize and reposition charts and chart legends. You can add a title to a chart. 
You can format chart elements (fonts, textures, colors, axis and data point labels, and 
tick marks). You can adjust the angle and lighting style of 3D charts. 

Using a Legend
The chart legend describes the meaning of the colors used to plot data points in each 
data series.
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You can show or hide a chart’s legend, and you can reposition it.

Here are ways to work with a chart’s legend:
m To show the legend, select the chart and then select Show Legend in the Chart 

Inspector.

m To edit the labels in the legend, edit the series labels in the Chart Data Editor or select 
the legend and edit the text directly in the legend.

m To format the legend’s text, see “Formatting Titles, Labels, and Legends” on page 213.

m To hide the legend, select the chart and then deselect Show Legend in the Chart 
Inspector.

You can also select the legend and press Delete.

m To move the legend, select and then drag it.

Using a Chart Title
You can add a title to a chart. The title can be formatted.

Here are ways to work with a chart’s title:
m To add a title, select the chart and then select Show Title in the Chart Inspector. Replace 

the placeholder text with your title.

m To format the title’s text, see “Formatting Titles, Labels, and Legends” on page 213.

m To hide the title, select the chart and then deselect Show Title in the Chart Inspector.

Resizing a Chart
You can make a chart larger or smaller by dragging one of its active selection handles 
or by using the Metrics Inspector.

Here are ways to resize a chart:
m Click the chart to select it, and then drag an active selection handle. Active selection 

handles have a black outline.

The selection handles on the top of inline charts are inactive. To resize an inline chart, 
drag the active handles on the lower right side.

m To maintain a chart’s proportions, hold down the Shift key as you drag to resize the 
chart. 

m To resize a chart in one direction, drag a side handle instead of a corner handle. 

m To resize by specifying exact dimensions, click Inspector in the toolbar, click the Metrics 
Inspector button, and then click Metrics. In this pane, you can specify a new width, 
height, and angle of rotation, and you can change the chart’s distance from the 
margins.
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Rotating Charts
There are several techniques for rotating 2D charts. You can’t rotate (or flip) 3D charts. If 
a 3D chart is grouped with 2D charts, you can rotate the group, but only the 2D charts 
in the group will rotate.

Here are ways to rotate 2D charts:
m Select the chart, hold down the Command key, move the pointer toward an active 

selection handle until it changes to a curved, double-headed arrow, and then drag a 
selection handle.

m To rotate a chart in 45-degree increments, press the Shift and Command keys while 
dragging a selection handle.

m Click Inspector in the toolbar, click the Metrics Inspector button, and then drag the 
Rotate wheel or use the Angle controls to set the angle of the chart.

Pie charts can also be rotated using the Chart Inspector (see “Rotating 2D Pie Charts” 
on page 216).

Adding Labels and Axis Markings
Use the Axis pane in the Chart Inspector to format the grid and general look of chart 
axes.

Most charts have two axes, an X-axis and a Y-axis. Depending on the type of chart, data 
points are plotted on one of the axes and data sets are grouped on the other axis. The 
data point axis is called the value axis, and the data set axis is called the category axis.

Showing Axes and Borders
You can show any or all of these elements of a chart: the X-axis, the Y-axis, and chart 
borders.

To show axes and borders:
1 Select a chart.

2 Click Inspector in the toolbar, click the Chart Inspector button, and then click Axis.

Set attributes of labels, tick 
marks, and more.

Select units for values in 
the chart.

Show or hide axes and chart 
borders (2D charts only).

Set the range of values that 
appear on the chart grid.
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3 Choose one or more items from the Axes & Borders pop-up menu to select the items.

A selected item has a checkmark next to it; choose the item again to deselect it.

To format the border stroke and color, select the chart and use the controls on the left 
side of the Format Bar.

Using Axis Titles
You can add a title to a chart’s X-axis and Y-axis. The title can be formatted.

Here are ways to work with an axis title:
m To add an axis title, select the chart and then select Show Category Title from the X-

Axis or Show Value Title from the Y-Axis pop-up menu in the Axis pane of the Chart 
Inspector. Replace the placeholder text with your title.

m To format the title’s text, see “Formatting Titles, Labels, and Legends” on page 213.

m To hide an axis title, select the chart and then deselect Show Category Title from the X-
Axis or Show Value Title from the Y-Axis pop-up menu in the Axis pane of the Chart 
Inspector.

Showing Data Point Labels
You can display data point values on columns, bars, pie wedges, and other chart 
elements of 2D and 3D charts.

To format data point labels:
1 Select the chart.

2 Click Inspector in the toolbar, click the Chart Inspector button, and click Series.

3 Choose Show Value from the Data Point Settings pop-up menu. 

To display the value as a percentage or logarithmic value instead of an absolute value, 
choose Percentage or Logarithmic in the X-Axis or Y-Axis pop-up menu on the Axis 
pane.

For pie charts, you display values as percentages by choosing Show Pie Values as 
Percentages from the Data Point Settings pop-up menu on the Series pane. To display 
the data series name for a wedge, choose Show Series Name from the Data Point 
Settings pop-up menu.

4 Select a label location from the Data Point Settings pop-up menu (for example, Middle 
or Below Right).

Choose a line style.

Choose a line width.

Choose a line color.
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5 Specify the number of decimal places to display by entering a number in the Decimals 
field.

6 To format the data point labels, see “Formatting Titles, Labels, and Legends” on 
page 213.

Formatting the Value Axis
You can set the values and units to be displayed along the value axis, the axis on which 
you read the data point values. For column charts (vertical bars), line charts, and area 
charts, the Y-axis is the value axis. For horizontal bar charts, the X-axis is the value axis. 
For scatter charts, both axes are value axes. (Pie charts don’t have a value axis. To read 
about formatting pie charts, see “Pie Charts” on page 214.)

To format the value axis:
1 Select a chart.

2 Click Inspector in the toolbar, click the Chart Inspector button, and then click Axis.

3 To set the value at the chart origin, type a number in the Minimum field (under Value 
Axis Format).

The Minimum value cannot be higher than the minimum value of your entire data set.

4 To set the highest number displayed on the value axis, type a number in the Maximum 
field.

The Maximum value cannot be lower than the maximum value of your entire data set.

5 To specify the number of axis markings between the minimum and maximum values, 
specify a number in the Steps field.

6 To display the minimum data value on the value axis, select Show Value Labels and 
Show Minimum Value from the Labels, Ticks, & Grids X-Axis or Y-Axis pop-up menu, 
depending on the chart.

7 To specify units for axis values, under Number Format type text in the Prefix or Suffix 
field (or choose a symbol from the pop-up menus).

8 To display values on the value axis as logarithmic values, choose Logarithmic from the 
X-Axis or Y-Axis pop-up menu, depending on the chart. This option is available only for 
2D bar/column charts that aren’t stacked and for line charts. You can’t plot negative 
values on the log axis.

9 To display values on the value axis of stacked charts as percentages, choose Percentage 
from the X-Axis or Y-Axis pop-up menu on the Axis pane.

For pie charts, you display values as percentages by choosing Show Pie Values as 
Percentages from the Data Point Settings pop-up menu.
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Placing Labels, Gridlines, and Tick Marks
The X-Axis and Y-Axis pop-up menus in the Axis pane of the Chart Inspector provide an 
array of options for placing tick marks, labels, and gridlines along the value axis or the 
category axis. The options in these pop-up menus vary depending on the kind of chart 
you select.

For vertical bar charts (column charts), line charts, and area charts, the Y-axis is the 
value axis and the X-axis is the category axis. For horizontal bar charts, the X-axis is the 
value axis. For scatter charts, both axes are value axes. For 3D charts, the X and Y axes 
are the same as their 2D counterparts.

To format axis markings:
1 Select the chart.

2 Click Inspector in the toolbar, click the Chart Inspector button, and then click Axis.

3 To format the X-axis, choose an option from the X-Axis pop-up menu. The menu for a 
column chart looks like this:

4 To format the Y-axis, choose an option from the Y-Axis pop-up menu. Here’s what the 
menu looks like for a column chart:

Place tick marks along 
the X-axis.

Show or hide the 
X-axis gridlines.

Set the text direction for 
the category axis labels.

Show or hide category 
axis labels and title.

Place tick marks along 
the Y-axis.

Show or hide the 
Y-axis gridlines.

Show or hide value 
axis labels.
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Formatting the Elements in a Data Series
You can use a variety of visual effects to enhance the appearance of data series 
elements, such as bars, wedges, and area shapes.

To format data series elements:
1 To format all data series, select the chart. 

To format elements in a single data series, select the chart and then click one of the 
elements in the series.

For all chart types except pie charts, selecting one element (such as a bar) of a series 
automatically selects the full series. For pie charts, you select individual wedges.

2 To fill series elements with specially designed colors or textures, click Inspector in the 
toolbar, click the Chart Inspector button, and then click Chart Colors.

Choose a fill type (for example, 3D Texture Fills) from the first pop-up menu, and 
choose a fill collection (for example, Marble or Wood) from the second pop-up menu. 

To fill all the elements in all the data series, click Apply All. The first fill is applied to 
elements in the first series, the second fill to elements in the second series, and so on.

To fill elements in a single data series, drag the fill to an element (bar, column, and so 
on) in the series. 

3 To adjust the opacity, stroke, shadow, and other graphical attributes of series elements, 
click the Graphic Inspector button. You can also use the Format Bar to control the fill 
color, opacity, and shadow of the entire chart or individual data series in the chart. 

4 To adjust series element colors, see “Filling an Object with Color” on page 147.

5 To use one of your own images to fill series elements, see “Filling an Object with an 
Image” on page 149.

6 To format data point labels, see “Showing Data Point Labels” on page 210.

“Formatting Specific Types of Charts” on page 214 provides instructions for formatting 
charts of particular types.

Formatting Titles, Labels, and Legends
You can change the size and appearance of chart and axis titles, axis labels, data point 
labels, and legends. 

To format the text of labels and legends:
1 Select the text you want to format. 

To format all chart titles and labels, click the chart to select it. If you select the text for 
one data point or axis label, all the text of that kind is also selected. You change the 
font for a chart legend separately.
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2 Use the Format menu, the Font panel, or the Format Bar to format the text. See “Using 
the Format Menu to Format Text” on page 75, “Using the Font Panel to Format Text” on 
page 77, and “Using the Format Bar to Format Text” on page 75 for instructions.

Adding Descriptive Text to a Chart
You can add descriptive text to a chart, such as when you want to provide background 
information for a particular data point.

To add text:
1 Create a text box. See “Adding Text Boxes” on page 100 for instructions.

2 Drag the text box to where you want it on the chart.

3 Type text in the text box.

Optionally group the chart and the text box so the text stays with the chart. Shift-click 
to select both the chart and the text box, and then choose Arrange > Group.

Formatting Specific Types of Charts
Different chart styles offer unique options for formatting their elements.

Pie Charts
For pie charts, Pages plots only the first data point for each data series. If the data series 
are in rows, only the first column is charted; if the data series are in columns, only the 
first row is charted. 

Thus, one pie chart represents a single data set, and each wedge is one element in that 
set. You can chart any data set by moving it to the first row or column.

You can format a pie chart as a whole, or you can format individual wedges. 

Selecting Individual Pie Wedges
If you want to format one or more wedges, you need to select them first.

Here are ways to select pie wedges in a selected pie chart:
m To select a single wedge, click it.

m To select all the wedges, select any wedge and press Command-A.

m To select nonadjacent wedges, hold down the Command key as you select each 
wedge.

m To select a continuous range of wedges, select the first wedge, and then hold down the 
Shift key as you select the last wedge.

Showing Series Names in a Pie Chart
On pie charts, you can display series names.
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To show series names in a pie chart:
1 Select the chart or individual pie wedges.

2 Click Inspector in the toolbar, click the Chart Inspector button, and then click Series. 

3 Choose Show Series Name from the Data Point Label pop-up menu.

4 Choose Inside or Outside from the Data Point Label pop-up menu.

Separating Individual Pie Wedges
To make pie wedges more visually prominent, you can separate them from the pie. You 
can add a series name to separated wedges to further enhance their prominence, as 
“Showing Data Point Labels” on page 210 describes.

Here are ways to separate individual pie wedges:
m To move a single wedge away from the center of a 2D or 3D pie chart, select it and 

then drag it or use the Explode control on the Series pane of the Chart Inspector.

m To separate all the wedges away from the center of a 3D pie chart, select the chart 
before using the Explode control.

Adding Shadows to Pie Charts and Wedges
You can put shadows on individual pie wedges or on the pie as a whole. Putting 
shadows on individual wedges makes it look as if the wedges are on different layers.

When you add a shadow to a pie wedge, it’s a good idea to separate it first. See 
“Separating Individual Pie Wedges” on page 215 for instructions.

To add shadows:
1 Select the chart or individual pie wedges.

2 Click Inspector in the toolbar, click the Chart Inspector button, and then click Series.

3 To add shadows to wedges, choose Individual from the Shadow pop-up menu.

To add shadows to the chart as a whole, choose Group from the Shadow pop-up 
menu.

4 To set shadow attributes, use the Graphic Inspector. See “Adding Shadows” on 
page 144 for instructions.

Set a pie wedge apart
by using the Explode

slider and giving it
a series name.
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Adjusting the Opacity of Pie Charts
You can change the opacity of the chart and individual chart elements, such as the 
legend. See “Adjusting Opacity” on page 146 for more information.

Rotating 2D Pie Charts
You can use various techniques for rotating a 2D pie chart. 

Here are ways to rotate a pie chart:
m Select the chart, click Inspector in the toolbar, click the Chart Inspector button, click 

Series, and then use the Rotation Angle wheel or field.

m Click Inspector in the toolbar, click the Metrics Inspector button, and then drag the 
Rotate wheel or use the Angle controls to set the angle of the chart.

m Select the chart, hold down the Command key and move the pointer toward an active 
selection handle until it changes to a curved, double-headed arrow, and then drag a 
selection handle.

m To rotate the chart in 45-degree increments, press the Shift and Command keys while 
dragging a selection handle or the Rotate wheel.

Bar and Column Charts
You can apply shadows to individual data series or to the entire chart. You can adjust 
the opacity for the chart as a whole or for individual series (but not individual bars). You 
can also adjust the spacing between data sets or individual bars. 

Adjusting Spacing of Bar and Column Charts
You can adjust spacing between individual bars or data sets.

To adjust spacing:
1 Select the chart.

2 Click Inspector in the toolbar, click the Chart Inspector button, and then click Series.

3 To change the space between bars, type a value (or click the arrows) in the “Gap 
between bars” field.

To change the space between data sets, specify a value in the “Gap between sets” field.

The value is the percentage of the bar thickness. Decreasing the space between the 
bars makes them thicker. 

Separate the individual 
bars in the chart.

Separate the data sets 
in the chart.

Add shadows to bars 
or data sets.
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You can also move the pointer near a bar edge until it becomes a double-headed 
arrow, and then drag to make the bars thicker or thinner.

Adding Shadows to Bar and Column Charts
You can add shadows to each bar in the chart or to each group of bars.

If you want to add shadows to individual bars, it’s a good idea to separate them first. 
See “Adjusting Spacing of Bar and Column Charts” on page 216 for instructions.

To add shadows:
1 Select the chart.

2 Click Inspector in the toolbar, click Chart Inspector, and then click Series.

3 To add shadows to individual bars, choose Individual from the Shadow pop-up menu.

To add shadows to each group of bars, choose Group from the Shadow pop-up menu.

4 To set shadow attributes, use the Graphic Inspector. See “Adding Shadows” on 
page 144 for instructions.

Adjusting the Opacity of Bar and Column Charts
You can change the opacity of the chart and individual chart elements, such as the 
legend. See “Adjusting Opacity” on page 146 for more information.

Area Charts and Line Charts
In area and line charts, you can use symbols (circles, triangles, squares, and diamonds) 
to represent data points.

The data points in this 
series are represented 
by squares.

The data points in this 
series are represented 
by triangles.
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Here are ways to format area charts and line charts:
m To format symbols, select a data series (area shape or line), click Inspector in the 

toolbar, click the Chart Inspector button, and then click Series. Choose a symbol from 
the Data Point Symbol pop-up menu.

Use the options on the Symbol Fill pop-up menu to add color or images to the 
symbols. See “Filling an Object with an Image” on page 149 and “Filling an Object with 
Color” on page 147 for instructions.

m To set the line color in line charts, select a line, click Inspector in the toolbar, click the 
Graphic Inspector button, and then use the Stroke controls. See “Changing the Style of 
Borders” on page 142 for instructions.

m To add shadows to line or area charts, select a data series (area shape or line), click 
Inspector in the toolbar, click the Graphic Inspector button, and then use the Shadow 
controls. See “Adding Shadows” on page 144 for instructions.

Scatter Charts
Scatter charts display data differently than the other kinds of charts. They require at 
least two columns or rows of data to plot values for a single data series. To show 
multiple data series, you use additional two-column or two-row pairs. 

Each pair of values determines the position of one data point. The first data value in the 
pair is the X-axis of the point. The second data value is the Y-axis of the point.

Here are ways to work with a scatter chart:
m To format a symbol for a data series, see “Formatting the Elements in a Data Series” on 

page 213.

m To specify axis settings, use the Axis pane of the Chart Inspector. Because both axes of 
scatter charts have values, value axis format settings apply to both X-axis and Y-axis. 
Each axis can have its own number format. See “Formatting the Value Axis” on page 211 
for instructions.

Choose a symbol to 
use for data points.

Fill data point symbols 
with color or images.
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3D Charts
All the chart types except scatter charts can be displayed as 3D charts. 

Here are 2D and 3D versions of a pie chart.

And here are 2D and 3D versions of a line chart.

To define 3D scene settings:
1 Select a 3D chart. 

2 Click Inspector in the toolbar, click the Chart Inspector, and then click 3D Scene.

3 Modify the chart’s viewing angle, lighting style, and depth as desired using the 3D 
Scene controls.

Viewing angle arrows:  Drag an arrow to adjust the angle. Click the vertical arrow and 
drag up or down to move the chart up or down. Click the horizontal arrow and drag 
side to side to move the chart left or right. To move the chart both ways, click the 
intersection of the arrows and drag.

Lighting Style:  Choose an item from this pop-up menu to adjust the lighting effect.

Chart Depth:  Slide this control to increase or decrease the depth of the 3D elements.
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11 Personalizing Documents 
with Address Book Data

This chapter tells you how to use contact information stored 
in Address Book and vCards to personalize letters, envelopes, 
and other Pages documents.

Many Pages templates contain Address Book fields, which provide an automatic way to 
insert names, phone numbers, addresses, and other data into a document. This 
capability lets you create a document, such as a letter or a contract, and then reuse it 
for different individuals.

Using Address Book Fields
You can insert any data you’ve defined for contacts in Address Book into Pages 
documents. You can also insert data from a virtual address card (vCard) that someone 
has sent you. This way you can reuse a letter, contract, envelope, or other document for 
multiple people. This feature is sometimes called mail merge.

When a Pages document contains Address Book fields, contact data is automatically 
inserted into the Address Book fields. Address Book fields identify which Address Book 
or vCard data to insert and where to insert it.

A document can contain two kinds of Address Book fields:

Â A sender field displays information about the document’s distributor. For example, a 
letter can be formatted with a header that uses sender fields to display a company’s 
name, address, and phone number. 
Pages automatically fills sender fields with data from the Address Book card that’s 
designated My Card. But you can use another card to populate sender fields if you 
prefer. 

Â A recipient field displays information for a person who will receive the document. For 
example, you can use recipient fields to insert a person’s name at various locations in 
a letter. 
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When you want to personalize a document for multiple recipients, you specify an 
Address Book group or select multiple individual cards. Pages creates a separate 
version of the content for each contact. In each version of the document, the same 
sender data is used, but the recipient fields are personalized. Personalized results can 
be printed or saved in a new document with a section for each contact.

Using Address Book Fields
 Many of the Pages templates have predefined Address Book fields, but you can also 
create your own Address Book fields, as “Defining Your Own Address Book Fields” on 
page 223 describes.

When an Address Book field has been defined in a Pages document, you can insert 
sender or recipient data for a contact into it.

Inserting Sender Data
You can use Address Book or vCard data to personalize sender fields in your 
documents.

Here are ways to insert sender data:
m Open a document that contains sender fields, such as a letter template. Pages 

automatically inserts data from your My Card in Address Book into the fields. If the card 
doesn’t contain data for any of the sender fields, the field label continues to be 
displayed.

m If you want to use data other than the data on your My Card as sender field data, drag 
an Address Book card or vCard to a sender field in the document. The new card’s data is 
applied to all sender fields in the document.

Inserting Recipient Data for One Contact
You can personalize a document for one recipient by using an Address Book card or a 
vCard.

To insert recipient data for one contact:
1 Open a document that contains recipient fields.

2 Select the contact’s Address Book card or vCard and drag it to a recipient field. 

The contact’s data appears in all the recipient fields throughout the document. If the 
card doesn’t contain data for one of the recipient fields, the field label continues to be 
displayed.

3 Save or print the document if desired.

4 To reuse the document with another contact’s data, select another card and drag it to a 
recipient field. The new data replaces the recipient data inserted in step 2.
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Inserting Recipient Data for Address Book Groups
You can personalize a document for multiple recipients by using an Address Book 
group.

To insert recipient data for all contacts in an Address Book group:
1 Open a document that contains recipient fields.

2 Choose Edit > Merge Address Book Cards, then choose a group or All from the pop-up 
menu.

You can also select a group or All in Address Book and drag it to a recipient field in the 
document.

3 In the dialog that appears, choose New Document from the pop-up menu to create a 
new document that contains a section for each contact in the group. Otherwise, 
choose “Send to printer” from the pop-up menu to print a personalized copy of the 
document for each contact in the group.

If you don’t wish to have missing contact information substituted (for example, a work 
address for a home address), deselect the checkbox.

The original document is not affected by the merge. You can reuse the document for 
additional merges as required.

Inserting Recipient Data for Contacts in Multiple Cards
You can personalize a document for multiple recipients by using multiple Address Book 
cards.

To insert recipient data for contacts in multiple cards:
1 Open a document that contains recipient fields.

2 Select the Address Book cards you want to use, and then drag them to a recipient field.

In the dialog that appears, choose New Document from the pop-up menu to create a 
new document that contains a section for each contact. Otherwise, choose “Send to 
printer” from the pop-up menu to print a personalized copy of the document for each 
contact. 

If you don’t wish to have missing contact information substituted (for example, a work 
address for a home address), deselect the checkbox.

The original document is not affected by the merge. You can reuse the document for 
additional merges as required.

Using Contact Data Not in Address Book or a vCard
You can use contact information that isn’t in Address Book or a vCard for a sender or 
recipient field.
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To insert data you type into Address Book fields:
1 Click an Address Book field and type the data you want to use. The Address Book field 

is replaced by the text you type.

2 Repeat step 1 as required.

3 To retain the version of the document containing all the Address Book fields you’ve 
eliminated, choose File > Save As to save your changed document as a new file.

If you don’t need to save your changes, simply choose Edit > Undo Typing to restore 
the original Address Book fields.

Defining Your Own Address Book Fields
 When you need to modify an Address Book field or create new Address Book fields, 
you use the Merge pane of the Link Inspector.

Creating an Address Book Field
You can add an Address Book field to a document that can later be replaced with 
contact information from Address Book.

To create an Address Book field using the Address Book name:
1 Open a Pages document.

2 Place the insertion point at the location where you want the Address Book field to 
appear.

3 If the Link Inspector isn’t open, choose Insert > Address Book Field. Otherwise, select 
“Enable as an Address Book field” in the Merge pane of the Link Inspector. A 
placeholder for the Address Book field is inserted and highlighted.

4 In the Merge pane of the Link Inspector, open the Type pop-up menu. Choose the 
category that best describes the kind of data you want inserted into the field.

5 From the Field pop-up menu, choose the Address Book field name for the data you 
want to insert into the Address Book field. The placeholder text is replaced by the name 
you choose.

Choose the category 
describing the data 
you want to insert.

Choose the Address Book 
field that contains the data.

Select to make
selected text an

Address Book field.
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6 Click Sender Field or Recipient Field to indicate the kind of Address Book field you want 
to create.

To create a field with a custom name, type and then select text to use as the Address 
Book field name. In the Link Inspector, select “Enable as an Address Book field,” choose 
the appropriate items from the Type and Field pop-up menus, and then click Sender 
Field or Recipient Field.

Changing an Address Book Field
You can disable an Address Book field, change the Address Book data it uses, change it 
from a recipient field to a sender field, and more.

Here are ways to change an Address Book field:
m To disable an Address Book field, click it, and then deselect “Enable as an Address Book 

field” in the Merge pane of the Link Inspector. 

m To change the related field in Address Book, click the Address Book field in your 
document, and then open the Link Inspector. In the Merge pane, use the Type and 
Field pop-up menus to specify the new field.

m To change an Address Book field from a sender field to a recipient field or vice versa, 
click the Address Book field and open the Link Inspector. Click Sender Field or Recipient 
field, as appropriate.

m To delete an Address Book field, click it and then press the Delete key.

m When a document uses an Address Book field that has work, home, or other variations, 
you can quickly switch from one variation to another by choosing Edit > Choose 
Address Label > Home, Work, or Other.

Changing an Address Book Field Label
You can change the label that identifies an Address Book field in a document

To change an Address Book field label:
1 Click the Address Book field whose label you want to change.

2 Type the new label.

3 Select the new label.

4 If the Link Inspector isn’t open, choose Insert > Address Book Field. Otherwise, select 
“Enable as an Address Book field” in the Merge pane of the Link Inspector.

5 In the Merge pane of the Link Inspector, open the Type pop-up menu. Choose the 
category that best describes the kind of data you want inserted into the field.

6 From the Field pop-up menu, choose the Address Book field whose data you want to 
insert into the Address Book field.

7 Click Sender Field or Recipient Field to indicate the kind of Address Book field you want 
to create. 
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12 Printing and Exporting Your 
Document to Other Formats

This chapter describes the various ways you can print and 
share your Pages document. 

In addition to printing or faxing your document, you can share your document 
electronically. By exporting to other document formats, you can collaborate with others 
who use AppleWorks or Microsoft Word. You can also make your document available as 
a PDF file, or attach it to an iWeb blog entry.

Printing Your Document
Pages and Mac OS X provide you with tools to print all or part of your document in 
various layouts and to adjust the color of the printed document.

Setting the Paper Size and Orientation
Before you print, you should make sure the paper size and orientation are set the way 
you want by opening the Page Setup dialog.

To set paper size and orientation:
1 Choose File > Page Setup.

2 In the Page Setup dialog, choose the printer you will use from the “Format for” pop-up 
menu.

3 Choose a standard paper size from the Paper Size pop-up menu. 

If you want to set a custom paper size and you’re using Pages with Mac OS X version 
10.4, go to step 4.
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4 In Mac OS X version 10.4, choose Manage Custom Sizes from the Paper Size pop-up 
menu.

Click the Add (+) button, and then enter values in the Page Size fields.

Either choose your printer’s default margins from the pop-up menu, or enter your own 
values for margins in the Left, Right, Top, and Bottom fields.

If you want to change the custom size’s name, double-click the name in the list and 
enter a new name.

Click OK.

Choose the new paper size you named from the Paper Size pop-up menu, and then 
click OK.

5 Select an orientation option using one of the buttons at the bottom of the Page Setup 
dialog.

Previewing a Document Before Printing It
To make sure everything is laid out the way you expect, it’s a good idea to preview a 
document onscreen before you print it.

To preview a document for printing:
1 Choose File > Print, and then click the Preview button in the Print dialog.

Choose a printer to set 
its default page margins.

Delete a selected 
paper size.

Duplicate a selected 
paper size.

Create a new
custom paper size.

Landscape orientation with 
the top of the page on the 
left side of the paper

Landscape orientation with 
the top of the page on the 
right side of the paper

Portrait orientation
(default for most

templates)
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Preview shows what individual document pages will look like when printed. It doesn’t 
show the effects of some layout options, such as borders. (For more information about 
layout options, see “Setting a Print Layout and Other Options” on page 228.)

2 Select Soft Proof at the bottom-left corner of the Preview window to take your printer’s 
capabilities into account. For example, if you’re printing a color document to a black-
and-white printer, selecting Soft Proof previews the document in black and white.

3 Click Print to print your document directly from the Preview window.

For information about using Preview, see Preview Help. Choose Help > Preview Help 
when the Preview window is active.

Printing Comments
When a Pages document contains comments that you or someone else has added, you 
can print the document with comments showing.

See “Using Comments” on page 68 for more information about comments.

To print comments:
m Make the comments visible by clicking View in the toolbar and choosing Show 

Comments, and then print your document. Printed pages are adjusted to make room 
for the comments. 

Printing All or Part of Your Document
You can print your entire document or a selected page range to a printer your 
computer is configured to access.

To print a full document or a range of pages:
1 Choose File > Print.

2 Choose the printer you want to use from the Printer pop-up menu. If you don't see the 
printer you want to use, choose Add Printer from the Printer pop-up menu.

To learn about adding a printer, search for “Adding a printer” in Mac OS Help. To find 
out where the printer you are using is located, pause with the pointer over the printer's 
name when you are choosing it from the Printer pop-up menu.

3 Type the number of copies you want to print in the Copies field, and then select 
Collated if you want each group of pages to print together in order before printing the 
next group. If you want to print a batch of page 1, then page 2, then page 3, and so on, 
deselect the checkbox.

4 To print the entire document, select All next to Pages.

To print a range of pages, select From, and then type the page number of the first page 
in the From field, and the page number of the last page in the “to” field.

5 Click Print.
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Setting a Print Layout and Other Options
The Copies & Pages pop-up menu in the Print dialog provides several printing options, 
including printing your document in reverse order, printing only odd or even pages, 
printing a cover page (separator page), and more. You can also manage color settings, 
as “Adjusting the Document Color with ColorSync” on page 229 describes.

Here are ways to set print options:
m To print the document pages in reverse order, choose Paper Handling from the Copies 

& Pages pop-up menu, and then select Reverse.

m To print only odd or even pages, choose Paper Handling from the Copies & Pages pop-
up menu, and then select “Odd numbered pages” or “Even numbered pages.”

m To print several pages on a single sheet of paper, choose Layout from the pop-up menu 
below the Presets pop-up menu.

Choose the number of pages you want to appear on each sheet from the “Pages per 
Sheet” pop-up menu. Select a layout direction, and then choose the line style you want 
to separate each printed page from the Border pop-up menu.

m To print double-sided, choose Layout from the pop-up menu below the Presets pop-up 
menu, and then select a binding option.

Long-Edge Binding:  Prints the pages to be bound lengthwise.

Short-Edge Binding:  Prints the pages to be bound on the short side of the paper.

Not all printers can print double-sided. Check the documentation that came with your 
printer.

Print left to right first, 
then down.

Print pages right to left first, 
then down.

Print pages top to bottom 
first, then across to the right.

Print pages top to bottom 
first, then across to the left.

See a preview of 
your layout.

Select double-sided 
printing options.

Choose a line style to 
separate the printed pages 
on each sheet.
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m To save your printing options as a preset that you can use later instead of respecifying 
options, choose Save As from the Presets pop-up menu in the Print dialog and then 
type a name for the preset.

To use the same settings in the future, choose the preset’s name from the Presets pop-
up menu.

Adjusting the Document Color with ColorSync
You can make printed documents lighter, darker, or sepia-toned, or add other effects by 
adding a Quartz filter to your printer output. The filter uses ColorSync technology to 
modify the printed document without modifying the document itself. 

Not all printers can print in color. Check the documentation that came with your 
printer.

To adjust document color:
1 Choose File > Print.

2 Choose ColorSync from the pop-up menu below the Presets pop-up menu in the Print 
dialog.

3 Choose an option from the Color Conversion pop-up menu.

Standard:  Uses the default settings in Pages to control the color management of the 
printed document.

In Printer:  Lets the printer you’re using control the color management of the printed 
document.

4 Choose an option from the Quartz Filter pop-up menu.

To see a preview of the printed document with the Quartz filter you have chosen, click 
Preview.

After you have selected the Quartz filter you want, you can save this setting as part of 
your preset. 

For more information about ColorSync and Quartz filters, see ColorSync Utility Help by 
opening the ColorSync application (located in Applications/Utilities), and then 
choosing Help > ColorSync Utility Help.

The ColorSync Utility icon
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Exporting to Other Document Formats
You can share your Pages documents across different platforms by exporting them to 
other formats, such as Microsoft Word, PDF, or plain text. You can also save a document 
so it can be opened using Pages in iWork ’05 and iWork ’06.

Exporting a Document for Use in Another Application
You can export your Pages document using file formats such as PDF, Microsoft Word, 
RTF, and Plain Text.

To export a document to another file format:
1 Choose File > Export.

2 Choose a format for the document and click Next.

3 Type a new name for the document.

4 Choose where you want to save the document.

5 Click Export.

You can export a Pages document in these formats:

Â PDF:  PDF files can be created using an image quality of good, better, or best. When 
the image quality is set to best, the resolution of images isn’t scaled down. When the 
image quality is set to better, images are downsampled to 150 dpi. When the image 
quality is set to good, images are downsampled to 72 dpi. Images without an alpha 
channel are JPEG compressed with a compression level of 0.7 at the good setting 
and 0.9 at the better setting.
When you export a Pages document on a computer with Mac OS X version 10.4 or 
later, hyperlinks are exported. Hyperlinks are created in the PDF document for table 
of contents entries, footnotes and endnotes, webpages, email messages, and 
bookmarks.

The PDF file, which preserves font characters used in the document, can be viewed 
or printed in Preview, viewed or printed in Safari on Mac OS X version 10.4 or later, 
and edited with a PDF application.

Â Word:  Word files can be opened and edited in Microsoft Word on a Mac OS X 
computer or on a Windows computer.
Because of text layout differences between Microsoft Word and Pages, an exported 
Word document may contain a different number of pages than its Pages counterpart. 
Also, special typographic features and some graphics may not display as well, 
particularly those using transparency (alpha channels). Tables and column layouts 
may not export identically, and charts created in Pages appear as static images.

Â RTF:  RTF files retain most of the text formatting and graphics. You can open and edit 
RTF files in a word processor.
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Â Plain Text:  Plain text files can be opened and edited in a text editing application, 
such as TextEdit. However, exporting to a plain text file removes all your formatting, 
and images aren’t exported.

Saving a Document as a Previous iWork Version
You can save a Pages document so that users with an older version of iWork can open 
and use the document.

To save a document in a previous iWork version:
1 Choose File > Save As, or choose File > Save.

2 Type a new name for the document in the Save As field.

3 Choose where you want to save the document.

4 Select “Save a copy as”, and choose the iWork version from the pop-up menu.

5 Click Save.

Users of Pages in iWork ’05 can open and use the document, but won’t have access to 
the new iWork ’08 features. For example:

Â Address Book fields and comments are removed.
Â Endnotes are converted to footnotes.
Â An image masked with a shape gets a rectangular mask.
Â A curved or polygonal shape isn’t editable.
Â A custom shape is converted to a shape.
Â Formulas in table cells are removed, and the last calculated value is displayed.
Â Number formatting isn’t supported, so the last calculated value is displayed with the 

formatting directly applied.
Â 3D charts are converted to 2D charts.

Users of Pages in iWork ’05 and iWork ’06 can open and use the document, but won’t 
have access to the new iWork ’08 features. For example:

Â Change tracking isn’t supported, so all changes will be accepted.
Â Headers and footers of a page layout document will not export if hidden.
Â Different column settings within linked text boxes aren’t supported, so the first linked 

text box’s settings will be used.
Â Page layout documents will be exported as floating objects.
Â Comments on text within a shape or table will be moved to the top level (on the 

shape or table). Comments on a header or footer are dropped.
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Sending a Pages Document to iWeb
If you use (or intend to use) iWeb to create a website, you can send a Pages document 
directly to your iWeb blog or podcast. The document becomes an attachment that your 
website visitors can download.

To send a document to iWeb:
1 Make sure you have iWeb ’08 or later installed.

2 Open your Pages document and choose File > Send to iWeb > PDF or File > Send to 
iWeb > Pages Document.

PDF creates a PDF version of your document.

Pages Document creates an archive version of your document.

3 If iWeb wasn't open, it opens, and you can choose a new or existing blog or podcast to 
attach your document to. If you have only one blog or podcast, the document is 
attached to it.

When you publish your website, visitors who subscribe to your blog or podcast will 
automatically get the latest attachments sent to their iTunes library (PDF publish only).

For more information about using iWeb to design and publish webpages, open iWeb 
and choose Help > iWeb Help.
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13 Designing Your Own 
Document Templates

This chapter is for designers who want to create their own 
document templates.

This chapter assumes you are already familiar with the design and formatting features 
of Pages described in earlier chapters.

Designing a Template
The templates that come with Pages provide ideas for page designs as well as the look 
of charts, tables, and text. You can modify the following attributes of these templates to 
create your own templates:
Â Page orientation
Â Page layout and section formatting
Â Page margins
Â Page numbering
Â Background graphics (watermarks)
Â A variety of text styles, including body text, headers, footers, callouts, and so on
Â Table of contents styles
Â Bullet and numbering styles
Â Object fills and line styles for objects
Â Chart colors and styles
Â Look of tables
Â Additional template page designs

While creating your own template can be as simple as adding your company logo to an 
existing template, you can also add images, change placeholder text, or define new 
text styles. Or you can start with a blank document and create your own template.
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Step 1:  Set Up the Document
The first step in setting up a document as a template is to set up the overall size and 
shape of the document.

Here are ways to set up general document attributes:
m Set paper size and orientation. 

Consider the paper size and orientation that will be used for the finished document. 
For example, if you are creating a template for envelopes, make sure that you have 
selected the correct envelope size (or created a custom size) before you proceed with 
further document design. To learn about setting the paper size and orientation, see 
“Setting the Paper Size and Orientation” on page 225.

m Set page margins.

Define the body text area and header and footer text areas. If your document will be 
bound, you can set different margins for right- and left-facing pages. Document 
margins are set in the Document Inspector. For more information, see “Setting 
Document Margins” on page 42.

m Set up the format of headers and footers.

Define recurring text and graphics you want to appear at the top or bottom of pages in 
the document. See “Using Headers and Footers” on page 49 for instructions.

m Place master objects.

Add watermarks, logos, or other background images so they appear in the same spot 
on every page of your document. See “Using Master Objects (Repeated Background 
Images)” on page 57 for details.

m Add alignment guides.

Create alignment guides to help place floating objects in the same position on 
different pages. See “Creating New Alignment Guides” on page 140 for instructions.

Step 2:  Define Default Attributes
A template must have default values defined for the following document elements:
Â Paragraph, character, and list styles
Â Table of contents attributes
Â Text box attributes
Â Shape attributes
Â Table attributes
Â Chart attributes
Â Imported graphics attributes
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You can customize any of these for the template you are creating, or you can use the 
defaults that already exist in the template you started with (including the Blank and 
Blank Canvas templates).

Defining Default Styles
If you don’t find a paragraph, character, or list style with exactly the look you want in 
the Pages templates, you can modify an existing style or create a new style.

For instructions, see “Modifying and Creating New Paragraph Styles” on page 123, 
“Modifying and Creating New Character Styles” on page 127, and “Modifying and 
Creating New List Styles” on page 129.

Defining Default Table of Contents Attributes
You can include a formatted table of contents in your Word Processing template. See 
“Using a Table of Contents” on page 58 for information.

Defining Default Attributes for Text Boxes and Shapes
The default attributes of text boxes and shapes determine their color, size, and 
orientation when they’re first inserted on a page.

To define default text boxes and shapes:
1 Place a floating text box and a shape on the page. To read about placing a floating text 

box, see “Adding a Floating Text Box” on page 100. To read about placing a floating 
shape, see “Using Floating and Inline Objects” on page 134.

2 Type text into the text box and shape, select the text, and then set its attributes. To 
read about setting text attributes, see “Formatting Text Size and Appearance” on 
page 75.

3 Select the text box and the shape, and then set attributes for both. See “Modifying 
Objects” on page 141 and “Filling an Object with Color” on page 147 for more 
information.

Line length and orientation can’t be defined within a template. Line attributes such as 
color, thickness, and opacity must be set separately.

4 Set text wrapping using the Wrap Inspector. To read about setting text wrapping, see 
“Wrapping Text Around an Object” on page 110.

5 Select the shape, and then choose Format > Advanced > Define Default Shape Style.

Select the text box, and then choose Format > Advanced > Define Default Text Box 
Style.

6 Delete the text box and shape from the page.
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Defining Default Attributes for Tables
You can set up such attributes as number of rows and columns, line styles and colors, 
text styles, and shadows for the default table.

A table consists of distinct formatting areas, including the header row, header column, 
inside borders, and outside borders. To set default table attributes, you must apply each 
attribute to an entire formatting area. For example, if you change the formatting of one 
cell in a header row, the change will not be saved as part of the default table style; you 
need to change the formatting of all the cells in the header row.

To set default table attributes:
1 Place a table on the page. “Adding a Table” on page 168 tells you how.

2 Select the table, and then set its attributes.

See “Resizing a Table” on page 170 if you want to change the table’s dimensions.

See “Working with Rows and Columns” on page 183 to learn about adding and 
removing columns and rows and creating header rows and columns.

See “Working with Table Cells” on page 186 for information about splitting and 
merging table cells, resizing them, and formatting their borders.

See “Formatting Cell Values” on page 178 to learn about options for formatting cells 
that will contain numbers.

See “Adding Images or Color to Cells” on page 182 if you want to add graphics to the 
table.

3 Set text wrapping around the table. See “Wrapping Text Around an Object” on 
page 110 for instructions.

4 Choose Format > Advanced > Define Default Table Style.

5 Delete the table from the page.

Defining Default Attributes for Charts
For charts, you can set the default chart type (the type of chart that appears when you 
choose Insert > Chart) and also the default look of each chart type. Default attributes 
must be set individually for each chart type.

To set default chart styles and placement:
1 Place a chart on the page. See “Adding a Chart” on page 204 for instructions.

2 Select the chart, and then set its attributes. 

See “Selecting a Chart Type” on page 204 to learn how to specify a chart type.

See “Formatting General Chart Attributes” on page 207 to learn how to resize a chart, 
rotate it, and set other attributes that charts have in common.

See “Formatting Specific Types of Charts” on page 214 to learn how to format pie 
charts, bar charts, and other chart types.



Chapter 13    Designing Your Own Document Templates 237

 

3 Set the text wrapping around the chart. See “Wrapping Text Around an Object” on 
page 110 for instructions.

4 Repeat steps 1 through 3 for each chart type.

5 Select each chart, one at a time, and then choose Format > Advanced > Define Default 
Style for chart type Chart.

6 Select the chart type that you want to be the first chart that appears when you choose 
Insert > Chart, and then choose Format > Advanced > Make chart type the Default 
Chart Type.

7 Delete the charts from the page.

Defining Default Attributes for Imported Images
For imported graphics, you can set default shadows, opacity, and outline (stroke) color.

To set default image attributes:
1 Place an image on the page. See “Importing an Image as a Floating Object” on 

page 158 and “Importing an Image as an Inline Object” on page 158.

2 Select the image, and then set its attributes. 

See “Adding Shadows” on page 144 to learn how to add a shadow.

See “Adjusting Opacity” on page 146 to learn how to adjust transparency.

See “Changing the Style of Borders” on page 142 for information about borders around 
imported images.

See “Adding a Reflection” on page 145 for information about adding reflection to 
imported images.

See “Framing Objects” on page 143 for information about adding graphical borders 
around imported images.

3 Set text wrapping around the image. See “Wrapping Text Around an Object” on 
page 110 for instructions.

4 Choose Format > Advanced > Define Default Image Style.

5 Delete the image from the page.
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Step 3:  Create Placeholder Text and Media Placeholders
Placeholder text and media placeholders model the look of the finished document. 
They can also provide instructions for the person using the template.

Creating Placeholder Text
You can modify placeholder text that already exists in a template, or you can create 
your own text.

Here are ways to create placeholder text:
m To edit existing placeholder text, select it, and then choose Format > Advanced > 

Enable Placeholder Text Authoring. After editing the text, choose Format > Advanced > 
Disable Placeholder Text Authoring.

m To create placeholder text from scratch, type some text on the page, and then format it 
the way you want.

Select the text in blocks, as you would like template users to be able to edit it, choosing 
Format > Advanced > Define as Placeholder Text for each block.

When selecting blocks of text, be careful not to select the final paragraph break 
character. Doing so will cause the entire paragraph to be deleted when the user begins 
typing in the placeholder text, and the new text will take on the attributes of the 
following paragraph. To see the paragraph break character as you work, click View in 
the toolbar, and then choose Show Invisibles.

To remove placeholder text, select it, and then press the Delete key.

Creating Media Placeholders 
When you drag your own image, audio file, or movie to a media placeholder, your 
media is automatically sized and positioned for you. You can easily replace media in the 
media placeholder by dragging a new file to it; you don’t have to delete the old file 
first.

To create a media placeholder:
1 Add an image, movie, or audio file to the document.

See “Working with Images” on page 158, “Adding a Sound File” on page 164, and 
“Adding a Movie File” on page 165 for instructions.

2 Select the imported object and move it to the location where you want it to be in the 
document, as “Moving Objects” on page 137 describes.

3 Format the imported object, as “Moving Objects” on page 137 describes.

4 Select the object, and then choose Format > Advanced > Define as Media Placeholder.

To delete a media placeholder, select it, and then press the Delete key.
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Step 4:  Add Sections to Your Template
You can make your template expandable so that Word Processing template users can 
simply insert additional sections by using the Pages button in the toolbar as described 
in “Adding New Template Pages” on page 72.

To create template sections that users can add:
1 Design a layout of one or more pages, inserting a section break at the beginning and 

end of the layout.

2 Choose Format > Advanced > Capture Pages. A dialog opens.

3 Type a name for the template section.

4 Choose the number of pages you want to include in the page design from the Include 
pop-up menu.

5 Click OK.

6 Delete the pages from your template if you don’t want them to be part of the initial 
template.

To rearrange, rename, or delete template sections you have created, choose Format > 
Advanced > Manage Pages. A dialog opens.

Select a section. Double-click the name and type new text to rename it. Click the up or 
down arrow buttons to change a section’s position in the list. Click the Delete (–) 
button to remove the section. Click Done when you are finished.
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Step 5:  Save a Custom Template
You can save your new template so that it appears in the Template Chooser. 

When a user chooses the template to create a new document, the new document 
opens in exactly the same state as when you saved it. That means you can choose to 
leave the Styles drawer open or closed, leave invisibles, rulers, and layout marks visible, 
and so on.

To save a custom template:
1 Choose File > Save as Template.

2 Type a name for the template.

3 Specify a folder in which to save your template.

By default, it will be saved in your home folder in Library/Application Support/iWork/
Pages/Templates/My Templates/ and it will appear in the My Templates pane of the 
Template Chooser.

To save the template in another location in your home folder, go to Library/Application 
Support/iWork/Pages/Templates/ and create a new folder. The folder name is used as 
the template category in the Template Chooser.

4 Click Save.

To delete a custom template, in the Finder navigate to the folder in which you saved 
the template, and drag the template to the Trash. 
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